Allow acces to SQL server from separate computer

Hi,

SQL Server is installed on a Windows 7 computer (MyServer).
An application connects to the database via a UDL-connection. This works fine if the user logs in directly onto MyServer.
Another computer in the network also needs access to the same database. For this purpose a shortcut is placed on the desktop to the application exe on MyServer.
But somehow the user cannot connect to the SQL Server database. Although when a UDL is placed on the desktop on MY2PC, than the connectiontest can be established when using user "sa".

TCP/IP is Enabled on MyServer (via clicofg.exe and in the configuration manager).
Firewalls on both computer have temporarly been shut down for testing purposes.

What setting must be set in order to give USER2 on MY2PC full access to the database?
Stef MerlijnDeveloperAsked:
Who is Participating?
 
mozculluConnect With a Mentor Commented:
1. connect with you application to the SQL Server
2. open SQL Server managemement studio and open a new query
3. run the following query:

use master
select * from sysprocesses where spid>50

4. find the process that is run by your application and check the loginname column.
5. if loginname column is a windows user like domain\username or computer\username then it is a trusted connection

it there is a trusted connection and your pc's are working without domain (i.e. workgroup mode) then you have to create a USER2 user on the server computer with the same password like in MY2PC and give necessary rights to this user on SQL Server. After doing this it should work.

if you are using a domain user on MY2PC, just give necessary rights to this user on SQL Server.
0
 
mozculluCommented:
check sql configuration manager and network settings of SQL if it is open to network or localhost only
0
 
Stef MerlijnDeveloperAuthor Commented:
How do I do that?
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

 
mozculluCommented:
if you dont know how to do that, below article can help you:

http://msdn.microsoft.com/en-us/library/ms165718.aspx
0
 
Stef MerlijnDeveloperAuthor Commented:
This was already done.
"TCP/IP is Enabled on MyServer (via clicofg.exe and in the configuration manager)."
0
 
mozculluCommented:
how about ip addresses. is the public ip address of the pc enabled for tcp connection of SQL?
0
 
Stef MerlijnDeveloperAuthor Commented:
Don't know? Where can I find that setting?
0
 
mozculluCommented:
the same window (TCP/IP Properties) IP Adresses tab.
0
 
mozculluCommented:
if everything is OK. also check the below

on sql management studio right click on the server. click connections tab and make sure that Allow remote connections to this server is checked.
0
 
Stef MerlijnDeveloperAuthor Commented:
In the attachment you find the whole errormessage.
SQL-Server-error.png
0
 
mozculluCommented:
your sql server may be running fine but your application connection should be cheked also. if it is running tursted connection then user2 on the second computer should be given right on sql server.
0
 
Stef MerlijnDeveloperAuthor Commented:
How can I check if is is running as a trusted connection?
0
 
Stef MerlijnDeveloperAuthor Commented:
Is this also neccessary when SQL Server is in Mixed Mode?
0
 
Stef MerlijnDeveloperAuthor Commented:
Thank you very much.
0
All Courses

From novice to tech pro — start learning today.