[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 351
  • Last Modified:

Issues with Desktop Wallpaper GPO on Windows XP 64bit

For quite a while we have had a GPO that sets the desktop wallpaper on all domain PCs. A few months ago we needed to install 64bit XP machines. These machines have the same GPO applied to them but will not set the desktop wall paper. By running rsop and gpresult I can see that the GPO is being applied to the machines, but the wallpaper is not being set. The GPO works perfectly with 100s of 32bit XP machines.
0
trineit
Asked:
trineit
  • 3
  • 3
2 Solutions
 
johnb6767Commented:
HKEY_CURRENT_USER\Control Panel\Desktop\WallPaper

Is that value present?
0
 
johnb6767Commented:
And hkcu\software\microsoft\windows\current version\policies\system\wallpaper?
0
 
trineitAuthor Commented:
hkcu\software\microsoft\windows\current version\policies\system\wallpaper is set to \\server\share\background.jpg - Which is the correct location

HKEY_CURRENT_USER\Control Panel\Desktop\WallPaper is set to:
C:\Documents and Settings\user\Local Settings\Application Data\Microsoft\Wallpaper1.bmp - "user" was the temp account that was used to create the default profile.

Shouldn't HKEY_CURRENT_USER\Control Panel\Desktop\WallPaper be controlled by the GPO?
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
johnb6767Commented:
"Shouldn't HKEY_CURRENT_USER\Control Panel\Desktop\WallPaper be controlled by the GPO?"

No, that's what the POLICIES keys are for. That's the USER setting that gets modified when a user changes it on their own..... GPO settings are primarily stored in the 4 POLICIES keys.

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies
HKEY_CURRENT_USER\Software\Policies
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies
HKEY_LOCAL_MACHINE\Software\Policies
0
 
trineitAuthor Commented:
Found the following Registry entry only existed on the 64bit machines once I removed it or set the value to 1 the issue was resolved.

HKLM\software\microsoft\windows\currentversion\policies\explorer ForceActiveDesktopOn
0
 
trineitAuthor Commented:
john6767 lead me to the correct area but was resolved by myself.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now