• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1327
  • Last Modified:

Second Exchange 2010 server, EWS urls?

Site A: Exchange 2010 with externally avail Autodiscover and OWS urls and certs.
Site B: Exchange 2010, configured much later after Site A, unsure of urls.


This morning I ran into an issue with users on the Site B server not being able to set OOF with going thru OWS.  In researching this problem I discovered that my Autodiscover url might not be correct.  I tried Googling for half an hour and came up with bumpkiss.  So what would the correct EWS urls be if this second server is not externally accessable from the interwebs?

Site A:

Internal OWA url: https://internetmail.domainname.com/owa
External OWA url: https://internetmail.domainname.com/owa

Availability Service URL: https://internetmail.domainname.com/ews/exchange.asmx
OOF url: https://internetmail.domainname.com/ews/exchange.asmx
OAB url: https://internetmail.domainname.com/OAB/68261e53-3fa6-46do-894b-8c2db4e3d9cc/
Unified Message Service URL: https://internetmail.domainname.com/ews/um2007legacy.asmx
Auth Package: Unspecified
Exchange Control Panel URL: https://internetmail.domainname.com/ecp

Site B:


Availability Service URL: https://servername.domainname.com/ews/exchange.asmx
OOF URL: https://servername.domainname.com/ews/exchange.asmx
OAB URL:  https://internetmail.domainname.com/oab/68261e53-3fa6-46d0-894b-8c2bd4e3d9cc
Unified Message Service URL: https://servername.domainname.com/ews/um2007legacy.asmx
Auth Package: Unspecified




This info was gleened from the Test Autoconfiguration tool in Outlook 2010 from a user on the site A server and a user from the site B server.  Isn't the missing internal/external OWA urls a problem?  Users from site B CAN successfully login to OWA.  Also shouldn't the other URL's match the Site A server?
0
Ben Hart
Asked:
Ben Hart
  • 5
  • 3
1 Solution
 
sumit_aroraCommented:
First OWA has to do nothing with EWS. Your configuration is fine. tell us the error you are getting while you try to set up OOF in OWA. And on site B whats the Owa URLS
0
 
Ben HartAuthor Commented:
"unable to open out of office assistant.  server is unavailable"

The forum posts and blog notes I found on that all seemed to reference issue with Autodiscover. Which led me to run that Test Autoconfiguration tool from outlook.

There were no OWA urls listed for Site B, checking the owa site properties in EMC on that particular server the internal url is "https://servername.domainname.com/owa" the External field is empty.
0
 
sumit_aroraCommented:
you dont required External URL for OWA on the non internet facing Site.

Try this: from site B, take a user from site B and ON CAS server  in site B, try to login to and using https://Localhost/OWA/ email address of user, and try to set OOF if this work in site b which means issue is with site A cas server

try to recreate the OWA virtual directory on site A. You have to set URL again as will remove all the changes that you have made on OWA virtual directory. you need to see external URL only as https://internetmail.domainname.com/owa

===================================
remove-owavirtualdirectory
new-owavirtualdirectory

 
0
Configuration Guide and Best Practices

Read the guide to learn how to orchestrate Data ONTAP, create application-consistent backups and enable fast recovery from NetApp storage snapshots. Version 9.5 also contains performance and scalability enhancements to meet the needs of the largest enterprise environments.

 
Ben HartAuthor Commented:
Ok I have a test account I moved from Site A to Site B.. VNC'd into Site B's server and browsed to
https://localhost/owa/ttesterson@domainname.com

Open in new window


I was directed to an OWA login page.. entered credentials and was redirected to an error page stating
 The Outlook Web App address https://localhost/owa is out of date. 
To get the correct address, contact your helpdesk.  

Open in new window


Also does ti make any difference if testing autoconfiguration in Site B still does not show an External nor Internal OWA url in the results pane?
0
 
sumit_aroraCommented:
I am sorry, i looked at the comment of urs...

Autodiscover and OWS urls and certs in the primary comment..


here ows is EWS not OWA.
=========================================
Now.. u dont required the external URLon EWS ......

Please run this command on site A CAS server and share the Output..

Test-OutlookWebServices -Identity:holly@contoso.com

user should from Site b
0
 
sumit_aroraCommented:
u dont required the external url on the Non-internet site for EWS aor autodiscover
0
 
Ben HartAuthor Commented:
It *might* be fixed.  I had a user from SiteB tell me yesterday that she could no longer login via OWA.  I tried with her account and a test account I have from that site and indeed it did not work.  Outlook Web Services are unavailible, please try again later" (basically)

So after trying a few different things I changed the internalURL to 'https:\\servername.domain\owa' then set the authentication from Forms to Integrated Windows and today the tests work and she is able to login.

0
 
sumit_aroraCommented:
any update on this
0

Featured Post

Vote for the Most Valuable Expert

It’s time to recognize experts that go above and beyond with helpful solutions and engagement on site. Choose from the top experts in the Hall of Fame or on the right rail of your favorite topic page. Look for the blue “Nominate” button on their profile to vote.

  • 5
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now