?
Solved

SBS 2008 Internal website trouble

Posted on 2011-10-17
6
Medium Priority
?
927 Views
Last Modified: 2012-05-12
Hello all!
 I'm having trouble with my SBS 2008 server but feel like I'm not too far from where I need to be.  

Scenario - SBS Sharepoint internal website was attached to a new database and is working both internally and externally with exception of the "Internal Website" link form within RWW.  In trying to "fix" this in IIS Manager, I have now broken the link to access http://companyweb internally.  However, http://companyweb/default.aspx when typed locally into a browser window will allow me to access the website internally.  

Fact - Sharepoint internal website (companyweb) is up and working  -- but only when typing http://companyweb/default.aspx into a browser.  Typing http://companyweb into a browser renders an http 404 error.  

I think I've fouled up my bindings somehow and while I have another SBS 2008 server to compare to, I still can't quite make this work.    Ultimately, I need for http://companyweb to bring up my internal company website when typed in a browser on a local machine as well haveing the internal company website appear when clicking on the "Internal Website" from RWW.  Any help is greatly appreciated!

- Chris in SA
0
Comment
Question by:chrisdodds
  • 5
6 Comments
 

Author Comment

by:chrisdodds
ID: 36981739
Furthermore, I wonder if my issue is a DNS problem? Somebody -- HELP!
0
 

Expert Comment

by:sback
ID: 36982087
Since you are able to bring the site up by using the url http://companyweb/default.aspx you do not have a DNS issue.  Did you by chance change the documents tab within IIS?
0
 

Assisted Solution

by:chrisdodds
chrisdodds earned 0 total points
ID: 36983010
Okay.  I have spent all day working on this and I have it almost working.  From the outside, I can hit my https://remote.michaelgimber.com to log into the RWW.  From there, whenever I click on the "Internal Website" link, I am automatically prompted for a user name and password but I am then redirected to the http://mgi-2k8/default.aspx which then times out and gives me a 404 error.  However, once authenticated, I can manually type this address https://remote.michaelgimber.com:987/default.aspx into a browser window to bring up the internal company website.  The site is up and working, but the link is not pointing to the correct location.  I installed SBS 2008 updtae rollup 5 and I have rebooted my server but it didn't solve anything that I hadn't solved already.  I just need to figure out where this "Internal Website" is linked to the internal servername so I can modify it to point to my FQDN externally.  I am so close to having this solved.... HELP!
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 

Assisted Solution

by:chrisdodds
chrisdodds earned 0 total points
ID: 36983691
Okay, I have re-summarized my issue and here it is, more concisely written.  I am posting this in various forums in hopes of finding help.

I have an SBS 2008 server that has been pretty trouble free for the most part since it was implemented in February of this year (2011). However, due to a Trend Micro AV install that somehow or other did crazzy things to the internal datase, I had to create a new instance of a SQL database and use that for the internal website. No worries. I was able to manage that and all has been fine until recently I was instructed that the employees would like the functionality of accessing the companywide calendar by using Sharepoint in the RWW.

Here's where I'm at.

Locally - From either a client workstation or the server on the INTERNAL network, I can type in "http://companyweb" and view the contents of the internal website. Everything works as it should.
 
Externally (or internally for that matter) - From the Internet I can type in "https://remote.michaelgimber.com" to bring up my login for the RWW. With the proper credentials, I can successfully login and view 3 links - Email (through OWA which is working), Connect to a computer (which is also working), and the link for the Internal Website - which is almost working. If I click on the Internal Website link, I am immediately prompted to enter in a username and password and it appears as though I am going to be allowed to view the internal company website through the RWW. However, once I am authenticated, the window that pops up redirects me to "http://mgi-2k8/default.aspx" and I am suddenly shown a window that tells me that the webpage cannot be shown and I have the option to trouboleshoot connectivity, etc. From within this pop up browser window I cannot modify the url in the adress bar. However, if I close this window and open up a new browser window I can manually type "https://remote.michaelgimber.com:987/default.aspx" into the address bar of the browser window and I can then view the internal website and company calendar and all other links associated with this site. Furthermore, on a machine that I do NOT log into the RWW but simply type in the "https://remote.michaelgimber.com:987/default.aspx", I am prompted with a login that will also allow me to view the internal website securely without having to login otherwise. And yes -- the server cert is installed properly on my server and on my workstations both internally and externally and it is NOT a self-signed certificate, but rather a cert purchased from a 3rd party vendor.

My question is -- where do I need to look to find the pointer that is redirecting my Internal Website link in RWW (from outside) to an internal domain name as opposed to resolving to the external FQDN? I have another SBS 2008 install that I have looked through and tried to match all IIS settings and I am soooooooo close, but I just don't know where else to look to modify this pointer. I thought perhaps in DNS, but I can't find anything that looks like it is pointing to an incorrect site. I'm wondering if somehow there is something still bound in IIS to the old database that needs to be modified? Any help is greatly appreciated. Thanks.
 
- Chris in San Antonio
0
 

Accepted Solution

by:
chrisdodds earned 0 total points
ID: 36985451
I solved this shortly after I posted with the help from this Experts Exchange post (http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/MS-SharePoint/Q_24291608.html) and here's how --

Process:

Logon to the SharePoint 3.0 Central Administration site (Start --> Programs --> Administrative Tools --> SharePoint 3.0 Central Administration

Click on Operations.

Under the Global Configuration section, click on "Alternate cccess mappings"

You will see a list of all your SharePoint sites.

To the far right of the menu bar you will see a dropdown list labeled 'Alternate Access Mapping Collection:'

Click the drop down and select Change alternate access mapping collection.

Select the site you want to add the Alternate Aaddress Mapping to.

Click "Edit Public URLs" in the menu bar. This will open a page showing your URL in the zone it is defined in.

You can see there are several options to enter a value ( Default, Internet, Intranet, Custom, and Extranet). Enter the full URL using https: into one of these areas. I was able to enter it into any one of those fields and got the same behavior, but I chose Internet for mine since it was a problem of the Internal Website link redirecting to the incorrect location from the RWW.  Click Save.  You should now be able to view your site using either http: or https:.

This information is apparently not too widely disseminated because I've seen many folks with similar issues but no resolutions.  Hopefully this document will serve to help other admins troubleshoot and resolve similar issues more quickly than this has taken me.
0
 

Author Closing Comment

by:chrisdodds
ID: 37013462
There was only a single comment posted by anybody other than myself and the solution was found buried deep in the heart of an Experts Exchange post.  This took me the better part of a 12 hour day to resolve.
0

Featured Post

Veeam Disaster Recovery in Microsoft Azure

Veeam PN for Microsoft Azure is a FREE solution designed to simplify and automate the setup of a DR site in Microsoft Azure using lightweight software-defined networking. It reduces the complexity of VPN deployments and is designed for businesses of ALL sizes.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you don't have the right permissions set for your WordPress location in IIS, you won't be able to perform automatic updates. Here's how to fix the problem.
A quick step-by-step overview of installing and configuring Carbonite Server Backup.
this video summaries big data hadoop online training demo (http://onlineitguru.com/big-data-hadoop-online-training-placement.html) , and covers basics in big data hadoop .
Exchange organizations may use the Journaling Agent of the Transport Service to archive messages going through Exchange. However, if the Transport Service is integrated with some email content management application (such as an anti-spam), the admin…
Suggested Courses
Course of the Month14 days, 9 hours left to enroll

839 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question