?
Solved

Autodiscover not populating the HTTPS connection settings for Outlook 2010

Posted on 2011-10-17
5
Medium Priority
?
372 Views
Last Modified: 2012-05-12
We are running into an issue when we assign new laptops to users.  They are unable to connect to the Exchange server from outside the network.  When looking at their configuration, I noticed that under the "Microsoft Exchange Proxy Settings" the HTTPS URL is not being filled in.  When I enter the information, they have no issues...  It is automatically filled in on Outlok 2007 though.  I need to resolve this so I don't have to touch every machine to make sure that it is configured correctly.
0
Comment
Question by:warewols
  • 3
  • 2
5 Comments
 
LVL 49

Expert Comment

by:Akhater
ID: 36982288
what exchange version do you have 2007 or 2010 ? how many cas servers do you have ?


ctrl + right click on the outlook icon in the system tray and test autoconfiguration settings, put the username password UNCHECK all options keep only autodiscover and run it go to the xml view and give me the results
0
 

Author Comment

by:warewols
ID: 36982418
We are running Exchange 2010.  We have 2 CAS servers.

<?xml version="1.0" encoding="utf-8"?>
<Autodiscover xmlns="http://schemas.microsoft.com/exchange/autodiscover/responseschema/2006">
  <Response xmlns="http://schemas.microsoft.com/exchange/autodiscover/outlook/responseschema/2006a">
    <User>
      <DisplayName>Kowalski, Mike</DisplayName>
      <LegacyDN>/o=Campbell-Ewald/ou=First Administrative Group/cn=Recipients/cn=mkowalsk</LegacyDN>
      <AutoDiscoverSMTPAddress>mkowalsk@campbell-ewald.com</AutoDiscoverSMTPAddress>
      <DeploymentId>001f83c8-f77f-464a-ad76-f8c3358ce591</DeploymentId>
    </User>
    <Account>
      <AccountType>email</AccountType>
      <Action>settings</Action>
      <Protocol>
        <Type>EXCH</Type>
        <Server>itcas.ad.campbell-ewald.com</Server>
        <ServerDN>/o=Campbell-Ewald/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=itcas.ad.campbell-ewald.com</ServerDN>
        <ServerVersion>738180DA</ServerVersion>
        <MdbDN>/o=Campbell-Ewald/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=itcas.ad.campbell-ewald.com/cn=Microsoft Private MDB</MdbDN>
        <PublicFolderServer>ITMBX1.ad.campbell-ewald.com</PublicFolderServer>
        <AD>ITAD1.ad.campbell-ewald.com</AD>
        <ASUrl>https://itcas1.campbell-ewald.com/ews/exchange.asmx</ASUrl>
        <EwsUrl>https://itcas1.campbell-ewald.com/ews/exchange.asmx</EwsUrl>
        <EcpUrl>https://itcas.campbell-ewald.com/ecp/</EcpUrl>
        <EcpUrl-um>?p=customize/voicemail.aspx&amp;exsvurl=1</EcpUrl-um>
        <EcpUrl-aggr>?p=personalsettings/EmailSubscriptions.slab&amp;exsvurl=1</EcpUrl-aggr>
        <EcpUrl-mt>PersonalSettings/DeliveryReport.aspx?exsvurl=1&amp;IsOWA=&lt;IsOWA&gt;&amp;MsgID=&lt;MsgID&gt;&amp;Mbx=&lt;Mbx&gt;</EcpUrl-mt>
        <EcpUrl-ret>?p=organize/retentionpolicytags.slab&amp;exsvurl=1</EcpUrl-ret>
        <EcpUrl-sms>?p=sms/textmessaging.slab&amp;exsvurl=1</EcpUrl-sms>
        <OOFUrl>https://itcas1.campbell-ewald.com/ews/exchange.asmx</OOFUrl>
        <UMUrl>https://itcas1.campbell-ewald.com/ews/UM2007Legacy.asmx</UMUrl>
        <OABUrl>https://itcas2.campbell-ewald.com/oab/4107e889-dd78-4f32-8b9c-427329ca7f6c/</OABUrl>
      </Protocol>
      <Protocol>
        <Type>EXPR</Type>
        <Server>webmail.c-e.com</Server>
        <SSL>On</SSL>
        <AuthPackage>Basic</AuthPackage>
        <ASUrl>https://webmail.c-e.com/ews/exchange.asmx</ASUrl>
        <EwsUrl>https://webmail.c-e.com/ews/exchange.asmx</EwsUrl>
        <EcpUrl>https://webmail.c-e.com/ecp/</EcpUrl>
        <EcpUrl-um>?p=customize/voicemail.aspx&amp;exsvurl=1</EcpUrl-um>
        <EcpUrl-aggr>?p=personalsettings/EmailSubscriptions.slab&amp;exsvurl=1</EcpUrl-aggr>
        <EcpUrl-mt>PersonalSettings/DeliveryReport.aspx?exsvurl=1&amp;IsOWA=&lt;IsOWA&gt;&amp;MsgID=&lt;MsgID&gt;&amp;Mbx=&lt;Mbx&gt;</EcpUrl-mt>
        <EcpUrl-ret>?p=organize/retentionpolicytags.slab&amp;exsvurl=1</EcpUrl-ret>
        <EcpUrl-sms>?p=sms/textmessaging.slab&amp;exsvurl=1</EcpUrl-sms>
        <OOFUrl>https://webmail.c-e.com/ews/exchange.asmx</OOFUrl>
        <UMUrl>https://webmail.c-e.com/ews/UM2007Legacy.asmx</UMUrl>
        <OABUrl>https://webmail.c-e.com/OAB/4107e889-dd78-4f32-8b9c-427329ca7f6c/</OABUrl>
        <CertPrincipalName>msstd:webmail.c-e.com</CertPrincipalName>
      </Protocol>
      <Protocol>
        <Type>WEB</Type>
        <Internal>
          <OWAUrl AuthenticationMethod="Basic">https://itcas.campbell-ewald.com/owa/</OWAUrl>
          <Protocol>
            <Type>EXCH</Type>
            <ASUrl>https://itcas1.campbell-ewald.com/ews/exchange.asmx</ASUrl>
          </Protocol>
        </Internal>
        <External>
          <OWAUrl AuthenticationMethod="Fba">https://webmail.c-e.com/owa/</OWAUrl>
          <Protocol>
            <Type>EXPR</Type>
            <ASUrl>https://webmail.c-e.com/ews/exchange.asmx</ASUrl>
          </Protocol>
        </External>
      </Protocol>
      <AlternativeMailbox>
        <Type>Delegate</Type>
        <DisplayName>tpevoicing</DisplayName>
        <LegacyDN>/o=Campbell-Ewald/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=tpevoicing</LegacyDN>
        <Server>itcas.ad.campbell-ewald.com</Server>
      </AlternativeMailbox>
      <AlternativeMailbox>
        <Type>Delegate</Type>
        <DisplayName>Simon Creative PTO</DisplayName>
        <LegacyDN>/o=Campbell-Ewald/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=Simon Creative PTOc8c543e2</LegacyDN>
        <Server>itcas.ad.campbell-ewald.com</Server>
      </AlternativeMailbox>
    </Account>
  </Response>
</Autodiscover>
0
 
LVL 49

Accepted Solution

by:
Akhater earned 2000 total points
ID: 36982472
nothing wrong on this one! you mean that this outlook if you let autodiscover configure it won't have the settings correct ? are you 100% sure it is an outlook version issue ? is outlook anywhere enabled on both cas servers ?
0
 

Author Comment

by:warewols
ID: 36982499
I am assuming that it is an Outlook issue.  We had no complaints in regards to the configuration when we were running Office 2007, but a handful of users are experiencing this issue.  I had it when I recently rebuilt my laptop.

Yes, Outlook Anywhere is enabled on both servers as far as I can tell.
0
 
LVL 49

Expert Comment

by:Akhater
ID: 36982512
would it be feasible for you to provide me with a test username/pass so i can do some tests on my end?

the way to contact me is in the profile
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Today as you open your Outlook, you witness an error message: “Outlook is using an old copy of your Outlook Data File…”. Probably, Outlook is accessing an old OST file.
I came across an unsolved Outlook issue and here is my solution.
This Experts Exchange video Micro Tutorial shows how to tell Microsoft Office that a word is NOT spelled correctly. Microsoft Office has a built-in, main dictionary that is shared by Office apps, including Excel, Outlook, PowerPoint, and Word. When …
This video shows how to quickly and easily add an email signature for all users on Exchange 2016. The resulting signature is applied on a server level by Exchange Online. The email signature template has been downloaded from: www.mail-signatures…
Suggested Courses
Course of the Month15 days, 10 hours left to enroll

850 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question