• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 642
  • Last Modified:

RPC - HTTP Stopped working on SBS2003 Exchange Server

RPC over HTTP stopped working for all remote users using outlook.
OWA works just fine. Please help.
0
MIT-Techs
Asked:
MIT-Techs
  • 4
  • 4
  • 3
  • +1
1 Solution
 
Sid_FCommented:
Check event viewer and iis setup. Take a look at this article which shows you how to test the connection http://www.petri.co.il/testing_rpc_over_http_connection.htm
0
 
PradeepCommented:
Check the connectivity using testexchangeconnectivity and post the results here.
0
 
Alan HardistyCo-OwnerCommented:
Check to make sure you have Integrated and Basic Authentication enabled in IIS Manager on the RPC Virtual Directory of the Default Website.  Sometimes the settings change!

Once checked and if you change anything, please run iisreset and test.
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

 
MIT-TechsAuthor Commented:
@ Exchange9: results of test

      Testing RPC/HTTP connectivity.
       The RPC/HTTP test failed.
       
      Test Steps
       
      ExRCA is attempting to test Autodiscover for user@domain.com.
       Testing Autodiscover failed.
       
      Test Steps
       
      Attempting each method of contacting the Autodiscover service.
       The Autodiscover service couldn't be contacted successfully by any method.
       
      Test Steps
       
      Attempting to test potential Autodiscover URL https://domain.com/AutoDiscover/AutoDiscover.xml
       Testing of this potential Autodiscover URL failed.
       
      Test Steps
       
      Attempting to resolve the host name domain.com in DNS.
       The host name resolved successfully.
       
      Additional Details
       IP addresses returned: 205.xxx.xxx.179
      Testing TCP port 443 on host domain.com to ensure it's listening and open.
       The port was opened successfully.
      Testing the SSL certificate to make sure it's valid.
       The SSL certificate failed one or more certificate validation checks.
       
      Test Steps
       
      ExRCA is attempting to obtain the SSL certificate from remote server domain.com on port 443.
       ExRCA successfully obtained the remote SSL certificate.
       
      Additional Details
       Remote Certificate Subject: CN=*.gridserver.com, O="Media Temple, Inc", L=Culver City, S=California, C=US, SERIALNUMBER=zttPjdMuz3O/1KzjUIngUrI59j8hc8Rv, Issuer: CN=GeoTrust SSL CA, O="GeoTrust, Inc.", C=US.
      Validating the certificate name.
       Certificate name validation failed.
        Tell me more about this issue and how to resolve it
       
      Additional Details
       Host name domain.com doesn't match any name found on the server certificate CN=*.gridserver.com, O="Media Temple, Inc", L=Culver City, S=California, C=US, SERIALNUMBER=zttPjdMuz3O/1KzjUIngUrI59j8hc8Rv.
      Attempting to test potential Autodiscover URL https://autodiscover.domain.com/AutoDiscover/AutoDiscover.xml
       Testing of this potential Autodiscover URL failed.
       
      Test Steps
       
      Attempting to resolve the host name autodiscover.domain.com in DNS.
       The host name resolved successfully.
       
      Additional Details
       IP addresses returned: 205.xxx.xxx.179
      Testing TCP port 443 on host autodiscover.domain.com to ensure it's listening and open.
       The port was opened successfully.
      Testing the SSL certificate to make sure it's valid.
       The SSL certificate failed one or more certificate validation checks.
       
      Test Steps
       
      ExRCA is attempting to obtain the SSL certificate from remote server autodiscover.domain.com on port 443.
       ExRCA successfully obtained the remote SSL certificate.
       
      Additional Details
       Remote Certificate Subject: CN=*.gridserver.com, O="Media Temple, Inc", L=Culver City, S=California, C=US, SERIALNUMBER=zttPjdMuz3O/1KzjUIngUrI59j8hc8Rv, Issuer: CN=GeoTrust SSL CA, O="GeoTrust, Inc.", C=US.
      Validating the certificate name.
       Certificate name validation failed.
        Tell me more about this issue and how to resolve it
       
      Additional Details
       Host name autodiscover.domain.com doesn't match any name found on the server certificate CN=*.gridserver.com, O="Media Temple, Inc", L=Culver City, S=California, C=US, SERIALNUMBER=zttPjdMuz3O/1KzjUIngUrI59j8hc8Rv.
      Attempting to contact the Autodiscover service using the HTTP redirect method.
       The attempt to contact Autodiscover using the HTTP Redirect method failed.
       
      Test Steps
       
      Attempting to resolve the host name autodiscover.domain.com in DNS.
       The host name resolved successfully.
       
      Additional Details
       IP addresses returned: 205.xxx.xxx.179
      Testing TCP port 80 on host autodiscover.domain.com to ensure it's listening and open.
       The port was opened successfully.
      ExRCA is checking the host autodiscover.domain.com for an HTTP redirect to the Autodiscover service.
       ExRCA failed to get an HTTP redirect response for Autodiscover.
       
      Additional Details
       A Web exception occurred because an HTTP 404 - NotFound response was received from Unknown.
      Attempting to contact the Autodiscover service using the DNS SRV redirect method.
       ExRCA failed to contact the Autodiscover service using the DNS SRV redirect method.
       
      Test Steps
       
      Attempting to locate SRV record _autodiscover._tcp.domain.com in DNS.
       The Autodiscover SRV record wasn't found in DNS.
        Tell me more about this issue and how to resolve it
0
 
PradeepCommented:
Ok, also perform the same test for Autodiscovery.
0
 
PradeepCommented:
Check this once..
0
 
Alan HardistyCo-OwnerCommented:
What address was configured for your domain to use RPC over HTTPS?

It may be that someone has changed your DNS records and that the name now resolves to another IP Address.
0
 
MIT-TechsAuthor Commented:
I just tested alanhardisty's recommendation and it looks like the issue was with the RPC virtual Directory in IIS. Integrated authentication was not enabled. It really did somehow change.

I will test a little more and confirm fix shortly.
0
 
Alan HardistyCo-OwnerCommented:
No problems - it's a common issue but an easy fix.
0
 
MIT-TechsAuthor Commented:
Thank you for your help. Have a great day!
0
 
Alan HardistyCo-OwnerCommented:
You are welcome.  Glad it is working for you.

Best wishes

Alan
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

  • 4
  • 4
  • 3
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now