how do I get Java Web Start Launcher

I have a program that needs to be associated with Java Web Start Launcher but when I try to choose it in IE it doesn't exist.  How do I get it?
J.R. SitmanIT DirectorAsked:
Who is Participating?
 
CEHJCommented:
Have you made sure you correctly installed the JRE to IE?
0
 
for_yanCommented:

http://wiki.wholebraincatalog.org/wiki/Set_up_JNLP_Browser_Association

Internet Explorer

To set up the association between *.jnlp files and javaws.exe in Windows which also handles IE:

    In Windows, not IE, click Start | Settings | Control Panel | Folder Options | File Types.
    Check to see if there is already an association for *.jnlp files.
    If there is no entry for *.jnlp files already then click new | advanced | select "jnlp file"
    If there is an entry, select it and click advanced.
    Then edit the open application used to perform action field and make sure it is set to "C:\Program Files\java\jre...\bin\javaws.exe ""%1". Uncheck DDE.
    Click OK.
    Click Set As Default to make Open the default action. Likely Open will be the only action.
    Click OK | Close.

Even after all this is done, IE will only half work. It will work with JNLP files loaded off the web, but not ones from local hard disk. This is because webservers provide a MIME type to give IE an extra hint, where the Windows file system provides no MIME types.
0
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

 
for_yanCommented:
You also need to have JRE installed on your machine.

Check if applects are working in your browser:
just go here to check:
http://www.realapplets.com/tutorial/GuiExample.html

0
 
J.R. SitmanIT DirectorAuthor Commented:
I get as far as "folder options" but don't see an option for "file types".  I'm using Win7 32bit.
0
 
for_yanCommented:
There should be tab on top together with general, view, file types and Offline files
But I'm on XP
Microsoft of course coudl have cnahged it  - they like to change things, but this was pretty stable on previous versions
0
 
for_yanCommented:

afgain maybe it is in Vista only?
Go to Control Panel and launch the Default Programs tool, then click the link for "Associate a file type or protocol with a program".

 

After you scroll and select a file type, click Change Program. In the Open With dialog, the recommended programs will be listed above the line and "other" programs below. This may initially be empty. But before you click Browse, try clicking the down caret button and it will populate with other programs that might include the one you're looking for.

 

This works only for associations - there appears to be no way to specify the text for a context menu item, or to specify how arguments are passed. And, the system types like "Folder" aren't listed at all - just actual extensions and protocols.

 

My interim solution is Creative Elements' Power Tool. Using that I could associate the Folder type with cmd.exe - but the command session is not opening in the selected directory ("%1") as was the case under XP. If you right-click a folder in the Folders list, it always opens in %Windir%System32. If you right-click a folder in the files list, it opens in the parent folder, not the folder you clicked on. You get the same behavior defining the command on the "Directory" file type.

 

I'm not sure how "%1" will work for files associated with other programs, but for cmd.exe it saves a few CD commands...
0
 
for_yanCommented:
This seem to show how to do it on annoyances.org!

http://www.annoyances.org/exec/show/article02-500
0
 
J.R. SitmanIT DirectorAuthor Commented:
Thanks
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.