Ubuntu networking issue - no packets transmitting

Posted on 2011-10-17
Last Modified: 2012-05-12

I have a Ubuntu 9.04 disk running on an ASUS P9H67-I motherboard (Realtek gigabit ethernet controller).   This is a pretty new system.  The eth0 port was running fine after installation, except that I had to plug in the ethernet cable after the machine had booted for the DHCP client to function correctly.   I took it to another network and it did not assign an IP4 address.  Brought it back to my network, and it is now failing here as well.

I have validated the hardware and dhcp server by booting from a Windows disk and connecting the internet.

Symptoms (from ifconfig) include incrementing of the RX bytes but TX bytes stay at 0.  I also see RX packet errors increasing and RX dropped value increasing.  Otherwise, I don't spot anything out of the ordinary in the ifconfig command.

When I run ps -e, I don't see a dhcp client running but I'm not quite sure what I the process name should be or how to create it. I tried running dhclient based on info from another entry here.  It ran, but did not find a dhcp host.  

This interface did previously work from this same boot disk and I just now validated the hardware with my Windows boot disk.  Doesn't work now though.  Any assistance appreciated.
Question by:markdolar
    LVL 6

    Expert Comment

    If your network including DHCP is working from Windows environment, it must be a Ubuntu configuration problem.

    Please make sure that your network interface is up with "sudo ifconfig" and your network cable plugged in.

    Then please do a "sudo dhclient [your-network-interface]" and check by the help of dhclient output if your network interface got an ip address.

    If the above didn't work try to assign and ip address manually with "sudo ifconfig [your-network-interface] [ip-address]". Than try to ping your router ip address. Please make sure that you assign a different ip address to your computer as the ip address of your router is (but the same subnet).

    If you don't know the router ip adress try to find it out under Windows with "ipconfig /all". There should be an entry about DHCP-Server. Be sure that your Network / Internet does work while checking the router ip adress.
    LVL 6

    Expert Comment

    To ping your router ip address please do a "ping [your-router-ip-address]" in your Linux command line.

    Author Comment

    I tried all the above - included adding a netmask of   No change and the ping test fails.  I also tried pinging the client from the router, which also failed.

    I notice that the loopback lo is running and the number of tx and rx packets there match.
    LVL 6

    Accepted Solution

    Is it very important for you to get Ubuntu 9.04 running with your network card? Since Ubuntu 9.04 is not supported anymore. I would recommend you to install Ubuntu 10.04 (Lucid Lynx) Long Time Support (maintained untill April 2013) or the newest version of Ubuntu 11.10 (Oneiric Ocelot) ( also maintained untill April 2013).

    To check what version you have do a "lsb_release -a" in your command line.


    Author Closing Comment

    It appears the problem is related to the hardware.  I use the same boot disk on another system (older motherboard) and it works with the same LAN device driver being loaded.  So my conclusion is that the software is too old for the motherboard.

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Free Trending Threat Insights Every Day

    Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

    Network Interface Card (NIC) bonding, also known as link aggregation, NIC teaming and trunking, is an important concept to understand and implement in any environment where high availability is of concern. Using this feature, a server administrator …
    Using 'screen' for session sharing, The Simple Edition Step 1: user starts session with command: screen Step 2: other user (logged in with same user account) connects with command: screen -x Done. Both users are connected to the same CLI sessio…
    Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
    Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

    737 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    22 Experts available now in Live!

    Get 1:1 Help Now