CentOS Linux 5.7 TCP Window Scaling Question

I did a clean install and use Webmin/Virtualmin.

The server seemed a little slow and I eventually figured out it was a TCP window scaling issue. At the command line I get 0 if I do "sysctl net.ipv4.tcp_window_scaling".

So I edited /etc/sysctl.conf and added this line at the end:
net.ipv4.tcp_window_scaling=1

If I do "/sbin/sysctl -p" it works. But...When I reboot, the setting is still 0 if I do "sysctl net.ipv4.tcp_window_scaling"!

How can I fix this setting so that it is permanent?
PaliTreeAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

pritamduttCommented:
Is the value of net.ipv4.tcp_window_scaling also changed in /etc/sysctl.conf after reboot?
0
pritamduttCommented:
Because  /etc/sysctl.conf is used to permanently store the desired kernel tuning parameters for the system,  to be read in and set at boot time.

If you find the value has not changed and for some reason the changes are not reflecting, you can make a call to /sbin/sysctl in /etc/rc.local file.

Hope this helps!

Regards,
0
PaliTreeAuthor Commented:
Thanks - yes I could fix the vale myself at boot. But it seems to me that there must be something wrong if the vlues of /etc/sysctl.conf are not being read-in at boot? Otherwise what is the conf file for?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

PaliTreeAuthor Commented:
I have found the problem (and it's good I didn't go the /etc/rc.local route).

I am using APF firewall. This has a setting:

# These are system control (sysctl) option changes to disable TCP features
# that can be abused in addition to tweaking other TCP features for increased
# performance and reliability.
SYSCTL_TCP="1"

And if you set this, APF does this:
echo 0 > /proc/sys/net/ipv4/tcp_window_scaling
0
pritamduttCommented:
Great.. so it was a application issue..
Thanks for sharing!
0
PaliTreeAuthor Commented:
In the latest version of APF this has now been fixed
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
PaliTreeAuthor Commented:
Completely solved
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.