Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 771
  • Last Modified:

joomla article shows as forbidden

Hi There

i have run into a problem and not sure what it is as i has happened on 2 fresh joomla installs

i have a domain www.surfs.co.za with joomla installed(currently offline)

i have a menu item called news with subitems

world tour
local
junior
womens

the submenu items go to a category blog layout and i put news articles into the relevant categories

however after the opening lines of the article i put a read more link, i can then see the opening lines but when i select read more i get the following

Forbidden

You don't have permission to access /news/world-tour/16-surfs-asp-news-rip-curl-pro-on on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Thanks in advance
Tyrone
0
tyronenoel
Asked:
tyronenoel
1 Solution
 
Panagiotis Sweb developer - designer Commented:
try to disable SEF urls to see
0
 
tyronenoelAuthor Commented:
same thing

Forbidden

You don't have permission to access /index.php on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
0
 
LinuxGuruLinux Server AdministratorCommented:
Hi,

According to the error, there seems to be a permission issue for the files/folders. You need to check the permission/ownership and correct it. Are you on a Linux based server? If yes, please check the apache error log for more details or paste the log here so we could assist you further. Also you can contact your hosting provider to correct the permission/ownership issue.

Cheers !!!
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
Andrew DerseIT ManagerCommented:
A few questions for you...

Do you use any SEF extensions?

Have you set the article to be viewable only by registered or special permissions?
0
 
tyronenoelAuthor Commented:
Hi  Testez

i also thought so as the permissions were 740 i have changed everything to 755 and still no use, i just dont understand why doing it on some articles and not others, i go into the error log and its empty

Nukit

no SEF extensions are install and the article is viewable by the public
0
 
tyronenoelAuthor Commented:
i seem to have found the problem

the read more puts the alias in
http://www.surfs.co.za/index.php?option=com_content&view=article&id=16:surfs-asp-news-rip-curl-pro-on&catid=13&Itemid=173

this is what is causing the problem as it should be like below

i have checked the link below and this fixes it, maybe a jce editior issue?

http://www.surfs.co.za/index.php?option=com_content&view=article&id=16&catid=13&Itemid=173
0
 
tyronenoelAuthor Commented:
tried with tiny mce as the editor, recreated the read more link and same problem
0
 
Andrew DerseIT ManagerCommented:
Try completely recreating the article or a new article without JCE and a read-more link and see if it occurs.  If it doesn't, then re-create the article you are having problems with and see if will work properly.
0
 
tyronenoelAuthor Commented:
alright NUKIT i think i am going to have to give you the points, it wasnt the article that was faulty it was the category, anything i put in that category didnt work but every other category did, so i deleted the articles and the category, recreated and voila everything came alive, even though your answer wasnt exactly on the problem it helped steer me into the right direction

Thanks alot
0
 
Andrew DerseIT ManagerCommented:
Sounds good...glad you were able to resolve your problem.
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now