• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 843
  • Last Modified:

SBS 2008 blocking port 25 - pop3 connector error

All of a sudden we stopped receiving mails in our Outlook exchange.

I have found out that pop3 connector results in an error, therefore not receiving any mails from our webmail providor.

In Event Viewer I get this message:
Cannot connect to the SMTP server 'localhost' on port 25. The error code was 0x800ccc0e. Verify that the Microsoft Exchange Transport service is running and that the Exchange receive connectors are properly configured.

Telnet to port 25 gives me: Connection Failed on both internal an external IP.
E.g. port 80 is OK.

The "Fix My Network" keeps complaining about a missing port mapping (prob. port 25)

My router forwards OK, but using canyouseeme.org results in a "Connection Timeout"
When changing the forward of port 25 to another device the connection is successfull.

So I assume that the problem must lie in SBS.

I have AVG Internet Security Business Edition 2012 installed on the server.
have tried to disable resident Shield and scanning of incomming emails, as I have disabled the Windows Firewall, but no change.

Please Help!!
0
bsit
Asked:
bsit
  • 8
  • 4
1 Solution
 
Madan SharmaConsultantCommented:
0
 
bsitAuthor Commented:
I don't think we have the same error, as it seems that wirelessnut in the thread actually can get a response on port 25, but having authorisation problems.

My log file says:
10/18/11, 11:54:35: EVENT: Cannot connect to the SMTP server 'localhost' on port 25. The error code was 0x800ccc0e. Verify that the Microsoft Exchange Transport service is running and that the Exchange receive connectors are properly configured.
[t 0] 10/18/11, 11:59:16: (AsyncConn[ localhost:25 ]) err: WSAGETSELECTEVENT = 0x10, WSAGETSELECTERROR = 10061
[t 0] 10/18/11, 11:59:17: (AsyncConn[ localhost:25 ]) err: WSAGETSELECTEVENT = 0x10, WSAGETSELECTERROR = 10061
[t 0] 10/18/11, 11:59:18: (AsyncConn[ localhost:25 ]) err: WSAGETSELECTEVENT = 0x10, WSAGETSELECTERROR = 10061
[t 0] 10/18/11, 11:59:19: (AsyncConn[ localhost:25 ]) err: WSAGETSELECTEVENT = 0x10, WSAGETSELECTERROR = 10061
[t 0] 10/18/11, 11:59:19: (SMTP) ERROR: "The connection to the server has failed.", hr=800ccc0e
[t 0] 10/18/11, 11:59:19: Failure hrResult (0x800ccc0e) trying to connect to SMTP server 'localhost':
[t 0] 10/18/11, 11:59:19: (no response)
0
 
bsitAuthor Commented:
By the way. I tried sending a mail from one exchange user to another, but that didn't reach the other exchange user either.
0
WEBINAR: 10 Easy Ways to Lose a Password

Join us on June 27th at 8 am PDT to learn about the methods that hackers use to lift real, working credentials from even the most security-savvy employees. We'll cover the importance of multi-factor authentication and how these solutions can better protect your business!

 
Madan SharmaConsultantCommented:
please reboot your server once and after reboot check for exchange transport service running or not.
0
 
bsitAuthor Commented:
Done!
The service is not started.
which was also a symptom before I restarted the server.

I can start the service, but shortly after it stoppes again, without notice.
0
 
Madan SharmaConsultantCommented:
check out your server logs for it why its getting stops automatically and post the error log here for further discussion.
0
 
bsitAuthor Commented:
Well were back to the same error message that i mentioned in the beginning:

Cannot connect to the SMTP server 'localhost' on port 25. The error code was 0x800ccc0e. Verify that the Microsoft Exchange Transport service is running and that the Exchange receive connectors are properly configured.

The message is logged under Application and Services Logs -> Win SBS -> Mic-Win-SBS operational
It is the only message in that window. But there is a lot of them.
0
 
Madan SharmaConsultantCommented:
go to “<drive>\Program Files\Microsoft\Exchange Server\TransportRoles\data\Queue and check out how many mails are there. Please rename queue folder as queue_old
And start the exchange transport service it will create this folder automatically again.
0
 
bsitAuthor Commented:
It did create a new folder, but I still get the same error.
0
 
bsitAuthor Commented:
at canyouseeme.org:
testing port 25 gives me "Connection Time out"
disabling the firewall gives me "connection refused"
is that helpfull?
0
 
bsitAuthor Commented:
Problem solved.
AVG Internet Security 2012 seemed to cause the problem.
I uninstalled AVG.
After uninstalling I still could not get through.
Reinstalled AVG
After installing pop3 connector suddently started to recieve emails.
Has worked ever since.

Weird!
0
 
bsitAuthor Commented:
Solved the problem.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

  • 8
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now