Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 323
  • Last Modified:

IE8 runs scrips with javascript disabled

I'm working with my web pages to provide alternative content for browsers with javascript disabled, so I've disabled active scripts on my IE8 browser.  To my surprise, active scripts are still run on files residing on a local drive.  However, with identical files on a remote server, the "noscript" content appears, as expected.  How is this possible?  
0
ddantes
Asked:
ddantes
  • 3
  • 3
  • 2
1 Solution
 
gavsmithCommented:
The zone is hidden by default please see link below:

http://support.microsoft.com/kb/315933
0
 
gavsmithCommented:
Sorry I keep jumping in head first lately... this doesn't apply to IE8, you must use the IE Administration Kit (IEAK) to manage the 'My Computer' zone according to this article:

http://support.microsoft.com/kb/174360

Hope that helps
0
 
hankknightCommented:
Consider installing a web server on your local computer so you can test pages in a more real environment.

http://www.wampserver.com/
http://code.google.com/p/mongoose/

0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
ddantesAuthor Commented:
Thank you for your comment.  I installed Wampserver, but I don't see documentation about how to use it, and there is no help menu.  Can you refer me to a user's guide?  Meanwhile, can you explain how a javascript slide show would continue to play when javascript is disabled?
0
 
hankknightCommented:
If a JavaScript slide show is  playing the JavaScript is not actually disabled.  Internet Explorer is actually very tightly connected to Window's File Explorer, so certain settings are applied differently to files run from the file system to keep you from messing up the way Windows browses files and folders in the file system.

Presuming you installed Wampserver to C:\wamp\, DELETE "C:\wamp\www\index.php" then place your HTML files in that directory.  Then go here:

http://localhost/

0
 
ddantesAuthor Commented:
I deleted index.php (and testmysql.php) and placed my html files in the www directory.  When I navigate to http://localhost/  I get "Internet Explorer could not display this page."
0
 
hankknightCommented:
Do you see an icon that looks like a half circle in your tray bar?  If so, describe it.  Does it look like one of the icons below?  The color could let us know the problem.
wIcon.png
0
 
ddantesAuthor Commented:
There was no icon.  The wampserver server was offline.  Once I started the server, the files appear in the www directory.  Thank you for explaining the mysterious javascript behavior and suggesting this method as a testing environment.
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

  • 3
  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now