The BlackBerry Administration Service was unable to retrieve specific device attributes from the device that is connected to your computer.

Receiving the following error from the Blackberry Administration Service..

The BlackBerry Administration Service was unable to retrieve specific device attributes from the device that is connected to your computer.

When trying to associate a device with a domain administrator account.
I have checked the security for the user account, our BES Administrator account (BESadmin) does have Send as permission under 'Descendant User Objects'

We are running BESX Version on a Windows Server 2003 R2 server.
No other users are reporting any issues.

BESAdmin permissions are applied to the domain, inherting is turned on for all OU's the user account resides in.

I have tried removing the user and re-creating in BESX.

Any help will be greatly appreciated.

Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Tony GiangrecoCommented:
I've seen this before. I suggest backing up the device and then running a security wipe and resinstalling the device.

After adding the user again, attach the device and  check the following settings:

In the BlackBerry Administration Service, select the user and click Enable as BlackBerry user.
 In the BlackBerry Administration Service, under Devices, click Manage current devices > Assign current device > choose user > Associate user.

    Verify the CAL has not exceeded the user limit:
        Under Servers and Components, expand BlackBerry solution topology.
        Expand component view and click on BlackBerry Administration Service.
        Update the license information if necessary.

Have you checked the Receive As  and Administrative Information store.
If the above also are ok, then check the BB PIN or Model which is not allowed by Enterprise Service policy. Make sure the following settings:

    In the BlackBerry Administration Service, on the Servers and components menu, expand BlackBerry Solution topology > BlackBerry Domain > Component view.
    Click BlackBerry Enterprise Server.
    Click Edit component.
    In the Enterprise Service Policy section, in the Allowed drop-down list, click Yes for each BlackBerry smartphone model that you want to permit to access the BlackBerry Enterprise Server.
    To add a new BlackBerry smartphone, on the Add New Allowed PINs tab, in the New Allowed PINs field, type the PIN for the BlackBerry smartphone. Click the Add icon.
    Click Save All.


Check Wireline Activation setting under BlackBerry Web Desktop Manger information tab is Set to No or Yes.

    In the BlackBerry Administration Service, expand BlackBerry Solution Topology.
    Click Component view.
    Select BlackBerry Administration Service from the list of components.
    Click the BlackBerry Web Desktop Manager tab.
    Click Edit component.
    In the Allow user wireline activation drop-down list, click the Activate any PIN option.

If every thing is fine, and still the issue persists its better to do Wireless Activation.

antoniokingAuthor Commented:
We have 9978 licences available.

The BES administrator account has receive as and information store permission over the mailbox store.
I have followed Blackberry article KB02276 ( Twice for good measure!

We had the Enterprise Service Policy switched off, however for the purpose of your reply I have enabled the policy and added the BB PIN to the allow list as you suggested.

Activate any PIN option is already on.

Wireless activation also fails, the Enterprise Activation screen displays... "Activating" but eventually displays "
OWASP: Threats Fundamentals

Learn the top ten threats that are present in modern web-application development and how to protect your business from them.

antoniokingAuthor Commented:
Wireless activation also fails, the Enterprise Activation screen displays... "Activating", after a long delay of what seams inactivity it will display "Retrying" and repeat the process.
antoniokingAuthor Commented:
FYI, I have wiped the device and tried again. Same error.
Tony GiangrecoCommented:
Possible problem with that device. I suggest replacing it with a new device.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
antoniokingAuthor Commented:
Is that a joke or a genuine recommendation from an "expert"?
Tony GiangrecoCommented:
That is no joke. If you have repeatedly tried to setup the device and it repeatedly fails, possibly there is a problem with that device.
antoniokingAuthor Commented:
I am seeing the following in the MAGT log...

[30053] (10/19 04:03:53.203):{0x2DDC} Retry start for user: /o=Butler International/ou=First Administrative Group/cn=Recipients/cn=aking
[30041] (10/19 04:03:53.203):{0x2DDC} Starting handheld for Antonio King
[40153] (10/19 04:03:53.203):{0x2DDC} PMDatabase::OpenNamedFolder: opening existing folder 'BlackBerryHandheldInfo'
[40155] (10/19 04:03:53.203):{0x2DDC} PMDatabase::OpenNamedFolder: opened an existing folder 'BlackBerryHandheldInfo'
[40158] (10/19 04:03:53.203):{0x2DDC} Pager::OpenClientDatabase: invalid number of messages in client folder , num msg = 4
[20152] (10/19 04:03:53.203):{0x2DDC} OpenDatabase() failed for Antonio King

Open in new window

antoniokingAuthor Commented:
Article KB13458
Cause 1... User can send and receive emails using Outlook.
Cause 2... Correct email address was used. Multiple retries with the correct address.
Cause 3... Correct password, tried changing the activation password. 100% certain it's correct.
Cause 4... Sent blank.dat file from external source. Received and re-sent back ok.
Cause 5... No email forwarding is setup for the user account.
Cause 6... Not using IBM Lotus Domino server.
Cause 7... Contacted service provider. BES service is active on the line.
Based on that error message, there are a couple of things you can try that should resolve the issue.
1. Remove and readd the user to the BES and reactivate.

2. Remove the user from the BES and click yes to the delete user and Blackberry info prompt, then readd the user.  This will recrate the hidden folder for the use's Exchange
antoniokingAuthor Commented:
Hi pbolintx,

Thanks for the reply, however.. as stated in my original question..

"I have tried removing the user and re-creating in BESX."
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
BlackBerry Programming

From novice to tech pro — start learning today.