• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 357
  • Last Modified:

Weird tracert information!?

Hi,

I've got trouble connecting with one of my Windows 2008 servers to the Internet. When I do a tracert I see that he's trying to pass through 192.168.4.1 as first hop. But that's weird because the actual gateway is the 192.168.2.1 !? So where does he get this .4.1 from?

When I do an ipconfig /all the gateway is properly set to 192.168.2.1 though ...

Any ideas?

Thanks a lot!
0
Xeronimo
Asked:
Xeronimo
  • 7
  • 3
1 Solution
 
AegilCommented:
Is your gateway a Domain Controller with two interfaces by any chance and the 192.168.4.1 on the secondary nic? If so there is an issue with Nic priorities, as its responding with the other interface first.

If so then on your network properties in tools there should be an option for nic priority. Try changing them around and see if that resolves your issue.

If thats not the case, do you have any devices on your network with that ip address?
0
 
slemmesmiCommented:
Dear Xeronimo,

as it may be a static route please post the output from running the command (on the server in question): route print

Also please on/from that server provide the output of the "ipconfig /all" you mention.

Kind regards,
Soren
0
 
XeronimoAuthor Commented:
Aegil:

No, the gateway (2.1) is a hardware firewall. The 4.1. is a special router which shouldn't be addressed by this server at all.

And this works fine on all my other servers by the way.

Thanks

0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

 
XeronimoAuthor Commented:
slemmesmi:

I thought about static routes too but it doesn't seem to be the case. Here's the output though:


route.PNG
0
 
XeronimoAuthor Commented:
slemmesmi:

Here's the ipconfig /all screenshot




ipconfig.PNG
0
 
slemmesmiCommented:
Dear Xeronimo,

I find it a bit strange you have a default gateway '0.0.0.0'.
I do assume you haven't got such on the other servers (which routes correctly to the Internet), so could you verify you haven't got a such specified for the NIC in question?
Maybe that originates for an application/service on the server?

Kind regards,
Soren
0
 
XeronimoAuthor Commented:
slemmes:

I've not consciously created a gateway 0.0.0.0 ... how would I delete this one then?
0
 
slemmesmiCommented:
Dear Xeronimo,

check out the TCP/IPv4 properties of the NIC e.g. throuch "ncpa.cpl", then on the "General" tab thereof, select Advanced.
In the "Advanced" properties, you may see more than one (e.g. the '0.0.0.0') default gateway is defined in the section "Default Gateways".
If that is the case, then (I assume you are in full compliance with the change management processes of your orgnization and avoid disruption of any business processes before proceeding), try out removing that, and see if your tracert problem is gone.

Kind regards,
Soren
0
 
XeronimoAuthor Commented:
Ok, seems that was the problem ... I've deleted the route to 0.0.0.0 ... although I had to add 192.168.2.1 as gateway again to the NIC.

Now the tracert works as it should!

Thanks :)
0
 
XeronimoAuthor Commented:
Soren,

I've delete the route using the command line. I didn't see it under 'advanced'. Though that's weird, no?

Anyway, it seems to work again now! :)
0
 
XeronimoAuthor Commented:
That's indeed where the problem came from! I removed it and now it works again. Thanks :)
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 7
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now