intialization failed when starting exchange server 2010

hi sir

i am using 2008 sp1 r2 server and installed 2010 exchange server,i have finished my exchange server installation without error, and when i checked it ,it was working fine, after installation i installed 2 roles first remote access and routing and remote desktop web access and went office, at evening when i came back and checked and click at server role its show some error, without any hesitation i restart my server, because i was sure that after restart problem will automatically solve.but it could not be solve, then i start to search solution at google and found a great link http://www.petenetlive.com/KB/Article/0000477.htm, with the help of this site i was trying to solve problem but could not success because at last when i was trying to start default web site it's showing error "another web site may be using same port. another problem is that when i checked inetpub folder in c drive and click at wwwroot  the web file is not showing .
'

please help me , i am sending 3 screen shot
exchange-server-error.jpg
iis-error.jpg
Untitled.jpg
kkgg12Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

RadweldCommented:
Remote Desktop Web Access installs a new Website which it uses to publish RDP connections I would remove this server role. I would also remove the routing and remote acess server role as these server roles are messing with Exchange 2010. Many of these server roles are not supported for co-existence unless your using SBS which is a special version of windows.

Remove the additional server roles and see if Exchange is working again.
0
sunnyc7Commented:
You can download EMTShooter and run it from commandline
http://blogs.technet.com/b/exchange/archive/2010/12/07/resolving-winrm-errors-and-exchange-2010-management-tools-startup-failures.aspx

You can run this command from a elevated Powershell

C:\Windows\System32\WindowsPowerShell\v1.0\powershell.exe -noexit -command ". 'C:\Install\EMTshooter\EMTshooter.ps1'"


0
kkgg12Author Commented:
i am unable to run in power shell its showing error.see the screen shot,
i have also uninstall both role but problem is same
emtshooter-error.jpg
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

sunnyc7Commented:
run this
C:\Windows\System32\WindowsPowerShell\v1.0\powershell.exe -noexit -command ". 'C:\EMTshoote\EMTshooter.ps1'"
0
kkgg12Author Commented:
how to run this command ,

should i run this command in single line or separate because when i am run this command in single line its showing error, i have no more idea to run this type command so please describe in detail or step by step for run command
0
kkgg12Author Commented:
i create shortcut of powershell at desktop with -noexit command and run the command line but showing same error
0
kkgg12Author Commented:
i have also tried to run this file at right click and run with Powershell but could not run it
0
RadweldCommented:
If this is taking too long to troubleshoot then it is probably quicker to rebuild the server. If the server contains  mailboxes and has been used to send/receive mail the you need to backup the mailbox database.

reset the computer account in ad for the exchange server.
Rebuild the server with the same OS, ip an name.
Re join the domain.
Re install exchange pre reqs.
Recover exchange using setup /mode:recoverserver

http://technet.microsoft.com/en-us/library/dd876880.aspx

As active directory stores all the configuration data it's usually quicker to rebuild.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
sunnyc7Commented:
It's not necessary @ rebuild the server.
Powershell vdir's are off, that's why EMS/EMC are not loading
EMT Shooter fixes that

Open powershell
Use Elevated Admin prompt
navigate to c:\emtshooter
and then run this
C:\Windows\System32\WindowsPowerShell\v1.0\powershell.exe -noexit -command " 'C:\EMTshoote\EMTshooter.ps1'"

If there are any erorrs, Post a screenshot of the powershell window after you execute the command
0
kkgg12Author Commented:
ok thanks now i have formatted system for re installation
0
kkgg12Author Commented:
I've requested that this question be closed as follows:

Accepted answer: 0 points for kkgg12's comment http:/Q_27402364.html#36999308

for the following reason:

no comment i did a lot of troublshoot but could not solve it, i could not the reson behind this error, now again i am trying to intall exchange
0
kkgg12Author Commented:
ok please look into this error if find any solution please post me
0
sunnyc7Commented:
kkgg
I have solved that issue numerous times with EMTShooter PS script. I am not sure why you were not able to get it working. If you have formatted the system and you are reinstalling, I am not sure there is much you can do on at this point.
0
kkgg12Author Commented:
ok sunnyc7, whole night i tried to run EMT shooter but every time the same error was coming, i could not understand why it was not working , i am going to  new installation , i have already mention in question , my server was running properly when i have installed it, but after installation of 2 roles ,that error come , if you seen any other solution plz post me  i am wating from your side
0
sunnyc7Commented:
did you run this before running emt shooter ?
Run from Powershell
set-executionpolicy unrestricted
0
kkgg12Author Commented:
yes
0
e_aravindCommented:
I've used the below mentioned URL for these type of issues...

Troubleshooting Exchange 2010 Management Tools startup issues
http://blogs.technet.com/b/exchange/archive/2010/02/04/3409289.aspx
0
kkgg12Author Commented:
hi sir , to day i have formatted my system and installed fresh exchange server. i installed 2008 r2 server without any service pack with exchange 2010,i am sending screen shot please check it confirm me my exchange server is installed with service pack or not.now i have to go live my exchange so i have to installed routing and remote service but i am scaring if i will install this service and again same problem  repeat, so first i want to create a restore point of this server,for safety purpose. so please tell me is it possible or not and also confirm to me ,if i go to install routing and remote service ,then  my exchange server will work fine or not because you can see in screen shot this time its working fine
Untitled.jpg
0
RadweldCommented:
If your server has a raid 1 array for the is you can create an instant backup by removing one disk. If you need to go back you can remove the disk with the new OS and fo back to the old disk with the old OS on it. It's an instant restore point
0
kkgg12Author Commented:
no i have system without raid , then how it possible to create restore point. if any software available then tell me.
0
e_aravindCommented:
As per the Console, the server is installed with the RTM-Bits

Build numbers and release dates for Exchange Server
http://support.microsoft.com/kb/158530
Microsoft Exchange Server  2010                     14.00.0639.021
0
RadweldCommented:
You will need to install windows server backup feature and then using an external hard drive take a full backup of the exchange server. I wouldnt recommend installing routing and remote access on an exchange server. I think SBS comes with it but SBS has been tweaked to make all the elements work together.  
0
kkgg12Author Commented:
thanks sir, you have confirmed to me that i have install exchange server 2010 without service pack, but sir if i want to live my server with static ip then what  should i have to do, because without routing and remote access service , how can i route my public ip to private ip, i have no facilities in my modem ,so have you any idea regarding this problem,because i have to route my static i to local ip
0
RadweldCommented:
What kind of modem? Is this connected to adsl type connection? If so any router on the Market with a firewall will allow you to publish port 443 to the Internet and this will perform the natting for you. The exchange server also needs a static ip, now I realise this may have been dynamic this could have Been your original issue. More likely it was the RRAS as installing this components has a profound effect on the way traffic entered and exits the server.

It's bad practice to place the server directly connected to the internet because it would be prone to attack,Yes a
Inbuilt firewall will take steps towards protecting the server however i wouldn't trust it.

Review your network hardware and replace the modem for a router that replaces the need for RRAS
0
kkgg12Author Commented:
hi sir

now i have installed RRAS service and 4 to 5 times restart my server, my server is working fine with exchange 2010,so i want to close this question. if problem will come in next 2 or 3 days then i contact to you for support.

thanks & regards
0
kkgg12Author Commented:
thanks
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.