[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 829
  • Last Modified:

Cisco 3745 replacement

Greetings,

We're in the process of upgrading our infrastructure. We're adding new T1 circuits or upgrading existing circuits at our locations.

We have a 3745 at one location and it's details are given below. I've looked around and did my research - the only viable options that I found were the 3845 which is eol this fall and the 3945 which seems to be an overkill for our needs. We need to ppp multilink 4 T1 data only circuits with the ability to ssh into the router and maybe do some QOS. We're not looking to encrypt data or have any other bells and whistles.

Could some one suggest a good upgrade to the router without breaking the bank?

I appreciate your help in this matter.

Thanks
router#sh run
Building configuration...

Current configuration : 5186 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname router
!
logging queue-limit 100
logging console warnings
enable secret *******
enable password ********
!
username admin privilege 15 password *******
clock summer-time EDT recurring 2 Sun Mar 2:00 1 Sun Nov 2:00
ip subnet-zero
!
!
ip domain name mydomain.prv
ip name-server 192.168.1.1
ip name-server 192.168.1.2
!
ip dhcp-server 192.168.1.3
mpls ldp logging neighbor-changes
frame-relay switching
!
modemcap entry test:MSC=&F&D2S34=18000S40=10S54=172
!
no voice hpi capture buffer
no voice hpi capture destination
!
!
mta receive maximum-recipients 0
!
!
controller T1 0/0
 framing esf
 linecode b8zs
 channel-group 1 timeslots 1-24 speed 64
!
controller T1 0/1
 framing esf
 clock source internal
 linecode b8zs
 channel-group 1 timeslots 1-24 speed 64
!
!
!
interface Loopback0
 ip address 192.168.254.9 255.255.255.255
!
interface Tunnel1
 no ip address
!
interface FastEthernet0/0
 ip address 192.168.9.3 255.255.255.0
 ip helper-address 192.168.1.3
 speed auto
 full-duplex
 no cdp enable
!
interface Serial0/0:1
 no ip address
 encapsulation frame-relay IETF
 frame-relay lmi-type cisco
!
interface Serial0/0:1.96 point-to-point
 description ISP Business MPLS Circuit
 ip address X.X.X.X 255.255.255.252
 frame-relay interface-dlci 96 IETF
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 no cdp enable
!
interface Serial0/1:1
 no ip address
 no cdp enable
!
router ospf 1
 log-adjacency-changes
 redistribute static
 redistribute bgp 65005 subnets
 network 192.168.9.0 0.0.0.255 area 0
 network 192.168.254.9 0.0.0.0 area 0
!
router bgp 65005
 no synchronization
 bgp log-neighbor-changes
 network X.X.X.96 mask 255.255.255.252
 network 192.168.9.0
 network 192.168.254.9 mask 255.255.255.255
 redistribute connected
 neighbor X.X.X.97 remote-as 65000
 no auto-summary
!
ip nat translation timeout never
ip nat translation tcp-timeout never
ip nat translation udp-timeout never
ip nat translation finrst-timeout never
ip nat translation syn-timeout never
ip nat translation dns-timeout never
ip nat translation icmp-timeout never
no ip http server
ip classless
ip default-network 0.0.0.0
!
!
!
logging 192.168.1.9
access-list 2 permit Y.Y.Y.128 0.0.0.63
!
!
snmp-server view rtt-view sysUpTime included
snmp-server view rtt-view ciscoPingMIB included
snmp-server view rtt-view ciscoRttMonMIB included
snmp-server community ******* RW
snmp-server community ******** RO
snmp-server chassis-id *********
snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
snmp-server enable traps tty
snmp-server enable traps isdn call-information
snmp-server enable traps isdn layer2
snmp-server enable traps isdn chan-not-avail
snmp-server enable traps isdn ietf
snmp-server enable traps hsrp
snmp-server enable traps config
snmp-server enable traps entity
snmp-server enable traps envmon
snmp-server enable traps ds0-busyout
snmp-server enable traps ds1-loopback
snmp-server enable traps bgp
snmp-server enable traps pim neighbor-change rp-mapping-change invalid-pim-messa
ge
snmp-server enable traps ipmulticast
snmp-server enable traps msdp
snmp-server enable traps rsvp
snmp-server enable traps frame-relay
snmp-server enable traps frame-relay subif
snmp-server enable traps syslog
snmp-server enable traps rtr
snmp-server enable traps mpls ldp
snmp-server enable traps mpls traffic-eng
snmp-server enable traps mpls vpn
snmp-server enable traps cnpd
snmp-server enable traps dlsw
snmp-server enable traps pppoe
snmp-server enable traps atm subif
snmp-server enable traps dial
snmp-server enable traps dsp card-status
snmp-server enable traps ipmobile
snmp-server enable traps vtp
snmp-server enable traps vsimaster
snmp-server enable traps director server-up server-down
snmp-server enable traps voice poor-qov
snmp-server enable traps dnis
snmp-server enable traps xgcp
!
call rsvp-sync
!
!
mgcp profile default
!
!
!
dial-peer cor custom
!
!
!
rtr responder
banner login ^C
---------------------------------------------------------------------------

**WARNING**


You have accessed a restricted device.

Use of this device without authorization or for purposes for which authorization
 has not been extended is prohibited.

LOG OFF IMMEDIATELY.

Violators will be prosecuted to the full extent of the law.


**WARNING**

---------------------------------------------------------------------------
^C
!
line con 0
 exec-timeout 0 0
 logging synchronous
 login
 speed 115200
line aux 0
 login local
 modem InOut
 no exec
 transport preferred telnet
 transport input telnet
 transport output none
 stopbits 1
 flowcontrol software
line vty 0 4
 exec-timeout 3600 0
 privilege level 15
 password ********
 logging synchronous
 login local
 transport input telnet
!
end

router#sh ver
Cisco Internetwork Operating System Software
IOS (tm) 3700 Software (C3745-JS-M), Version 12.2(15)T2,  RELEASE SOFTWARE (fc2)
TAC Support: http://www.cisco.com/tac
Copyright (c) 1986-2003 by cisco Systems, Inc.
Compiled Thu 01-May-03 02:58 by nmasa
Image text-base: 0x60008954, data-base: 0x61E28000

ROM: System Bootstrap, Version 12.2(8r)T2, RELEASE SOFTWARE (fc1)

router uptime is 1 year, 18 weeks, 6 days, 1 hour, 52 minutes
System returned to ROM by power-on
System restarted at 09:26:05 EDT Tue Jun 8 2010
System image file is "flash:c3745-js-mz.122-15.T2.bin"

cisco 3745 (R7000) processor (revision 0.0) with 118784K/12288K bytes of memory.
Processor board ID
R7000 CPU at 350Mhz, Implementation 39, Rev 3.3, 256KB L2, 2048KB L3 Cache
Bridging software.
X.25 software, Version 3.0.0.
SuperLAT software (copyright 1990 by Meridian Technology Corp).
TN3270 Emulation software.
Primary Rate ISDN software, Version 1.1.
2 FastEthernet/IEEE 802.3 interface(s)
2 Serial network interface(s)
2 Channelized T1/PRI port(s)
DRAM configuration is 64 bits wide with parity disabled.
151K bytes of non-volatile configuration memory.
31296K bytes of ATA System CompactFlash (Read/Write)

Configuration register is 0x3922

router#

Open in new window

0
netcmh
Asked:
netcmh
  • 6
  • 3
1 Solution
 
Garry GlendownConsulting and Network/Security SpecialistCommented:
2900 series (which is pretty new and far from being EOS) should do. Well beyond the ~6mbit you can push through the T1. Maybe even a 1900 series, 1941. with its 2 HWIC ports, adding two 2T1E1 cards would provide for your WAN links, an additional services module could be used for additional features ...
0
 
netcmhAuthor Commented:
So, a 2911 c2900-universalk9-m IOS15.0 with 2 VWIC2s or 4 HWICs would be optimum for our need?
0
 
netcmhAuthor Commented:
Need affirmation. Thanks
0
 [eBook] Windows Nano Server

Download this FREE eBook and learn all you need to get started with Windows Nano Server, including deployment options, remote management
and troubleshooting tips and tricks

 
Garry GlendownConsulting and Network/Security SpecialistCommented:
Just checked, there's also a 4 port T1/E1 HWIC, check this document for some details. Couldn't find confirmation at the moment whether it's compatible with 2900 series, but I would believe so ... do check with your distributor before ordering though ...
0
 
netcmhAuthor Commented:
So, a 2911 c2900-universalk9-m with IOS15.0 with 2 VWIC2s or 4 HWICs would be optimum for our need? :)
0
 
netcmhAuthor Commented:
? :)
0
 
Garry GlendownConsulting and Network/Security SpecialistCommented:
Performance should be more than sufficient, an the HWIC-4T1E1 should cover your lines nicely ... (though I believe it's no channelized card, so not usable e.g. for ISDN dialin on a PRI link - which isn't necessary for your setup)
0
 
netcmhAuthor Commented:
You're right in that assumption. Thanks Garry-G!
0
 
netcmhAuthor Commented:
Thanks, just what I needed.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 6
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now