How do I fix missing ActiveSync and other folders following hard repair of Exchange 2007 db?

A customer site's only  Exchange 2007 (SBS) db dismounted. There were no backups. I did a hard repair, defrag and isinteg. Isinteg was clean except for ~400 folder errors. I "repaired" the folder errors and was able to mount the db. I did backups between each repair step.

1. I see numerous event 1008's, MSExchange ActiveSync. including these lines:

Exception type: Microsoft.Exchange.Data.Storage.FolderSaveException,.
Exception message: Unable to save sync state folder Autd due to PartiallySucceeded, Property = [0x7c020102] SyncCustomState, PropertyErrorCode = MapiCallFailed,

Most of these users are getting Outlook mail but nothing on their iPhones. I tried disabling and enabling ActiveSync on their accounts to no avail.

2. At least one user can't save a Junk mail rule because there is no place to store it.

3. At least one user can't start Outlook at all: "Cannot start Microsoft Outlook. Cannot open the Outlook window. The set of folders cannot be opened. The folder you specified cannot be found."

Is there a way to rebuild the missing folders?
digitalsoupOwnerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

PradeepCommented:
Check activesync connectivity using https://www.testexchangeconnectivity.com/ and post the results here.
0
digitalsoupOwnerAuthor Commented:
Testexchageconnectivity is all green for all mailboxes, syncing or not.

Issue 3 is resolved for both users. I bought an ost to pst converter and rebuilt their mailboxes.

I really think it is a missing folder issue but am not sure how to fix it. I created another db and am moving one of the problem mailboxes right now. Will post the result.
0
digitalsoupOwnerAuthor Commented:
Creating a new db and moving the mailboxes resolved the ActiveSync issues for all users.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
digitalsoupOwnerAuthor Commented:
Came up with my own solution. Doesn't seem to be a very common problem.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.