[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

[SBS 2011] Slow DHCP

Posted on 2011-10-18
10
Medium Priority
?
3,049 Views
Last Modified: 2012-08-14
I have a SBS 2011, this is also the DHCP server for us.

I have problem with some PC's (most Windows 7). It takes a long time to start Windows and sometimes is the pc also slow by working. When the PC starts: 'Please wait' stuck for a long time. I think it is a DHCP / DNS problem. Can someone help me?

SETTINGS:

I have the following dhcp scope:
Start IP address: 172.16.0.1
End IP address: 172.16.3.254
Lease duration is limited to: 2 days
Enable DNS dynamic updates is turned of
Network Access Protection is disabled for this scope
On the tab 'Advanced': Assign IP addresses dynamically to clients of: DHCP

Address Pool: 172.16.0.1 - 172.16.3.254 (Address range for distribution)
172.16.0.20 - 172.16.0.60, 172.0.61 - 172.16.0.75, 172.16.0.200 - 172.16.0.220, 172.16.0.1 - 172.16.0.12 (IP addresses excluded from distribution)

The following reservations: 172.16.0191, 172.16.0.114, 172.16.0.91, 172.16.0.88

Scope options:
003 Router 172.16.0.1
006 DNS Servers 172.16.0.200 (SBS Server)
015 DNS Domain Name (Our domain.local)
044 WINS/NBNS Servers 172.16.0.200
046 WINS/NBT Node Type 0x8

IPV6 is also enabled in DHCP (00023 DNS Recursive Name Server and 00024 Domain Search List)

I have the following DNS settings on the SBS 2011 server:
Listen on: Only the following IP adresses (ipv6 address & 172.16.0.200 (SBS SERVER))
Forwarders: 8.8.4.4 (google) and 208.67.220.220 (opendns)

Sorry for my bad english...
0
Comment
Question by:Program1981
10 Comments
 
LVL 6

Expert Comment

by:Elwin3
ID: 36986734
ok to confirm it is the DHCP causing the problem assign a PC a static IP address and reboot it. Is it still slow then?
0
 
LVL 38

Accepted Solution

by:
Hypercat (Deb) earned 1000 total points
ID: 36988244
Your English is fine!  A couple of other suggestions:

1.  You should remove the WINS/NBNS server options from your DHCP scope options.  SBS 2011 does not run WINS by default, so unless you've purposely installed WINS, those entries would not be necessary and might possibly cause some slowness. Windows XP, Windows Vista and Windows 7 do not use WINS.

2.  Is it just a typo, or does your DHCP scope really include 176.16.0.1 through 176.16.3.254?  That's a HUGE number of hosts for an SBS domain.  Normally, you would have a scope of 176.16.0.1 through 176.16.0.254.

3.  Try removing the forwarders from your DNS settings, and see if that improves things at all.  This type of slowness is much more likely to be caused by DNS than by DHCP.
0
 
LVL 78

Assisted Solution

by:Rob Williams
Rob Williams earned 1000 total points
ID: 36988475
I would agree with hypercat on all accounts especialy; "This type of slowness is much more likely to be caused by DNS "
On a problematic workstation run ipconfig /all   and verify DNS points ONLY to your SBS server. This problem is very common when someone adds a router or ISP as an alternate DNS server.
0
A Cyber Security RX to Protect Your Organization

Join us on December 13th for a webinar to learn how medical providers can defend against malware with a cyber security "Rx" that supports a healthy technology adoption plan for every healthcare organization.

 

Author Comment

by:Program1981
ID: 36989055
Thanks for all the answers!

1. I'll remove the WINS/NBNS options ASAP.
2. The scope is a bit to much, but 0.1 - 0.254 is not enough. We have a lot of people with multiple devices.
3. I want to try to remove the forwarders and I will check all the DNS settings on the server and clients. I remember I need that forwarders for faster Internet on the clients. You think that's not necessarily?

Many Thanks!!
0
 
LVL 78

Expert Comment

by:Rob Williams
ID: 36989411
You have this in the SBS topic area. SBS is limited to 75 users, are you sure you have more than 254 devices?
Also SBS 2008/2011 does not support a non 255.255.255.0 subnet mask (.x.1 to x.254 subnet), so I suspect if you run the network wizards and/or BPA they will fail. "The NIC must use a private IP address with a 255.255.255.0 subnet mask. " see:
http://blogs.technet.com/b/sbs/archive/2008/09/16/sbs-2008-supported-networking-topology.aspx

Fowarders are not a problem, but the forwarders you have choosen could be. Some respond faster than others. I think Hypercat was suggesting try removing them and use root hints (SBS default) as a test.
0
 

Author Comment

by:Program1981
ID: 36991645
I removed the forwarders and it looks like better on the pc's. I have only trouble now with 2 (Windows 7) pc's.

one pc stucks at 'wait a moment' and one pc lose his connection sometimes. I'll try to solve that.

We have about 40 users and most of people have a iphone and laptop. Also all our telephones (about 50) are connected in our network. The pc have a UPT connection with the telephone.

I have checked the ip lease and there are about 180 ip adresses in use. I can reduce the DHCP scope. I know SBS 2011 have a default subnet mask 255.255.255.0, but I have changed that manually.
I don't use the network connection wizard, it shows a DHCP scope 'error' indeed.

The problem is: I am an software engineer (VS 2010) and about six months ago they ask me to manage the network. I'll do my best, but sometimes I realize my knowledge is not so much as I want. I learn very quickly :-)
0
 

Author Comment

by:Program1981
ID: 36992202
It looks like the problems are solved!

We did a flushdns on the first pc and the problems are gone. Please wait takes about 30 seconds before we can log in to the domain. That's ok.
0
 
LVL 78

Expert Comment

by:Rob Williams
ID: 36992432
Your IP phones should really be on a separate VLAN and could use a different subnet freeing up IP's
0
 
LVL 78

Expert Comment

by:Rob Williams
ID: 36992433
Your IP phones should really be on a separate VLAN and could use a different subnet freeing up IP's
0
 

Author Comment

by:Program1981
ID: 36992449
Yes, I know. I realise that by myself yesterday.
Thanks for the suggestion.
0

Featured Post

NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Because virtualization becomes more and more common, and, with Microsoft Hyper-V included in Windows Server at no additional costs, and, most server hardware nowadays is more than capable of running a physical Small Business Server (SBS) 2008 or 201…
Resolve DNS query failed errors for Exchange
Loops Section Overview
Screencast - Getting to Know the Pipeline
Suggested Courses

831 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question