• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1693
  • Last Modified:

cannot ping cisco AP 1131 on trunk

I have a cisco access point 1131 with 2 vlans hooked up my cisco 4500 switch on a trunk.  I am unable to ping the AP but the ssid's work and I am able to get network connectivity when connecting to them.  Below is part of the switch config and the AP config, what am I doing wrong?
aaa new-model
!
!
aaa authentication login default local
!
aaa session-id common
ip domain name test.local
!
!
dot11 syslog
!
dot11 ssid GUEST
!
dot11 ssid Guest
   vlan 65
   authentication open
   authentication key-management wpa
   mbssid guest-mode
   wpa-psk ascii 7 *
!
dot11 ssid OPS
   vlan 50
   authentication open
   authentication key-management wpa
   mbssid guest-mode
   wpa-psk ascii 7 *
!
!
!

!
!
bridge irb
!
!
interface Dot11Radio0
 no ip address
 no ip route-cache
 !
 encryption vlan 65 mode ciphers aes-ccm tkip
 !
 encryption vlan 50 mode ciphers aes-ccm tkip
 !
 ssid Guest
 !
 ssid OPS
 !
 mbssid
 station-role root
 bridge-group 1
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
 bridge-group 1 spanning-disabled
!
interface Dot11Radio0.50
 encapsulation dot1Q 50
 no ip route-cache
 bridge-group 50
 bridge-group 50 subscriber-loop-control
 bridge-group 50 block-unknown-source
 no bridge-group 50 source-learning
 no bridge-group 50 unicast-flooding
 bridge-group 50 spanning-disabled
!
interface Dot11Radio0.65
 encapsulation dot1Q 65
 no ip route-cache
 bridge-group 65
 bridge-group 65 subscriber-loop-control
 bridge-group 65 block-unknown-source
 no bridge-group 65 source-learning
 no bridge-group 65 unicast-flooding
 bridge-group 65 spanning-disabled
!
interface Dot11Radio1
 no ip address
 no ip route-cache
 shutdown
 dfs band 3 block
 channel dfs
 station-role root
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
 bridge-group 1 spanning-disabled
!
interface FastEthernet0
 no ip address
 no ip route-cache
 duplex auto
 speed auto
 bridge-group 1
 no bridge-group 1 source-learning
 bridge-group 1 spanning-disabled
 hold-queue 160 in
!
interface FastEthernet0.50
 encapsulation dot1Q 50
 no ip route-cache
 bridge-group 50
 no bridge-group 50 source-learning
 bridge-group 50 spanning-disabled
!
interface FastEthernet0.65
 encapsulation dot1Q 65
 no ip route-cache
 bridge-group 65
 no bridge-group 65 source-learning
 bridge-group 65 spanning-disabled
!
interface BVI1
 ip address 192.168.25.41 255.255.255.0
 no ip route-cache
!
ip http server
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
bridge 1 route ip
!
!

end

Open in new window

switch
interface GigabitEthernet2/21
 description trunk to AP
 switchport mode trunk
 switchport voice vlan 100
 qos trust device cisco-phone
 spanning-tree portfast

Open in new window

0
mmercaldi
Asked:
mmercaldi
  • 4
  • 3
1 Solution
 
SouljaCommented:
Which vlan does your BVI sit on?
0
 
SouljaCommented:
I think you need to configure a default gateway on your AP?
0
 
mmercaldiAuthor Commented:
ya I was just noticing that Soulja, and that IP by the way is on vlan 50.  I will be able to do that in like 20 minutes or so
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
SouljaCommented:
Ok
0
 
mmercaldiAuthor Commented:
i just put in the default gateway ip 192.169.25.243 which is the correct IP and its not working
0
 
mmercaldiAuthor Commented:
i should note that the AP cannot ping the default gateway
0
 
SouljaCommented:
Can you remove the qos trust command and the voice vlan command. Why are those there on the switch port connecting to the AP?

On your interfaces:

interface Dot11Radio0.50
and
interface FastEthernet0.50

add

encapsulation dot1Q 50 native

on the switchport connecting to the AP

add

switchport trunk encapsulation dot1q
switchport trunk native vlan 50

0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now