Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

OWA login screen keeps popping up

Posted on 2011-10-18
2
Medium Priority
?
944 Views
Last Modified: 2012-05-12
I am having this issue with only one user:
They are running Outlook 2007 on an exchange 2010 server.  Every 10 minutes or so they seem to be getting disconnected from the Exchange server.  When this happens, an OWA box pops up asking for credentials.  If you close outlook and reopen it, then it reconnects and works fine.  There are no other network issues.
0
Comment
Question by:suzanne2003
2 Comments
 
LVL 16

Expert Comment

by:Madan Sharma
ID: 36987671
please check which type of authentication is using by outlook NTLM or basic. is it the same as exchange server. please have look at http://www.experts-exchange.com/Software/Server_Software/File_Servers/Active_Directory/Q_27402007.html?cid=1573#a36985162
0
 
LVL 8

Accepted Solution

by:
I Qasmi earned 2000 total points
ID: 36994600
Outlook continually prompting for username and password

There have been a lot of questions recently regarding Outlook prompting for a username and password whilst using Exchange 2007. There are a few reasons why this would happen and I will try to cover the most common ones here.

Exchange 2007 Service Pack
There was an issue with repeated password prompts that was resolved by installing Rollup 9 for Exchange 2007 SP1, however I would recommend that you should now be using Exchange 2007 SP2 since it has been around since August 2009: http://www.microsoft.com/downloads/details.aspx?FamilyID=4C4BD2A3-5E50-42B0-8BBB-2CC9AFE3216A&displaylang=en

If you are in an Small Business Server 2008 environment and not yet using Exchange 2007 Rollup 9 you can also install SP2 for Exchange 2007 with the aid of the Installation Tool, available here: http://support.microsoft.com/default.aspx?scid=kb;EN-US;974271

Autodiscover
If that doesn’t fix the repeated prompt for password then it could be down to the autodiscover if your using Outlook 2007 then you must configure autodiscover correctly. There are many articles out there that cover the correct way to configure autodiscover, one of the better ones I have found is this one: http://www.exchange-genie.com/2007/07/exchange-2007-autodiscover-service-part-1/

However the part that most people are missing is the autodiscover.domainname.com (where domainname.com) is the part after the @ in your e-mail address. Newer versions of outlook will look for this for OAB download, free/busy information, Out of Office etc etc. If it’s not there then outlook will continually give user prompts. To accompany this you must have an SSL Certificate that contains the autodiscover.domainname.com URL (whilst you can configure ways around this, it really isn’t worth all the hastle). So purchasing an SAN/UCC Certificate with the following names in is a must for Exchange 2007 and Exchange 2010:

autodiscover.domainname.com
owa.domainname.com (the URL used for Outlook Web Access)
servername.domainname.local (the internal FQDN of your Exchange Server)
SERVERNAME (NETBIOS Name of your Server)
If you have not yet purchased an SSL Certificate I can recommend http://www.exchangecertificates.com/ as a cost effective product that is fully supported.

You must also have the coresponding autodiscover.domainname.com and owa.domainname.com A records configured in your external DNS

Kernel authentication Mode
If you have all the above configured and you are still experiencing problems then the following procedure will more than likely fix it for you. It has been working a lot for me lately and also for people asking questions on Experts Exchange.

In Internet Information Services (IIS) Manager locate the Exchange virtual directories, if you are using Small Business Server 2008 these will be under the SBS Web Applications website, if your not using SBS then they will be under the Default Website.

The virtual Directories you are looking for are:

Autodiscover
EWS
RPC
OAB
In turn highlight each of these virtual directories and double click the Authentication icon on the right hand side. Right click on Windows Authentication and select Advanced Settings. Place a check box in the box for Enable kernel-mode authentication. Do this for each virtual directory listed above.

0

Featured Post

Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

MS Outlook undoubtedly is the most widely used email client.Its user-friendliness, cost effectiveness, and availability with Microsoft Office Suite make it the most popular email application.  Its compatibility with Microsoft applications like Exch…
Often, the users face difficulty in accessing Outlook 2016 PST files on Windows 10 computer. One of the reasons behind it is the improper functioning of MS Outlook when the user tries to open it. MS Outlook suddenly stops working, or it will not op…
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…
Many of my clients call in with monstrous Gmail overloading issues with Outlook. A quick tip is to turn off the All Mail and Important folders from synching. Here is a quick video I made to show you how to turn off these and other folders in Gmail s…
Suggested Courses
Course of the Month11 days, 4 hours left to enroll

572 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question