• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2811
  • Last Modified:

windows XP file share access stopped working after disabling SMB2 on SBS 2008 SP2

A software vendor recommended we disable SMB2 on our windows 2008 server to resolve an application problem.  After disabling SMB2 on the server and the windows 7 PCs and rebooting a few times the windows xp computer can no longer access the file shares.  I have tried enabling SMB2 on the server and windows 7 work stations again, rebooting many times, repairing the network adapter etc.  i can ping the servers ip and name, I just cannot connect to the network drives.

file sharing still works on all the windows 7 computers.

0
tjscomp
Asked:
tjscomp
  • 4
  • 4
3 Solutions
 
zazagorCommented:
Hi,

Try removing the computer from the AD (or workgroup?) and re-adding it again.

//zazagor
0
 
scrabyCommented:
smb2 is server message block version 2 protocol which is responsible for file and printer sharing.  it uses tcp ports 139 and 445.  xp does not support smb 2 but only smb 1, however server 2008 is backwards compatible.  i don't know my way around 2008 very well but i would check to see if there is anything about smb 1 in services or server manager.  also try removing and reinstalling file and printer sharing in xp machine under network connection and properties of the wired connection (start > run > ncpa.cpl)

some info about it but disregard the disabling portion

http://www.petri.co.il/how-to-disable-smb-2-on-windows-vista-or-server-2008.htm
0
 
scrabyCommented:
you can also try to telnet to the server's ip address using port 139 and 445 to see if they are open. from the xp machine open a command prompt (start > run > cmd) and type

telnet 192.xxx.xxx.xxx 139  and hit enter (that is a space between the ip and port) if the port is open then you will get a black screen that you can't do much with, if the port is closed then telnet will tell you it could not establish the connection, try the same from the xp machine again on port 445.

by the way, do you get some sort of error message when you try to find a share with the unc.....\\servername\sharename ? or \\192.xxx.xxx.xxx\sharename (to bypass dns)
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
tjscompAuthor Commented:
So I have now isolated the problem to user/me trying to be lazy.  I setup 2 login scrips one for win 7 user one for xp.  Well a win 7 user logged into the win xp computers.  Me being lazy had put the command to disable smb2 on windows 7 in the kixstart script for win7, thus executing these 2 commands on all 4 windows xp computers on the network.  anyone know how to undo what was executed?  BTW I am not the user, I know better.

commands that were executed:
sc config lanmanworkstation depend= bowser/mrxsmb10/nsi
sc config mrxsmb20 start= disabled

i did try the above I cannot remove the computers from the domain(AD) the change name has the error: Rather Note: The identification of the computer cannot be changed because:
 - Networking is not installed or is not properly configured.

I have tried Sfc /scannow
i have re installed TCP/ip forcefully
i have removed client for MS networks and file and print sharing and re installed.
for the above I rebooted several times between each to see if they worked.

let me know your thoughts and thank you for the help.
0
 
scrabyCommented:
have you tried system restore (sfc /scannow restores system files but not the registry)?

looks like the first sc config changes the servicename "lanmanworkstation" to depend on smb1.0 and the second sc disables the start for smb 2.0  check below for description

http://technet.microsoft.com/en-us/library/cc990290(WS.10).aspx

did you just insert the sc commands in the script from the link above or have they been in there for a while?  i would try system restore to prior to the w7 script running on xp.  since xp does not support smb 2.0 then i'm not sure how running this script would affect the machine.  have you tried typing the commands in manually on one of the stations to see what the result is?

you need to check to see if you can get to port 139 and 445 on the server from these machines because in the original question you said you could ping the server which means that tcp/ip is working.  have you checked the firewall on the xp stations to see if the are allowing file and printer sharing which opens ports 139 and 445, you may even try manually opening the ports.  again if everything was working and then it stopped then i would try system restore first.  i would also share a folder on one xp machine and see if you can get to it from another.
0
 
tjscompAuthor Commented:
I cant try system restore it was disabled due to low disk space.  UGH!

This was just done last friday, so the problem didn't start till tuesday morning.  1st reboot was ok changes were implimented, 2nd reboot no network drives.  I didn't think it should have effected the machine either since the protocol isn't supported, but it did.

I can telnet to those ports, I forgot to mention on my prior post.  All Firewalls are disabled internally, NIS and windows.

I did find a way to fix it on one of the computer tho I am not looking forward to 3 more that is an inplace upgrade of windows XP, then install SP3, IE8 and then hours of windows Updates, Computer #1 is almost back to working again, 3 more to go Thursday unless there is a quicker better way to fix it.
0
 
scrabyCommented:
that's a lot of work.  are the pc's identical? if this worked on one and the pc's are identical then take and image of the working one and dump it on the other three.  what do you mean by almost back to working again? did you try sharing folders and trying to access them between the two workstations not going to the server?  what message do you get when you try the unc path to a share?  have you tried the administrator share........\\computername\c$
0
 
tjscompAuthor Commented:
Scraby,

Sorry for the long delay, been swamped with things since this happened and really held me up.  I didn't have the luxury of waiting any longer to play around trying to actually find the quick fix, just pushing through and doing in place upgrades worked so that was the fix.

Yes it was alot of work but got things up and running again.  I did also have to remove the windows printer and file sharing, reboot then re install.  Other than that was pretty straight forward once I found what worked.

By almost up and running on the first system, I meant running countless windows updates after in place upgrade.

Thanks for the help.
0
 
tjscompAuthor Commented:
Was pointed in the right direction by comments.  Took it from there.  What the final fix was I documented and posted as the final post.
0

Featured Post

Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

  • 4
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now