SharePoint Top Link Bar Navigation Broken

We have a subsite in SharePoint that appears in the Top Link Bar of the parent site.  I know that it worked at one time, but now, the tab is pointing to a broken link.  I looked into it, and the tab is pointing to this address:
site/SitePages/Home.aspx
This page doesn't exist.  It should be pointing to this address:
site/default.aspx

If I go to View All Site Content and click on the link to the subsite, it goes to the right place.  Any suggestions to get the navigation tab to point to the correct address?
MSECAsked:
Who is Participating?
 
TEEDACommented:
You can manually add the page address to the end of the site address in the welcome page screen(I've had to do this in SP 2010 in the last couple of days when creating a site from a site template, but it happened immediately upon site creation).  In a team site, the default page is in the root of the subsite (at least in 2007) and in a publishing site, it's in the Pages folder.  Are you creating from a site template? In 2007 or 2010?
0
 
TEEDACommented:
You can edit the Global navigation in Site Settings/ Navigation and either edit the existing link or delete the broken one and create a new one.
0
 
MSECAuthor Commented:
The problem is that it is a subsite, so it won't let me change the link.  I can only Show or Hide the link.  What I've done for a temporary solution is to hide the link and create a new heading with the correct link, but the actual site link is still wrong.
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

 
TEEDACommented:
I guess that will work for now. The interesting question is why it was broken to begin with. I wonder if the Site Pages/Home.aspx was set as the default page for that site originally, but changed at some point.  Usually the default home page is in the Pages folder. You could try going to site settings for the subsite, and manually setting the Welcome page to site/default.aspx and see if that corrects the original link.
0
 
MSECAuthor Commented:
How do I set the welcome page?
0
 
TEEDACommented:
in the browser, go to Site Actions, Site Settings, Modify All Site Settings.  Under the Look and Feel Column, you will see Welcome Page - that will allow you to manually set the path to the welcome page for that site.
0
 
MSECAuthor Commented:
That's odd.  I don't have that option.  Is it a feature I need to activate? Look and Feel section
0
 
TEEDACommented:
Perhaps it's not available due to permissions? You may need higher permissions than you have.
0
 
MSECAuthor Commented:
I'm the site collection and farm admin.  There are no higher permissions.
0
 
TEEDACommented:
Wish I could help more, but I'm stumped. Hope an expert can figure out what is causing this.
0
 
MSECAuthor Commented:
Thanks for the suggestions.
0
 
MSECAuthor Commented:
When I turned on the publishing feature, the Welcome Page link appeared.  However, the welcome page address does not include the actual page address, just the site address, so that didn't help me.  
Also, we've had a second site start exhibiting this behavior.  This morning, the tab on the top link bar was working perfectly until all of a sudden it wasn't, with no provocation that I can see.
0
 
MSECAuthor Commented:
Thanks.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.