[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 11703
  • Last Modified:

CISCO SIP phone not registering with call manager

Hello Experts,

I have a CISCO SIP IP Phone SPA504G with SIP enabled. I am attempting to get it to register with the Cisco call manager. I am running CM 8.01.

I have created the sip user ID and password. Assigned it basic third part SIP protocol. I do have sufficient licenses. I have also assigned a DN to the phone.

I am getting error 404 failed on the screen of the SIP phone. I checked the call manager under the SIP phone device and it is showing under device information registration rejected.

I have double checked all of the user ID's to make sure that they match between the CM and the sip phone. I suspect the sip phone isn't able to register with the call manager.

Any ideas?
0
TNRD
Asked:
TNRD
  • 5
  • 4
1 Solution
 
José MéndezCommented:
Most likely the phone is sending the line as the user, make sure the user is correctly configured. If you upload a packet capture from the CallManager, I may help you better. Here is a guide:

https://supportforums.cisco.com/docs/DOC-11599

Hope it helps.
0
 
TNRDAuthor Commented:
Hi,

I tried running the RTMT as per the document guide. When I try to capture packet logs it doesn't appear anything is getting captured. This is the output:

Collect Files in progress for node tnrdcucm
No files matched the date Range for node tnrdcucm

I made sure the Packet Capture Logs check box was checked off. Is the call manager not configured to be capturing?
0
 
José MéndezCommented:
Follow step 1 through step 4b first
0
Configuration Guide and Best Practices

Read the guide to learn how to orchestrate Data ONTAP, create application-consistent backups and enable fast recovery from NetApp storage snapshots. Version 9.5 also contains performance and scalability enhancements to meet the needs of the largest enterprise environments.

 
TNRDAuthor Commented:
Packet capture of the sip device attached.
Thanks

packets.txt
0
 
José MéndezCommented:
Ok, its actually using the username as the CallManager Directory Number:

From: "U2500" <sip:U2500@172.16.30.10>;tag=451f58fe996e8a18o0
To: "U2500" <sip:U2500@172.16.30.10>

The username is sent ok, but the line is not. Don't have an SPA around, but you need to find where to change the line.
0
 
TNRDAuthor Commented:
I took a look through the manual. I can't seem to find anything regarding authentication with the username instead of the line. I have attached some screen shots of the phones configuration tabs. (SIP and the EXT tabs).
Sip-phone.docx
0
 
José MéndezCommented:
On Extension 1 page, change the Auth ID to U2500 --> CallManager user account, change the User ID to the extension number in CallManager, and change Use Auth ID to value yes
0
 
TNRDAuthor Commented:
Thank you sir! Changed the U2500 to 2500 in the call manager and the SIP phone. Changed Auth ID field to 2500 and the value to yes. The phone is now functioning!

0
 
José MéndezCommented:
Great to hear that.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 5
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now