?
Solved

Manage Intel RAID on ESXi 5.0 Server using Intel RAID Web Console 2

Posted on 2011-10-18
11
Medium Priority
?
4,928 Views
Last Modified: 2012-05-12
I have installled ESXi 5.0 on a computer with an Intel RAID saswt4i card. The computer has a RAID 1 (mirrored) drive.  I am running the vSphere Hypervisor on another computer on my network, a Windows system.  vSphere works fine, I have installed guests.  I believe that the Intel RAID card is working properly.

RAID Web Console 2 is running on the Windows system and I want to communicate with the RAID card in the ESXi system. I want it to confirm that it rebuilds from a hot spare when I test it by unplugging a drive cable.  When I run RAID Console 2 and give it the IP of the ESXi server it says "no servers found".  The Intel web site has some info, http://communities.intel.com/message/74217 says to open port 3071 in the ESXi firewall.  

Within ESXi I went to the host system configuration, firewall, and added "gdbserve", which appears to open ports 1000 to 9999 for TCP.  I do not see a way to open only port 3071.  The 4.0 CLI commands for firewall port settings don't work.

There is a similar question for ESXi 4.0, one person said they did resolve the problem, but there were no details.



0
Comment
Question by:richard_roloff
  • 6
  • 5
11 Comments
 
LVL 124
ID: 36989141
This is how you create custom rule sets for the ESXi 5.0 firewall
http://www.virtuallyghetto.com/2011/07/how-to-create-custom-firewall-rules-in.html

Usually to monitor RAID rebuild and status in ESXi, you need to have agents installed in the ESXi server. HP, Dell and IBM have OEM versions of ESXi, which have CIM Providers, which shows status of the RAID, under Health Status or Hardware Status.

I'm not certain this will work, and you will not be able to monitor RAID status on ESXi.
0
 
LVL 124
ID: 36989146
The article in the link you have specified, refers to Windows 2008 R2, and not ESXi.
0
 

Author Comment

by:richard_roloff
ID: 37352918
Since the original posting I have made some progress, but the RAID Web Console (running on a Windows system) still cannot find the VMware ESXi 5.0 host with the Intel RAID card.
The Intel RAID card RS2BL040 appears to be the same as an LSI 9260-4i.
The VMware Compatibility Guide shows, for ESXi 5.0, "megaraid_sas version 4.32-1vmw" as the device driver, for both the Intel part number and the LSI part number.
I have installed two "vib" files on the ESXi host, downloaded from

http://www.lsi.com/channel/products/storagecomponents/Pages/MegaRAIDSAS9260-4i.aspx.

The files installed on the host and the ESXi host. Under Configuration, Health Status, Storage, vSphere  identifies the RS2Bl040 controller by name, and lists battery, two drives, a RAID volume, and two ports.
I installed Intel RAID Web Console 2 on my Windows Vista system, I took down the firewalls on both systems, but I cannot get RWC2 to find the server.
I can ping both ways.  How do I troubleshoot this further?


0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
LVL 124
ID: 37352984
0
 
LVL 124
ID: 37353009
also note, that you are using an OEM Intel card, that has an Intel BIOS, that may not have the same feature set as a retail LSI SAS card. We use retail LSI products.
0
 

Author Comment

by:richard_roloff
ID: 37361840
The GUI is still failing but I have found an acceptable workaround.

The GUI products from LSI and Intel, "MSM" and "RWC2", cannot find the host system. The documentation from LSI and Intel is vague regarding GUI support for ESXi 5.0.  

LSI provides a command line interface called MegaCli.  I downloaded  MegaCLI 8.03.16 (which lists  ESXi 5.0 as a supported OS) and copied MegaCli to my VMware host system.  On the host, $PATH is /bin:/sbin, and when MegaCli is copied (no vib install required) to either of these directories, it works.  For example
# MegaCli -adpCount
Controller Count: 1.
Exit Code: 0x01
I have not yet found the User Guide for MegaCli on the LSI website, but I expect LSI support will respond to my help request. Hopefully, a future release of the GUI will work too.
So there is a working remote management solution for the LSI/Intel RAID card for ESXi 5.0.
Note:  the two "vib" files that I indentified in an earlier posting to this thread are required.

Case Closed.
0
 
LVL 124
ID: 37361871
MegaCLI supports many OS. Usually documentation is provided by the vendor for MegaCLI.
0
 

Author Comment

by:richard_roloff
ID: 37391096
I've requested that this question be closed as follows:

Accepted answer: 0 points for richard_roloff's comment http:/Q_27403287.html#37383425

for the following reason:

I found intormation on other sites that led me to a solution.
0
 
LVL 124

Accepted Solution

by:
Andrew Hancock (VMware vExpert / EE MVE^2) earned 1500 total points
ID: 37391097
I have to disagree and object, in http:#a37361840 you state

"The GUI is still failing but I have found an acceptable workaround.

The GUI products from LSI and Intel, "MSM" and "RWC2", cannot find the host system. The documentation from LSI and Intel is vague regarding GUI support for ESXi 5.0.  

LSI provides a command line interface called MegaCli."


In the Recent VMware Knowledgebase Article which was published after you submitted your question, that I have provided in http:#a37352984

KB Article: 2004166, Updated: Nov 11, 2011 there is a reference to MegaCLI

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=2004166

Plan for Supporting the vSphere 5.0 ESXi Architecture

MegaCLI provides a command-line interface for managing MR controllers. MegaRAID Storage Manager (MSM) is a GUI application, the backend of which runs as a daemon installed in the ESX Console OS.
MegaCLI

On ESXi 5.0, MegaCLI runs in the technical support shell as a userworld application. This approach was selected to maximally retain the existing user experience and MegaCLI commands. MegaCLI on ESXi 5.0 retains the string-in/string-out data format to avoid breaking existing OEM/customer scripts that parse current CLI output.


I posted this information on the 30th November 2011, 2nd December you state LSI Provides MegaCLI......
0
 

Author Closing Comment

by:richard_roloff
ID: 37391115
The GUI still doesn't work.
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

HOW TO: Connect to the VMware vSphere Hypervisor 6.5 (ESXi 6.5) using the vSphere (HTML5 Web) Host Client 6.5, and perform a simple configuration task of adding a new VMFS 6 datastore.
In this article, I will show you HOW TO: Suppress Configuration Issues and Warnings Alert displayed in Summary status for ESXi 6.5 after enabling SSH or ESXi Shell.
Teach the user how to edit .vmx files to add advanced configuration options Open vSphere Web Client: Edit Settings for a VM: Choose VM Options -> Advanced: Add Configuration Parameters:
This Micro Tutorial walks you through using a remote console to access a server and install ESXi 5.1. This example is showing remote access and installation using a Dell server. The hypervisor is the very first component of your virtual infrastructu…
Suggested Courses

850 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question