• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 736
  • Last Modified:

Configure Cisco 2851 router for new IP block and bandwidth upgrade

We currently have a 20Mb Verizon Ethernet connection through our 2851 router, and just 2 external IP addresses.  We have been assigned a new IP block (65.199.167.160 255.255.255.248) and are also being upgraded to a 30Mb pipe.  Where Verizon has done any necessary router configs in the past, they now tell me they don't do that.

For the new IP block, which interface to I modify, and do I just replace IP information?

Also, for the bandwidth upgrade, do I just change the 20000 to 30000 in the line below?
>> scheduler allocate 20000 1000

Thanks for any help on this.  Here is the full config:

version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
boot-start-marker
boot-end-marker
!
no aaa new-model
!
resource policy
!
clock timezone EST -5
clock summer-time EDT recurring
ip subnet-zero
!
ip cef
no ip dhcp use vrf connected
!
no ip domain lookup
ip name-server 198.6.1.2
ip name-server 198.6.100.53
no ip ips deny-action ips-interface
!
no ftp-server write-enable
!
interface GigabitEthernet0/0
description *** Connected to local switch for the OUTSIDE LAN ***
ip address xx.xxx.xx.xxx 255.255.255.252
no ip mroute-cache
load-interval 30
duplex auto
speed auto
!
interface GigabitEthernet0/1
description To VerizonBusiness WAN
no ip address
load-interval 30
duplex full
speed 100
no keepalive
!
interface GigabitEthernet0/1.1
encapsulation dot1Q 2576
ip address yyy.yyy.yy.yy 255.255.255.252
no snmp trap link-status
!
interface ATM1/0
description *** Circuit ID # ***
no ip address
shutdown
atm scrambling cell-payload
no atm ilmi-keepalive
!
interface ATM1/0.1 point-to-point
description *** PVC to ISP ***
bandwidth 10000
ip address
pvc 1/120
 protocol ip zzz.zzz.zz.zzz broadcast
 vbr-nrt 10000 10000 1
 encapsulation aal5snap
!
ip classless
ip route 0.0.0.0 0.0.0.0 aaa.aaa.aa.aa
!
no ip http server
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
control-plane
!
line con 0
exec-timeout 0 0
password
login
line aux 0
password
logging synchronous
login
modem Dialin
modem autoconfigure discovery
transport input all
speed 300
flowcontrol hardware
line vty 0 4
password
login
transport input telnet ssh
line vty 5 15
password
login
transport input telnet ssh
!
scheduler allocate 20000 1000
!
end
0
nhrhs
Asked:
nhrhs
  • 2
  • 2
2 Solutions
 
Don JohnstonInstructorCommented:
First, ALWAYS remove any passwords on your config before posting.

Second, it's also a good idea to mask or alter public IP addresses.

Third, I would remove any identifying names.

As for your question, are you going to use this additional range to assign addresses to actual devices or will these addresses be used for NAT?
0
 
jigardaveCommented:
scheduler allocate is to guarantee CPU time for processes.

Currently you have 2 IP addresses check what you are doing with those addresses.
As mentioned in previous comment what is reason behind buying bigger IP range>> or Is that something that just come with purchasing higher bandwidth??
Or
With information you have provided with 65.199.167.160 255.255.255.248 you have 65.199.167.161-.166 usable ... use first two out of that and replace previous ones [while on the phone with provider].
0
 
nhrhsAuthor Commented:
donjohnston -- you're right; I was just about to start cleaning up what I posted when I got called away, and when I came back I just submitted without thinking.

Do you know if there is a way for me to edit it now?

I needed the additional range of IPs because my new Barracuda firewall doesn't do header inspection like my outgoing ISA box did, so they told me I need separate IPs for my mail server and an internal web server we have.  We'll need at least one for NAT, and one for each of the other servers.

This is new territory for me, so I'm not sure of the commands needed to accept and route this new block of IPs for use as mentioned above.

Also, any idea what I need to do in the config when they turn up the 30Mb bandwidth?

Thanks for your help so far.
0
 
Don JohnstonInstructorCommented:
>Do you know if there is a way for me to edit it now?

Contact the moderators.

>This is new territory for me, so I'm not sure of the commands needed to accept and route this new block of IPs for use as mentioned above.

You could simply create a new network for the devices that will use the new range of addresses. If you don't have any available interface on the existing router, you could create a subinterface on the 2851, create it off of a firewall or multilayer switch or another router. Which interface are used for what on the 2851?

>Also, any idea what I need to do in the config when they turn up the 30Mb bandwidth?

Which interface? If it's the ATM, you should change the bandwidth statement to 30000. If it's one of the ethernet interfaces, you don't have to do anything... but you should set the bandwidth on those too.
0
 
nhrhsAuthor Commented:
I'm going to try using the first address in our new block in this statement:
-----------------------------------------------------------------------------
interface GigabitEthernet0/0
description *** Connected to local switch for the OUTSIDE LAN ***
ip address xx.xxx.xx.xxx 255.255.255.252
no ip mroute-cache
load-interval 30
duplex auto
speed auto
------------------------------------------------------------------------------

It sounds like that's all I have to do to continue NATing.  Is that true?

As long as everyone can use the Internet without disruption, that's my main concern right now.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now