• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1681
  • Last Modified:

OpenSSH on AIX 5200-08

I installed openssh on aix 5.2. I can't get SSH daemon to start. Also, nothing comes back when I run an lppchk. Any help?

root@server:/root -> lslpp -l |grep ssh
  openssh.base.client     5.4.0.6101  COMMITTED  Open Secure Shell Commands
  openssh.base.server     5.4.0.6101  COMMITTED  Open Secure Shell Server
  openssh.license         5.4.0.6101  COMMITTED  Open Secure Shell License
  openssh.man.en_US       5.4.0.6101  COMMITTED  Open Secure Shell
  openssh.msg.EN_US       5.4.0.6101  COMMITTED  Open Secure Shell Messages -
  openssh.msg.en_US       5.4.0.6101  COMMITTED  Open Secure Shell Messages -
  openssh.base.client     5.4.0.6101  COMMITTED  Open Secure Shell Commands
  openssh.base.server     5.4.0.6101  COMMITTED  Open Secure Shell Server
root@server:/root ->

root@server:/root -> /usr/sbin/sshd -d
exec(): 0509-036 Cannot load program /usr/sbin/sshd because of the following errors:
        0509-130 Symbol resolution failed for /usr/lib/libcrypto.a(libcrypto.so.0.9.8) because:
        0509-136   Symbol __fd_select (number 58) is not exported from
                   dependent module /usr/lib/libc.a(shr.o).
        0509-150   Dependent module libcrypto.a(libcrypto.so.0.9.8) could not be loaded.
        0509-026 System error: Cannot run a file that does not have a valid format.
        0509-192 Examine .loader section symbols with the
                 'dump -Tv' command.
root@server:/root ->

root@server:/root -> startsrc -s sshd
exec(): 0509-036 Cannot load program /usr/sbin/sshd because of the following errors:
        0509-130 Symbol resolution failed for /usr/lib/libcrypto.a(libcrypto.so.0.9.8) because:
        0509-136   Symbol __fd_select (number 58) is not exported from
                   dependent module /usr/lib/libc.a(shr.o).
        0509-150   Dependent module libcrypto.a(libcrypto.so.0.9.8) could not be loaded.
        0509-026 System error: Cannot run a file that does not have a valid format.
        0509-192 Examine .loader section symbols with the
                 'dump -Tv' command.
0513-059 The sshd Subsystem has been started. Subsystem PID is 2457780.
root@server:/root -> exec(): 0509-036 Cannot load program /usr/sbin/sshd because of the following errors:
        0509-130 Symbol resolution failed for /usr/lib/libcrypto.a(libcrypto.so.0.9.8) because:
        0509-136   Symbol __fd_select (number 58) is not exported from
                   dependent module /usr/lib/libc.a(shr.o).
        0509-150   Dependent module libcrypto.a(libcrypto.so.0.9.8) could not be loaded.
        0509-026 System error: Cannot run a file that does not have a valid format.
        0509-192 Examine .loader section symbols with the
                 'dump -Tv' command.
exec(): 0509-036 Cannot load program /usr/sbin/sshd because of the following errors:
        0509-130 Symbol resolution failed for /usr/lib/libcrypto.a(libcrypto.so.0.9.8) because:
        0509-136   Symbol __fd_select (number 58) is not exported from
                   dependent module /usr/lib/libc.a(shr.o).
        0509-150   Dependent module libcrypto.a(libcrypto.so.0.9.8) could not be loaded.
        0509-026 System error: Cannot run a file that does not have a valid format.
        0509-192 Examine .loader section symbols with the
                 'dump -Tv' command.
0
AIX25
Asked:
AIX25
1 Solution
 
raysonleeCommented:
Have you done what the error message suggested?
Examine .loader section symbols with the 'dump -Tv' command
0
 
woolmilkporcCommented:
Hi,

at least your OpenSSL version (but I assume the OpenSSH version as well) is too new for your AIX.

The newer versions rely on several functions of libc which have been implemented in AIX 5.3 and up, but not in earlier versions.

Uninstall OpenSSH and OpenSSL to go back to a compatible version.

OpenSSL for AIX 5.2 and earlier is here:

http://www.bullopensource.org/download/aix52/openssl-0.9.7.1.bff

And here is OpenSSH:

http://www.bullopensource.org/download/aix52/openssh-3.8.1.0.exe

wmp
0
 
AIX25Author Commented:
Thank you wmp for your feedback and references! That was our issue, we had to downgrade our SSH to the previous version.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now