USB Drive Letters Revert

Running SBS 2003. Previously swapping two 250GB retail Seagate USB drives for backup without issue. Backups outgrew the drives. So we switched to two Seagate 1TB internal drives in USB drive enclosures. Drives were assigned with drive X:. Now when we swap drives, the drive letter reverts to F: and the backups fail. Have used this exact setup on other servers without fail.

I have searched high and low for a solution but have not been able to find one...yet.
jrobertson77Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Neil RussellTechnical Development LeadCommented:
You mean that the NEW drives wre assigned the drive letter X: and worked but have now defaulted back to F:?
OR
You mean the old ones where X: and when you put the news one in they are on F:?
0
jrobertson77Author Commented:
Neilsr:

I had the original drives setup as drive X:. I then took those out of the mix and started using the new drives. When I plugged them in the first time (one at a time), I initialized them and assigned each of them with with drive X:. The drive letter stays assigned until I swap the drives as which time they revert to drive F:, the lowest available drive letter.

Let me know if this doesn't make sense.
0
AnacreoCommented:
From the windows command line you can fix this fairly easily...

 
DISKPART> list volume

  Volume ###  Ltr  Label        Fs     Type        Size     Status     Info
  ----------  ---  -----------  -----  ----------  -------  ---------  --------
  Volume 0     D                       DVD-ROM         0 B  No Media
  Volume 1     E   U3 System    CDFS   CD-ROM        95 MB  Healthy
  Volume 2     C   Fast NTFS    NTFS   Partition     29 GB  Healthy    System
  Volume 3     F   WS03         FAT32  Removable   3827 MB  Healthy

DISKPART> select volume 3

Volume 3 is the selected volume.


DISKPART> assign letter=x

DiskPart successfully assigned the drive letter or mount point.

DISKPART> list volume

  Volume ###  Ltr  Label        Fs     Type        Size     Status     Info
  ----------  ---  -----------  -----  ----------  -------  ---------  --------
  Volume 0     D                       DVD-ROM         0 B  No Media
  Volume 1     E   U3 System    CDFS   CD-ROM        95 MB  Healthy
  Volume 2     C   Fast NTFS    NTFS   Partition     29 GB  Healthy    System
* Volume 3     X   WS03         FAT32  Removable   3827 MB  Healthy

DISKPART> exit

Open in new window

0
Cloud Class® Course: SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

AnacreoCommented:
Woops to get here just do

Windows Menu | Start | Run | Diskpart

0
jrobertson77Author Commented:
Anacreo:

So, are you sure that will take care of the issue when I swap drives as well. In other words: I go in now and set drive1 to X: using Diskpart. I backup my files. I swap in drive2. Use Diskpart to change the letter to X:. Do my backups. Bring drive1 back in the mix. WIll drive1 stay at X: then?

How is Diskpart different from changing the drive letters via Disk Management?
.
0
AnacreoCommented:
Hmm I'm not sure that there is anything different here, however you could put a fair number of solutions to this problem in place...

autoplay script on the root of the drive to do a drive assignment...

In the old days you could assign one drive to uppercase and one drive to lowercase and then they would both get the drive letter with the lower one taking precedence (major opportunity for hackers to own your system, secretly.)

It may be that Windows is not seeing the internal USB drive as a "removable drive" and there for is not allowing it to share drive letters at the slot, where as the removable disk is doing that.

Can you run diskpart and do "list volume" and see what is set for the "Type", if you are getting Partition instead of Removable you may have to revert to a tool like:
http://www.uwe-sieber.de/usbdlm_e.html

You could try making sure all your disk and controller drivers are up to date (and if you have an nVidia set you're using the nForce drivers... etc.) if a removable is showing up as a fixed.

Which can manage the USB drive letters on insertion.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jrobertson77Author Commented:
Anacreo:

Thanks for the info on the workarounds. I have already read about several of them. THe problem is, I don't really want to use a work around. Previously, I had a couple of drives connected to the server that worked the correct way. Now, with this new pair of drives, I can't get it to do what it is supposed to do. It's driving me crazy.

If I am going to do a work around, I will delete the drive map that is interfering with the drives and just let the drives populate as drive F: and reconfigure the backup. I just can't figure out why when I set them as drive X: it won't stick.
0
AnacreoCommented:
Honestly, its probably related to the drive not showing up as a removable drive when it should be.  So checking the drive type and updating drivers is a solution rather than a workaround, if it applies.  You'll want to verify this as well to make sure Windows isn't putting non removable files on those drives accidently as well as having improper flush settings.

There is a strong reason not to swap out drive on backup software as it should know which drive holds what data at what date (kind of vital information).

Having said that I used to run a quite large Networker environment 1.6PB and we switched to Avamar (all dedupe based), and now I use CrashPlan... never looking back.  Try CrashPlan as your backup software (its free) and you will really not be disappointed for ease of use and functionality.

Let me know if you decide to use any of the prior workarounds/fixes.
0
jrobertson77Author Commented:
Anacreo:

Thanks for the last post. It made me go back and really read what you posted before.

I did run Diskpart and indeed the drive is showing as a partition instead of removable. I am going to dig into this wrinkle to see what I can come up with. Before I do, any idea why the drive would show up as a partition instead of removable?

Also, you have me looking at CrashPlan. Interesting...
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.