• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 283
  • Last Modified:

Error either EOF or BOF is true when I can see a record in the table

I am using a recordset that is based on a table that I populated through a subform. I keep getting the above error, but when I look in the table there is a record sitting there.
0
smm6809
Asked:
smm6809
1 Solution
 
Jim Dettman (Microsoft MVP/ EE MVE)President / OwnerCommented:

 Does the form have a filter applied?

 Did you try stepping through the code to the point of the error to see what's going on?

 It would help to see the code.

Jim.
0
 
mbizupCommented:
Without seeing your code, I'd suggest:

1.  Add the following before any recordset code to ensure that any currently edited records get committed to the table:

Me.Refresh

or if the recordset code is on the mainform:

Me.SubformControlName.Form.Refresh

2.  Try a requery statement before the recordset code (and after it if it is writing data that might affect your form's recordsource):

Me.Requery

or if the recordset code is on the mainform:

Me.SubformControlName.Form.Requery
0
 
smm6809Author Commented:
Thanks! worked great
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Amazon Web Services - Basic

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now