SATA drive not recognised when installing new WIN XP system

Posted on 2011-10-19
Last Modified: 2012-05-12
Trying to install Win xp on a new SATA 400gb drive.
Motherboard is ASUS A7V8X-MX SE and does not have a SATA slot so I have installed PCI to Sata card. VIA  VT6421 raid controller on my old C drive (ide) in Win xp.
The new SATA (F drive) is recognised and formatted and is there in Windows Explorer and I initialised it so I tried to read/write and it is ok.
I created a floppy as per raid controller instruction.
Removed old c: drive and plugged in new sata drive.
Restarted with XP home disc and upon installation pressed F6 and when it asked for floppy it copied the files from floppy, then continued loading accross files for xp installation for 5 minutes using raid files from floppy.
It completed installation of all windows files and restarted.
Instead of getting the message "boot from cd" which I know to ignore so it starts to complete the windows instalation, it returns a message of "settings inspection configuration" and the installation just goes around in circles over and over.
I went back to the original ide c: drive, restarted with XP and when I looked into the new sata F: drive there were all the Windows files already there. So the PCI to SATA card must be ok if I can read all the files on the new sata F: drive.
Pressing "del" on reboot I tried altering the BOOT start up order from
2. HD
3. floppy
to include SATA, but there is no option to choose SATA.
With just the SATA connected and without the Win xp disc in the cd drive I get a message of no hard drive found.
How do I force the SATA to be recognised on the PCI to Sata card on reboot to continue the win xp installation?
Question by:MalcolmBishop
    LVL 46

    Assisted Solution

    this is because windows XP doesn't have SATA drivers built into it.  You need to  build a slipstreamed CDROM image of XP (google slipstream and they're are numerous how-to sites with software for free)
    LVL 5

    Assisted Solution

    Check your bios, make sure your sata controller is set to ATA, not AHCI.

    Also, you can try just disabling your sata controller.
    LVL 16

    Expert Comment

    It looks like BIOS from SATA add-on card is not loading during boot.
    Try to make RAID array with your SATA controller, even if you have only one hard drive attached
    to it.
    LVL 12

    Expert Comment

    what Kenmcse1969 said
    LVL 91

    Expert Comment

    is this the correct message?  "settings inspection configuration"  i could not find anything about it...
    what sata card do you have?

    Author Comment

    Kenmcse1969: I cannot find anything in BIOS that refers to SATA for me to enable it.
    LVL 91

    Expert Comment

    what about my post ?  any comments?

    Author Comment

    sorry, but I have been onto other stuff the last few days and not able to get onto EE to reply.
    Card is via VT6421
    The message I typed about "settings inspecting" is not quite right as I was doing it from memory, but it is the standard message you get when booting from the xp home boot cd after you have pressed "enter" at the "boot from cd" message.
    As I wrote at the top, on a correct xp installation you get all the files copying for about 10 mins with the yellow scroll bar. When it gets to the end the pc reboots and "boot from cd" message is there, but you ignore it, and windows carries on intalling from the HD with the message "39 minutes" etc etc.
    With this VT6421 in PCI slot and new sata drive connected this sequence is not happening, and the sequence is reverting to the "boot from cd" sequence without me pressing any keys.
    I have since re formatted my ide c:\ drive, re installed xp and spent 2 days doing all the updates so it is now at SP3. It is an old, but reliable 40gb ide drive so I wanted the new 400gb sata to be the new c:\ drive.
    Even though I have re installed the drivers for the VT 6421 on this 40gb ide drive I am now at a point where it will not even recognise the sata drive.
    LVL 91

    Accepted Solution

    is the drive recognised in the bios correct?  first thing to check (there can be a bios limit on the disk size) on older motherboards

    Author Closing Comment

    Thanks to all who helped.
    I gave the most points to "nobus" as he spotted the cure.
    Thank you.
    LVL 91

    Expert Comment

    not sure why a B grade then?

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Looking for New Ways to Advertise?

    Engage with tech pros in our community with native advertising, as a Vendor Expert, and more.

    This article is an update and follow-up of my previous article:   Storage 101: common concepts in the IT enterprise storage This time, I expand on more frequently used storage concepts.
    Today, still in the boom of Apple, PC's and products, nearly 50% of the computer users use Windows as graphical operating systems. If you are among those users who love windows, but are grappling to keep the system's hard drive optimized, then you s…
    As developers, we are not limited to the functions provided by the VBA language. In addition, we can call the functions that are part of the Windows operating system. These functions are part of the Windows API (Application Programming Interface). U…
    With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…

    761 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    11 Experts available now in Live!

    Get 1:1 Help Now