?
Solved

Multiple problems possibly related - IE 9 has an approx 30 to 90 second delay when first started, and "Error 2738. Could not access VBScript run time for custom action."

Posted on 2011-10-19
7
Medium Priority
?
586 Views
Last Modified: 2013-12-08
Hello everyone,

I am working on a computer that has an issue with or effecting Internet Explorer 9, and other programs on the computer

When first started there is a delay of 30-90 seconds before loading the first web page. After that it seems to work normal.

Google Chrome is also on this computer and works fine, so I don't believe it is a connection problem.

The reason I need to fix this is because Quickbooks 2009 is also on this computer, and it uses Internet Explorer as its internal browser to do its online services.

Also, I have been running into the error  "Error 2738. Could not access VBScript run time for custom action." when trying to remove some of the unneeded programs on this computer. I have done the processes described in various web posts of re-registering the VBScript service, and it does say that it re-registers, but the error still comes up. I made sure that the service was not registered under the HKEY_CURRENT_USER section of the registry, which some web sites say can be the reason that it does not work after being re-registered.

Not sure if they are related to each other, but just in case I am mentioning it here.

The computer is running Vista Home Premium, all patches and updates that were detected as needed have been applied.

I have run multiple scans with Norton Internet security, Malwarbytes, Super Anti-Spyware, Gmer, and I believe I took care of all the issues found. Everything scans clean now, so if something caused this issue, I believe its leftover damage and not an active program.

I have tried removing and reinstalling the Internet Explorer update to no affect. Though, I did not do a clean install of Internet Explorer (If that can be done, I have looked for a procedure, but did not find anything off hand that looked right). If any of you know that procedure I would greatly appreciate it.

I tried to remove and re-install Quickbooks 2009, but had to restore from a backup. I believe it was an issue with the VBScript service mentioned earlier. Sorry, not in front of the computer right now and I have been working on it for awhile so everything can blur together in my mind ;).

This computer was on a network that, before I started working on it, had many security issues, computers with "free" security software on them, which were not updated or monitored. I believe I have cleaned everything out, but I would not be surprised if something was left, or if, as I mentioned earlier, there is damage left from something that was already removed.

I know it would be easier to wipe and re-install on all of these computers, but there was not adequate backup system in place either, and I must avoid losing any critical data.

Its not my mess, I am just cleaning it up. I have already talked to the owner at length about how it should have been, and how its going to be once I am done.

Thank you all in advance for your help, and I will be working on this computer later today (10/19/2011)


0
Comment
Question by:Chicago_Guy
6 Comments
 
LVL 3

Expert Comment

by:ajcheung78
ID: 36994491
If not already done I assume you have disabled all of the addins from the menu:  Tools > Manage Add-ons.
0
 
LVL 34

Expert Comment

by:Paul MacDonald
ID: 36994493
Open a command prompt and run SFC /SCANNOW and see if that helps.
0
 

Author Comment

by:Chicago_Guy
ID: 36995811
ajcheung78 - I believe I did try disabling all the add ons. I did look at the add-on management interface and it did not identify anything taking the amount of time that it delays loading the page. I will have to try that to confirm tonight

paulmacd - I did run SFC /SCANNOW and it did not find anything wrong. Sorry, forgot to mention that earlier.

Thank you for your responses so far.
0
Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
LVL 70

Expert Comment

by:Merete
ID: 37067459
Hi  Chicago Guy
here's another tip
go to internet options>Connections>Lan>and untick automatically detect settings and also untick Use automatic configuration script.
ok  apply and ok
close out IE and re-open.
again
Go to Tools Internet options>advanced at the top of the list
To speedi it up a bit also check if this is unticked <use software renderring instead of GPU renderring<< instead tick it.
look down to browsing>
untick>Display a notification about every script error
tick>>Disable script debugging
tick>disable script debugging other

0
 

Author Comment

by:Chicago_Guy
ID: 37196496
Sorry about not responding, things have been a bit crazy for awhile.

I have not worked on this particular problem for awhile, but I do need to address it still.

Merete - If I disable the script debugging features, wouldn't that mean that the error is still present but I just turned off the error message? I am not familiar with the script debugging system, but I would prefer to actually address the error, unless I am mistaken about what this will do to the system. I don't want to remove the error message and open up other possible problems.

Thank you for your suggestions, just a little nervous about it.
0
 
LVL 70

Accepted Solution

by:
Merete earned 2000 total points
ID: 37196535
Yes,
However it he problem is scripts  within the owners webpage that's their problem not yours, when IE is set to show every script error that just causes a lag for you and you cant fix it.
It's ok to just ignore them.
You can choose to debug if it's your webpage
I find Internet Explorer 9 a lot slower in opening than it's precedessor, I dont know if it's my Video card or just all the add ons featured in the behind scenes security protocols tabbed windows etc.
The interface is nice but the opening responses can at times really frustrate.
So I use Both Maxthon combined with IE 9.
If you open your taskmanager take a look internet explorer there is always 2 instances now, and that is with one page open. I believe it is the new tabbed feature in IE9.
I think that is what causes the lag

This article offers five methods that you can try to resolve the issue, and also presents some advanced troubleshooting tips that you can try. Try each method in the order presented until you resolve the issue. If one method does not work, try the next.
http://support.microsoft.com/kb/308260
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I had to do a bit of research to find the answer to this question so I thought I'd share my results.  Due to our outdated mainframe systems, we need to downgrade IE9 to IE8 in order to stay compatible.  We also needed to downgrade Java.  In order to…
Introduction If you're like most people, you have occasionally made a typographical error when you're entering information into an online form.  And to your consternation, the browser remembers the error, and offers to autocomplete your future entr…
Google currently has a new report that is in beta and coming soon to Webmaster Tool accounts. This Micro Tutorial will highlight new features for Google Webmaster Tools.
How to create a custom search shortcut to site-search Experts Exchange using Google in the Firefox browser. This eliminates the need to type out site:experts-exchange.com whenever you want to search the site. Launch your Bookmark Menu: Press 'Ctrl +…

850 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question