?
Solved

Send As Permission Changes on Public Foders Fail Due to Insufficient Rights

Posted on 2011-10-19
14
Medium Priority
?
1,064 Views
Last Modified: 2012-05-12
Recently migrated from Exchange 2007 to 2010.  We used Send As successfully on public folders on the '07 iteration but something happened to these permissions during the migration. They all need to be recreated.  I've tried manually recreating individual folder permissions with no luck.  Have also tried recipes in a number of postings also without success. These include adding various permissions such as Exchange Recipient Admins and Organization Management.  Suggestions are welcome.  Thanks.
0
Comment
Question by:Herb-Avore
14 Comments
 
LVL 21

Expert Comment

by:Hendrik Wiese
ID: 36998083
You should not need to add anyone to the Organization Management group to achieve this.

Have you tried running the following command:
Add-ADPermission PUBLICFOLDERNAME -User contoso\jack -Extendedrights "Send As"

Open in new window


Also try to restart your Exchange servers as it seems like there is communication issues between the two.

Hope this helps.
0
 
LVL 2

Expert Comment

by:gleek
ID: 36999603
is inheritance turned on for your users?  Check to see.  I've found that sometimes if there is a block the proper permissions do not trickle down after an Exchange 2010 install.  verify the users have it turned on and all OUs up to the root do not have them blocked.
0
 

Author Comment

by:Herb-Avore
ID: 37000034
Tried the command in Exchange Management Console and got the same result.  Active Directory Operation Failed.  Access denied. The severs have been rebooted quite recently, several days ago.

As to the inheritance suggestion, the box is checked for all users that says Include Inheritable Permissions.
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
LVL 27

Expert Comment

by:davorin
ID: 37014357
You probably have also changed from windows server 2003 OS to windows server 2008 OS?
You should run exchange management console and exchange management shell with "run as administrator" option even if you are logged as an administrator.
0
 

Author Comment

by:Herb-Avore
ID: 37018503
You are correct about the OS upgrade.  We are now running one DC on 2003 and one on Server 2008.  However, the Exchange servers are all still on Server 2008 R2.  

Tried running the EMC as administrator.  No-go.  Same permissions error.  
0
 
LVL 21

Expert Comment

by:Hendrik Wiese
ID: 37018565
You should use the same account that was used to setup exchange.

Was it the administrator account?
0
 

Author Comment

by:Herb-Avore
ID: 37018584
It was setup with the domain admin account.
0
 
LVL 21

Expert Comment

by:Hendrik Wiese
ID: 37018624
Try adding your local account to the Origination Management group and try to assign permissions again after running EMC or EMS as administrator. I know this sounds crazy, but please try and let me know what the result is.

Hope this helps!!!
0
 

Author Comment

by:Herb-Avore
ID: 37019211
No, that did not work.  Actually, I had tried that before even posting this to the Group.  Good try, though. Do you think this might have something to do with the fact that we had a domain controller crash a few weeks back.  I have not had time to go through and manually remove all traces of it.  Just a thought.
0
 
LVL 21

Expert Comment

by:Hendrik Wiese
ID: 37022721
This may very well be part of the problem. Have you restarted your Domain Controller recently.

It seems to me like there is a communication problem between your DC and Exchange server.

Try restarting your DC and let me know what happens?
0
 

Author Comment

by:Herb-Avore
ID: 37050616
No, cleaning up the deceased domain controller nor a reboot allowed me to set Send As permissions on a public folder.  Still get "user has insufficient rights" error
0
 
LVL 21

Expert Comment

by:Hendrik Wiese
ID: 37055076
Try going through the following articles:

1. EMC Permissions Gone
2. Exchange Management Console Permissions Gone
0
 

Accepted Solution

by:
Herb-Avore earned 0 total points
ID: 37104522
OK.  Figured it out after a call to Microsoft.  This is a bug in Public Folders migrated from Exchange 2007 to Exchange 2010.  If you disable a mail-enabled public folder and re-mail enable it the permissions can be successfully applied.  Apparently, this problem is resolved by the latest Exchange 2010 rollup.  
0
 

Author Closing Comment

by:Herb-Avore
ID: 37126844
Called Microsoft tech support and they gave me the answer.  No charge.
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Upgrading from older Exchange server to the latest Exchange server can be tiresome, error-prone and risky, without being a seasoned exchange server administrators. It can become even problematic if you're an organization that runs on tight timeline…
After a recent Outlook migration from a 2007 to 2010 environment, some issues with Distribution List owners were realized. In this article, I explain how that was rectified.
This tutorial will show how to configure a single USB drive with a separate folder for each day of the week. This will allow each of the backups to be kept separate preventing the previous day’s backup from being overwritten. The USB drive must be s…
This video shows how to quickly and easily deploy an email signature for all users in Office 365 and prevent it from being added to replies and forwards. (the resulting signature is applied on the server level in Exchange Online) The email signat…
Suggested Courses
Course of the Month4 days, 9 hours left to enroll

601 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question