Cisco ASA 5505 and (very) limited internet access

Posted on 2011-10-19
Last Modified: 2012-05-12
Greetings Experts:

I work from a home office.  I've had a Cisco 5505 ASA for a couple years which has allowed me to access my company network including use of a network phone.  The system has worked flawlessly until recently when my laptop was upgraded to Windows 7 from Windows 98.  I'll note the setup and symptoms below but I should note that my IT guys seem stumped and I'm not particularly tech saavy.  I can't access the ASA to get a log or check settings and I wouldn't know what to look for.  My hope is that some of you can point me toward the more likely problem based on the symptoms listed below.

Here's the setup:  ISP modem>linksys wrt54G router (provides home internet access too)>Cisco 5505 ASA>laptop docking station and phone.  Again, this configuration has worked great for years and still works fine with a loaner laptop running Windows 98.

Here's the problem: with the Windows 7 machine, the same port(s) on the ASA  allow access to my company network, but only very limited access to the internet.  By "limited internet access" I mean that most external sites simply don't load.  They don't time out, the browser just keep trying with no results.  What's odd is that I can apparently access sites that are hosted by Google (search engine, YouTube, Google Maps).  The sites quickly return current information, not cached results.  I've not found any other sites that work.

I've checked the browser proxy settings and those are OK (unchecked).  I've tried different browsers and the results are the same.  Tried power cycling everything, lots of times.

I also tried moving the ASA between the modem and the linksys router.  Not only did that not solve the problem but it created the same exact symptoms on my home computer (an iMac).

My IT guys say it isn't a "split tunnel" issue and that's configured properly.  I don't know what else they've considered but I'm hoping to get some guidance from you folks.  Thanks!

Question by:happycowfarm
    LVL 10

    Expert Comment

    Put the ASA back where it was when you started.
    Plugin the 98 machine and verify everything works properly.
    Check the ip settings on the 98 machine.
    Check for proxy settings on 98 machine.
    Plug in the 7 box and check the ip settings.
    Compare to the 98 box.  You'll probably find some weird DNS or proxy settings.  Change the 7 box to match the 98 box.

    Author Comment

    Thanks Joelsplace.  I had the same thought and suggested it to the IT folks.  They've checked the configurations.  They're thought is that it's something specific about how the Windows 7 machine is interacting with the ASA--in other words the problem is unique to the combination of the 7 machine and the ASA.

    One lead they're looking into is whether the issue is IPv6 versus IPv4.  Apparently that's a key difference between Windows 7 and XP (old machine was running XP, not 98 as I accidentally wrote in the original post).  They've tried to disable IPv6 (with fix from Microsoft) but he made it sound as though the logs still show the laptop trying to use it (or whatever the proper characterization).
    LVL 10

    Expert Comment

    If you disabled IPv6 and it still shows activity.  I would make sure your NIC drivers are the most current.  I have lots of XP and 7 boxes behind ASA5505s and no issues.  I don't bother turning off IPv6 either.
    I wonder if your ASA needs an update?  They release updates often.

    Accepted Solution

    My IT folks came through.

    The MTU size was set to small for Windows 7, but it was fine for XP. They changed the MTU for both the ASA and Windows 7 to be 1500.

    Thanks for the input!


    Author Closing Comment

    My own IT folks came up with the fix

    Featured Post

    How to run any project with ease

    Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
    - Combine task lists, docs, spreadsheets, and chat in one
    - View and edit from mobile/offline
    - Cut down on emails

    Join & Write a Comment

    Join Greg Farro and Ethan Banks from Packet Pushers ( and Greg Ross from Paessler ( for a discussion about smart network …
    ADCs have gained traction within the last decade, largely due to increased demand for legacy load balancing appliances to handle more advanced application delivery requirements and improve application performance.
    Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
    This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor ( If you're looking for how to monitor bandwidth using netflow or packet s…

    730 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    16 Experts available now in Live!

    Get 1:1 Help Now