• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 394
  • Last Modified:

rdlc report change due a store procedure change

I have an rdlc report working. The report data is based on an.xsd file I created with an existing store procedure. Everything is work ok.

Now I made a change to the selection fields for the stored procedure. I deleted the previous .xsd and created a new xsd in order to match the changed selection fields. The .xsd file keeps the same name as before.

I always need to recreate a brand new report in order to make the report work again. It usually does not work only by remapping the fields. I don't think this is the correct way to make rdlc work due to the store procedure change.  How should I make the report work again normally?

Thanks.
0
minglelinch
Asked:
minglelinch
  • 3
  • 3
1 Solution
 
sammySeltzerCommented:
I *think* what is missing, from what you explained, is to update the .aspx page.

For instance, you have report.rdlc and you have report.aspx.

Open this .aspx report in designer mode of your vs.

Click on the body of the page to give it a rectangular view, right-click, then click on Smart tag.

Follow the on screen instruction and make your changes there.

See if that takes care of you.

0
 
minglelinchAuthor Commented:
Thanks for your comment.

I did not see the  a rectangular view, or I do not understand what  a rectangular view is. My report was opened by clicking a ink button in a page. When I right click the page in design mode, I did not see the Smartag.


0
 
sammySeltzerCommented:
see screenshot.

Whether you click on the arrow pointing right at top right corner rectangle or you right-click on the body of rectangle and click on Smart Tag.

Either one will give you a box with a list of options.
smartTag.JPG
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

 
minglelinchAuthor Commented:
I open the rdlc report by clicking a linkbutton.

The attached is what I got when right clicking > on the top coner of the aspx file with the linkbutton.


SMTag.doc
0
 
sammySeltzerCommented:
you should see something like this:


smartTag.JPG
0
 
minglelinchAuthor Commented:
I guess your aspx file is different. My aspx file does not have the top bar with arrows. My aspx file is just a normal one with a link to bring the PDF. So I did not see that.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Amazon Web Services - Basic

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now