How do I allow Wine to "see" my game (Diablo II, etc) CDs after install?

I ran into an issue with more recent versions of Ubuntu where the CDROM is always mounted as a new mount point matching the name of the CD.  I asked an EE question (id 27398894) and was able to mount the CDROM in such a way that the install would work with a multi CD installation.  Now I am unable to play the game.  It keeps asking me to install the PLAY DISC when it is already in there.  This seems to be some sort of permissions bug... I know the game wants to read some obscure portion of the disk in order to verify that it is the disc it is supposed to be.  The current FSTAB mounting line may be the issue... here it is.

/dev/sr0   /media/cdrom0   udf,iso9660 user,auto,exec   0 0

Keep in mind, the install programs worked while juggling 4 discs.  The mounting is working as expected.  I just need to figure out how to make the mount operation compatible with the request to read a non file location on the CD.
LVL 21
developmentguruPresidentAsked:
Who is Participating?
 
Swadhin RaySenior Technical Engineer Commented:
Please check this URL hope this will solve your problem:

http://www.blog.highub.com/linux/install-and-play-diablo-ii-on-ubuntu/

0
 
developmentguruPresidentAuthor Commented:
At the bottom of that link you will start to see posts that have the same issue I have been running into.  I got past the last issue I saw on there (it won't recognize when I switch disks during installation).  This was due to a change in how Ubuntu mounts CDs.  The question number I posted in my original question shows how to get around that.

  There is still an issue that apparently has to do with the rights (needed to do the security check) that games like Diablo II use to see if the original disk is in the drive.  I believe this check requires direct access to sectors on the disk that are not used in any files.  I need to know how to allow that level of access to the CDROM (most likely an fstab setting as near as I could guess).

I hope this explains the situation better.  I have found many examples of how to install such things on Linux under Wine, but most are very outdated by now.
0
Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

 
TobiasHolmCommented:
0
 
developmentguruPresidentAuthor Commented:
 I tried Winetrix.  It had a setup script that made installing Diablo II easy, but none for the expansion.  Keep in mind that the idea is to get multi disk installs to work, not just the game I am testing on.  If you are familiar with PlayOnLinux, will it make installing a multi CD windows program install easy?  Or is it limited to program installs that it "knows about"?

  The important issue right now is that, having created a static mount point for CDs on my system, and having successfully done a multi CD install, the game's CD test function does not work.  What I really want to do is make the test work.  If this can be done then I will have a way to make any such software work (as long as Wine supports all of it's required functionality).

  So... What can you tell me about PlayOnLinux regarding generic installs (say I have my own multi cd install program for a program I wrote)... and can you give me a Linux answer to giving the appropriate rights to the CD drive to allow the CD test to pass.
0
 
developmentguruPresidentAuthor Commented:
I managed to get some information that could be a help...

From a terminal I ran:
wine Explorer.exe

Once in there I navigated to the diablo II directory (C:\Program Files\Diablo II) and double clicked on Diablo II.exe.

This is the error message it gives me in the terminal EVERY TIME it tries to do the security check on the CD:

err:seh:setup_exception_record stack overflow 932 bytes in thread 0020 eip f74cbf2a esp 00240f8c stack 0x240000-0x241000-0x340000

Can anyone tell me 1) what that means and 2) how to allow the wine system to work around it?
0
 
developmentguruPresidentAuthor Commented:
Being a developer I have seen problems with stack overflow.  Normally these would be likely to be caused by a coding error, or by not setting the stack size high enough to run the application.  I believe that it might be possible that WINE does not allow a large enough stack size in some instances.  Is there a way to setup a stack size for WINE applications?
0
 
developmentguruConnect With a Mentor PresidentAuthor Commented:
You should have read more on the links.  The one you gave me that lead me here:
http://bugs.winehq.org/show_bug.cgi?id=24096#c5

gives a solution at the bottom.  Upgrading WINE fixed the issue.  I was on WINE 1.0 (which is the first recommended version on Ubuntu 11.04).  The Ubuntu software center had 3 separate versions and the beta release 1.3.15 made it work.  I didn't even have to reinstall the software after removing WINE and installing the new version.
0
 
developmentguruPresidentAuthor Commented:
Thanks for the help.  I hope this question is able to help others with this, rather tricky, question.

1) make a static mount point so multi disc installs will work
2) use a NEW version of WINE.
0
 
developmentguruPresidentAuthor Commented:
I do still have one issue.  The game works PERFECTLY... once.  The second run there is no sound (until I reboot).
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.