?
Solved

Small Business Server 2003 - cannot retrieve email from exchange server on smart phones and cannot access remote web workplace thru internet.

Posted on 2011-10-20
6
Medium Priority
?
345 Views
Last Modified: 2012-05-12
We have a small business server 2003.  Exchange server was configured as well as remote web workplace.  All was working fine for the last 2 years up until 2 days ago.  Yesterday I was informed that the ISP called them and informed them a pc on the network was phishing for bank information via the web.  They cut of their internet until the problem was resolved.

We discovered that a client who rents office space from us had a pc infected with a virus.  The pc was then removed from the network.  We called the ISP and they confirmed that the issue was resolved and allowed us to access the internet again.

Well now our smart phones do not receive emails from the server and we cannot access the remote web workplace thru the internet.  I can ping the server from outside our network.  Our exchange server is receiving emails and they are being relayed to the users.

This is what we have tried:
1. Rebooted the server
2. Run the internet connection wizard.  I did this because in ther services list, I noticed there were several services related to microsoft exchange that were disabled.
3. We have verified with the ISP that they are not blocking any ports.
4. I disabled the firewall temporarily but that didnot work.
5. I pinged our server from outside of our network got a reply.

Im not sure what to check next.  I thought maybe our server was infected and scanned it with symantec but no virus or trojan was found.

Any suggestions?

0
Comment
Question by:rrincones
  • 3
  • 2
6 Comments
 
LVL 76

Assisted Solution

by:Alan Hardisty
Alan Hardisty earned 2000 total points
ID: 37002090
Visit https://testexchangeconnectivity.com and run the Exchange Activesync test (no Autodiscover) and specify manual server settings.

What does that throw up in the results?
0
 
LVL 78

Expert Comment

by:Rob Williams
ID: 37002193
When the ISP re-enabled your service might they have assigned you a different public IP?
0
 

Author Comment

by:rrincones
ID: 37002853
@Robwill. The ip did not change.

@alanhardisty. The test result failed on validating the certificate name. It states: Host name www.garzapena.com doesnt match any name found on the server certificate CN=localhost, O=Internet wiedgits pty ltd, s=some-state, c=us
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 76

Accepted Solution

by:
Alan Hardisty earned 2000 total points
ID: 37003039
The website is pointing to an Apache Server - which could either mean you have a new server suddenly popped up and catering for your website, or it could mean you have an unwelcome visitor on your server and it is not running Apache on it as part of the virus / infection you have recently been victim of.

Check what is running on your server and run the following in a command prompt:

netstat -anbp tcp >c:netstat.txt

Then type netstat.txt and look for port 443 - what process is listening on port 443?
0
 

Author Comment

by:rrincones
ID: 37004024
@alanhardisty:  Thanks.  I will award you points.  

I checked IIS and noted that the default website and company web were not running.  When I tried to start them, I received an error.  When I looked up the error, I was directed to a microsft page that listed as a possible solution, the steps you listed above.

I found that the reporting feature on Symantec Endpoint Manager was using ports 80 and 443.  The process was listed as httpd.exe.  It indeed uses apache.  I ended the process and started the default website and company web.  Everything is working now.

One question:  How were you able to determine the website is pointing to an apache server?
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 37004093
How I found this out was by visiting https://www.yourdomain.com/exchange - that showed an Apache web server sitting there instead of IIS.

Glad you sorted it - well done.
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The problem of the system drive in SBS 2003 getting full continues to be an issue, even though SBS 2008 and SBS 2011 are both in the market place.  There are several solutions to this, including adding additional drive space or using third party uti…
I've often see, or have been asked, the question about the difference between the Exchange 2010 SP1 version, available as part of Small Business Server (SBS) 2011, and the “normal” Exchange 2010 SP1 Standard. The answer to the question is relativ…
This Micro Tutorial will teach you how to add a cinematic look to any film or video out there. There are very few simple steps that you will follow to do so. This will be demonstrated using Adobe Premiere Pro CS6.
Exchange organizations may use the Journaling Agent of the Transport Service to archive messages going through Exchange. However, if the Transport Service is integrated with some email content management application (such as an anti-spam), the admin…

750 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question