WebDav IIS7 problems copying large files.

I'm having problems with copying large files using webdav to an SBS 2008 (IIS7) server.

I've mapped a drive (to L:) and set up authentication so that ony authenticated users can access the folders.

WebDav works as planned on small files but I get the

"There is a problem accessing L:\",
"Make sure you are connected to the network and try again"

Network Error message on large files

Any clues on a fix would be greatly appreciated
Dale303Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

achaldaveCommented:
What is the client OS ? can you copy large file to non webdav share?

http://support.microsoft.com/kb/932045
0
Dale303Author Commented:
Client is Windows 7. Same file works fine over VPN
0
Dale303Author Commented:
Interestingly, I get "

An unexpected error is keeping you from copying the folder. If you continue to receive this error, you can use the error code to search for help with this problem.

Error 0x800700DF: The file size exceeds the limit allowed and cannot be saved.

<file name>

Try again Cancel"

Error trying to copy it back from SBS2008 to Win 7.

I've checked through http://support.microsoft.com/kb/900900 and chaged the registry key to



HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters\FileSizeLimitInBytes to 0xffffffff on both the Win 7 and SBS machines but still get the error.
0
Cloud Class® Course: SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

achaldaveCommented:
Is your server is configured to use sharepoint services?
Check these articles
http://support.microsoft.com/kb/944981/en-us
http://support.microsoft.com/kb/925083
http://jamesrossiter.wordpress.com/2011/04/04/allow-larger-file-downloads-than-50mb-from-sharepoint-fix-error-0x800700df/

For copying from 2008 to windows 7
Try disabling TCP auto tuning on windows 7 machine,  run from command prompt as administrator and reboot the windows 7 machine
netsh int tcp set global autotuninglevel=disabled


0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Dale303Author Commented:
SBS 2008 has Sharepoint 3.0 on it but the website/server I set up for Webdav is separate from it and is running under the Default App Pool.

Anyway, I've been through...
* http://support.microsoft.com/kb/944981/en-us anyway mainly because it will come in handy for Sharepoint

*http://support.microsoft.com/kb/925083
I modified my web.config file for the webdav site and now looks like this... (note the extra 0 to bump it up from 50 to 500MB)...

<?xml version="1.0" encoding="UTF-8"?>
<configuration>
    <system.webServer>
        <security>
            <requestFiltering>
                <requestLimits maxAllowedContentLength="524288000"/>
            </requestFiltering>
            <authentication>
                <windowsAuthentication enabled="true" useKernelMode="true" />
            </authentication>
        </security>
    </system.webServer>
</configuration>

Anyway, it seems I can now upload to the server but still having that download issue.
*http://jamesrossiter.wordpress.com/2011/04/04/allow-larger-file-downloads-than-50mb-from-sharepoint-fix-error-0x800700df/
is the same tip as my http://support.microsoft.com/kb/900900 link so that was already done but this tip is not working on my Win 7 machine. Any other ideas?
0
Dale303Author Commented:
nevermind... PC reboot seems to have fixed it
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft IIS Web Server

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.