?
Solved

can't start Apache using xampp

Posted on 2011-10-20
19
Medium Priority
?
1,076 Views
Last Modified: 2012-05-12
I installed xampp but cannot start Apache.  When I click the Start button, nothing happens.  in the message box, it just says:

Busy...
Apache started [port 80]

localhost in browser is blank.

I can start mysql just fine but not apache.

Any idea as to why apache would not start on local computer?
0
Comment
Question by:COwebmaster
  • 6
  • 6
  • 4
  • +1
19 Comments
 
LVL 24

Expert Comment

by:johanntagle
ID: 37003634
If browser is blank but doesn't report any error, it may be that the default index.html of xampp is blank and apache is actually running.  Btw, you didn't provide your OS but I assume it's Windows - have you checked if any firewall is blocking it?  Open the command prompt and run "telnet localhost 80" -> what do you get?
0
 

Author Comment

by:COwebmaster
ID: 37003659
yes, windows 7

I tried that code in command prompt but it says 'telnet' is not recognized as an internal or external command operable program or batch file.
0
 
LVL 24

Expert Comment

by:johanntagle
ID: 37003677
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 

Author Comment

by:COwebmaster
ID: 37003711
okay, I installed it.  now after running telnet localhost 80 in cmd prompt it is just a blank screen
0
 
LVL 24

Expert Comment

by:johanntagle
ID: 37003779
Unless MS has come up with a very weird implementation of telnet or a firewall is making it wait, it would have given a timeout or connection refused error if Apache wasn't running, so it's likely Apache is running.  If you're sure your firewall settings are okay, look for the default index.html that came with the package and see what it contains.  If it's blank, put some text in it then reload your browser.
0
 
LVL 8

Expert Comment

by:Ahmed Merghani
ID: 37004970
Open the httpd.config - you can find it in xampp\apache\config directory- and search for this line:
Listen 80

Open in new window

Change it to:
Listen 8080

Open in new window

Then restart all the Apache service or XAMPP.
0
 
LVL 8

Expert Comment

by:Ahmed Merghani
ID: 37004990
After restarting, enter in your browser the url:
localhost:8080

Open in new window

0
 
LVL 24

Expert Comment

by:johanntagle
ID: 37004997
@fishboy2000sd : I'm curious this is needed - does Windows 7 reserve or block port 80 ?
0
 
LVL 8

Expert Comment

by:Ahmed Merghani
ID: 37005187
@johanntagle not always but often there is a program use the port 80. May be an old installation of Apache or something like this.
0
 
LVL 17

Expert Comment

by:Dushan De Silva
ID: 37005762
It should be UAC problem, please disable it.
To disable the UAC, use the program "msconfig". In "msconfig" go to "Tools", select "disable user account control" and verify your selection. Now you must restart Windows. At the same place, you can enable the UAC again.

http://www.apachefriends.org/en/faq-xampp-windows.html
0
 

Author Comment

by:COwebmaster
ID: 37006990
UAC is set to Never Notify.

Also, when I have xampp up and click Start next to Apache, for a split second, it says "running", (and Start turns to Stop), then goes back to Start button.  I don't believe apache is running locally.
0
 
LVL 17

Expert Comment

by:Dushan De Silva
ID: 37007035
After setting UAC, need to restart to Machine.
0
 
LVL 17

Expert Comment

by:Dushan De Silva
ID: 37007043
I also had same experience and after setting UAC and restart the machine, apache was running correctly.
0
 

Author Comment

by:COwebmaster
ID: 37007135
Okay, I rebooted my machine.  Still I get same experience with Apache not running.
0
 
LVL 8

Expert Comment

by:Ahmed Merghani
ID: 37007365
Did you try to change the listening port?
0
 

Author Comment

by:COwebmaster
ID: 37007390
yes, I tried that but still nothing
0
 
LVL 8

Accepted Solution

by:
Ahmed Merghani earned 2000 total points
ID: 37007504
And do you restart your machine?
Are you sure, it is the suitable version for you machine and OS?

Anyhow, I suggest you to use WAMP instead and this is the link:
http://www.wampserver.com/en/
0
 

Author Closing Comment

by:COwebmaster
ID: 37008054
wamp worked after I uninstalled mcafee.  Thanks for the suggestion!
0
 
LVL 8

Expert Comment

by:Ahmed Merghani
ID: 37008180
You are welcome
0

Featured Post

NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

There are times when I have encountered the need to decompress a response from a PHP request. This is how it's done, but you must have control of the request and you can set the Accept-Encoding header.
In this article, we’ll look at how to deploy ProxySQL.
The viewer will learn how to dynamically set the form action using jQuery.
The viewer will learn how to count occurrences of each item in an array.
Suggested Courses
Course of the Month15 days, 8 hours left to enroll

850 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question