• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 902
  • Last Modified:

I cannot sent email from my thunderbird or windows live email, but i can receive email

I NEED AN IMMEDIATELY SOLUTION, MY EMAIL SERVICES HAS BEEN DOWN FOR ALMOST A WEEK IT WAS WORKING ONE DAY AND STARTED GIVING ME THE ERROR MESSAGE THE NEXT. BELOW IS THE ERROR MESSAGE I GET WHEN I ATTEMPT TO SEND A EMAIL OUT (SMTP). I CAN RECEIVE EMAIL BUT NOT SEND ANY. WHAT IS THE PROBLEM, I NEED HELP!!


ERROR MESSAGE: An error occurred during a connection to mail.b1fam.com:25

SSL received a record that exceeded the maximum permissible length.

(Error code: ssl_error_rx_record_too_long)

THANKS IN ADVANCE
0
dramous44
Asked:
dramous44
  • 2
  • 2
  • 2
  • +1
1 Solution
 
leader716Commented:
Sounds like the SSL certificate is invalid or expired for the server. Check that and install or generate a new certificate
0
 
FarWestCommented:
I don't think that port 25 is valid for ssl
you should either remove ssl from smtp option or change the port to ssl port that is documented in the email provider
0
 
leader716Commented:
This is the one that is used for TLS encryption. As a test you could disable SSL for sending email, if that works then you know that it is a certificate problem.  
0
 [eBook] Windows Nano Server

Download this FREE eBook and learn all you need to get started with Windows Nano Server, including deployment options, remote management
and troubleshooting tips and tricks

 
Dave BaldwinFixer of ProblemsCommented:
This page http://www.emailaddressmanager.com/tips/mail-servers.html shows the normal ports for different email functions.  Port 465 is the common one for secure email.  It sounds like either you accidentally changed to require SSL or you changed the port.  Your provider should have the correct answer.
0
 
dramous44Author Commented:
I have read over all the questions, but i find that it only solved part of my problem, what i did was create a self signing certificate in plesk, because i did not know how to renew the old one, i reboot the server and my emails started going out, but about ten minutes later, the same error start over again, so i need help in resolving this issue.  I was getting this message in my email about my certificate is about to expire in 14 days, so i just created a new self signing certificate so the message will stop and hopefully this will be the solution to my outgoing email issue, but if not take me in the right direction.


thanks ahead of time
0
 
dramous44Author Commented:
here is the error message i get when the email is being sent:

An error occurred during a connection to mail.b1fam.com:25.

SSL received a record that exceeded the maximum permissible length.

(Error code: ssl_error_rx_record_too_long)
0
 
Dave BaldwinFixer of ProblemsCommented:
As we said above, secure email does not normally use port 25.  That looks like an error.  It should (usually) be port 465.
0

Featured Post

What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

  • 2
  • 2
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now