subprocess Popen

This is driving me crazy as I cant figure out why it wont work. I have this very simple logic that once I can get working, I will start building more complex pieces:

process = Popen(['scp -i keyfile' ,'localpath', 'user@device:/remotepath'],  stdout=PIPE, stderr=PIPE)
stdout, stderr = process.communicate()



no matter how many ways I try to use the -i flag for the indentity to use for scp I get this:
Traceback (most recent call last):
  File "./test.cgi", line 11, in <module>
 
  File "/usr/lib/python2.7/subprocess.py", line 672, in __init__
    errread, errwrite)
  File "/usr/lib/python2.7/subprocess.py", line 1213, in _execute_child
    raise child_exception
OSError: [Errno 2] No such file or directory


If I run it without the -i flag, it works but I am prompted for password. If I run the exact same command (the scp portion for the Linux command line, it works fine... Is there some special way to deal with passing flags to the system binary being used with Popen?


I had used this same method way back and had working, but just cant seem to get it right here. Anyone have any pointers.


thanks
Andy
LVL 1
andrew_89Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

gelonidaCommented:
Few questions.


Shouldn't you write:

process = Popen(['scp', '-i',  'keyfile' ,'localpath', 'user@device:/remotepath'],  stdout=PIPE, stderr=PIPE)


instead of:

process = Popen(['scp -i keyfile' ,'localpath', 'user@device:/remotepath'],  stdout=PIPE, stderr=PIPE)

0
gelonidaCommented:
Some more coments:

Make sure, (one of the below options is true)
- keyfile is an absolute paht name
- the python script is started in the directory, where keyfile is located
- the python script performs an os.chdir() to the right directory before running scp

Do not use '~/.ssh/id_xxx' as file name. I think this would not be expanded.
use better os.path.join(os.environ['HOME'], '.ssh/id_xxx')

You might considerusing the option '-q' in order to get rid of the prgress bar

process = Popen(['scp', '-i',  'keyfile' , '-q', 'localpath', 'user@device:/remotepath'],  stdout=PIPE, stderr=PIPE)


0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
andrew_89Author Commented:
thanks that gets rid of the error but now of course I still get password prompt. That will  end up being another issue that I can debug separately.



andy
0
gelonidaCommented:
Two ways of getting rid of the password:
- ssh-agent can store the ssh passwords for you, so you don't have to enter them multiple times.

just run ssh-agent
and ssh-add prior to running your script.

Alternatively your python script could prompt for the password.

and you could use Pexpect (under linux) to send the password to scp


For more details it's probably best to open a new question.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Python

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.