• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1033
  • Last Modified:

Cisco Catalyst 3500XL - Does it Support "unsupported GBIC?"

Hi Experts,

Here is the GBIC I am using into my Cisco Catalyst 3500XL

 GBIC
I am checking to see if I need to use this command:

service unsupported-transceiver
no errdisable detect cause gbic-invalid


Or whether I need to buy a different GBIC?  I plugged them into my network and could not see my fiber devices.
0
activematx
Asked:
activematx
  • 7
  • 7
1 Solution
 
HellmarkCommented:
You should be able to get it working with the noerr command. In my experience, just taking care of that gets them working.
0
 
activematxAuthor Commented:
Does this model support that command?
0
 
activematxAuthor Commented:
I type that command into my switch.  I don't think it supports that command.  Does this mean I need to buy CISCO Branded GBIC?
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
HellmarkCommented:
What is the output of when you tried to use that command? Also, what mode were you in when you tried running that command?
0
 
activematxAuthor Commented:
After telnetting in I entered: en

Then I typed in my password.  That is the mode i was in.

The output was something along the lines of:

service unsupported-transceiver
              ^      The switch did not support the command at this mark

no errdisable detect cause gbic-invalid
         ^      The switch did not support the command at this mark
0
 
HellmarkCommented:
Well, that is your problem. You have to be in configure mode in order to use those commands.

hit en and log in just like you did, but then afterwards type in conf t, then type in those other commands. Then type exit. If things are working, type write
0
 
activematxAuthor Commented:
Okay, I purchased Cisco Branded GBIC's and it is still not working.  Also, when I plug the fiber in, I don't get any status light (green / orange) on the switch

Here is what I am seeing:

 Telnet 1 Telnet 2 Telnet 3
0
 
HellmarkCommented:
If your system starts with nothing on that interface, it may be set to disabled, and depending on what you did, it could have stored that in the settings, so that even after rebooting, it will still be disabled.
Switch>en
[i](give ID and password)[/i]
Switch#conf t
Switch(config)#int gi 0/1
Switch(config-if)#no shut

Open in new window


Just to be sure, copy and paste your config (from the base enable mode, do show run). Also, since this will most likely be several screen fulls, it will be best to copy and paste it, instead of doing screen shots.
0
 
HellmarkCommented:
Any luck with this yet?
0
 
activematxAuthor Commented:
Hellmark,

Thank you so much for helping me with this.  I am currently in Los Angeles and can't test this right now...

I will post back in a week, and pray that you will still be here to help me.  
0
 
HellmarkCommented:
I'll be here. Just post back, and EE will notify me by email.
0
 
activematxAuthor Commented:
I will be performing these steps this evening.  I will post results.  Thanks Hellmark!
0
 
HellmarkCommented:
Any Luck?
0
 
activematxAuthor Commented:
Hi Hellmark,

I inputted the commands successfully.  I will plug the switch into my fiber port in 8 hours from now.  I hope that it detects the fiber.

On a side note, I tried plugging in a Cisco SF-200 switch and that was able to get a green status light from the fiber.

I don't think my GBIC's or my switch is defective since I have a dozen GBIC's which I am swapping from and I have two Cisco 3500 XL switches which are both configured the same.

Here is my current configuration:

Cisco3500#show run
Building configuration...

Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cisco3500
!
enable secret 5 $1$BPo.$9bwr..DMroxT8naivyM4I1
!
!
!
!
!
!
ip subnet-zero
!
!
!
interface FastEthernet0/1
!         
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!         
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface VLAN1
 ip address 192.168.121.253 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
!
ip default-gateway 192.168.121.1
snmp-server engineID local 00000009020000097C873780
snmp-server community private RW
snmp-server community public RO
!
line con 0
 exec-timeout 0 0
 transport input none
 stopbits 1
line vty 0 4
 password ******
 login
line vty 5 15
 password ******
 login
!
end

Open in new window

0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 7
  • 7
Tackle projects and never again get stuck behind a technical roadblock.
Join Now