• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 910
  • Last Modified:

Packet loss with IP HASH- HELP!!!

Dear All,

 

We have 5 ESXi Server jonined a HA cluster. We want to use IP Hash based laod balancing. We have HP BL 680G7 Blade servers with HP GBE2C switch. We have 6 NIC and 2 vLAN needs to be communicated through same. Our 2xGBE2C switch are connected to Nexus 2x2248 switch which then connected to Nexus 2x5010 connected to 2xCISCO 6506 Core switch. The VLAN are defined on Juniper firewall which is conencted to Cisco core switch. there are 6 NIC connected to vSwitch0 and VM Network port group the policy is set to IP HASH. In this scenario we are having packet loss even with ping. We changed the load balancing at switch level and still the packet loss is coming. If we try to switch OFFany GBE2C switch in our blade chassis, all seems to work without any issue, e.g. no packet loss but when we switch ON both switch the packet loss issue is coming.

 

One more thing, if we set the load balancing to "Based on VLAN ID" then all seems to work well. We want to use IP HASH only as there only we achive true load balancing. Also We have got the configuration checked with VMware L2 and so many other experts and they all say all the config is as per requirement. We are using ESXi v4.1. Can someone help to isolate as we are stuck in this for last 1 month without a solution.

 

Thanks a ton in advance..
0
mukvinman
Asked:
mukvinman
  • 3
1 Solution
 
mukvinmanAuthor Commented:
i m posting the configuration related to our setup in core switch. Please let me know if any other config is required and i will provide same to close.

 

BTH-SF-N5k-01# sh int ethernet 101/1/1 switchport

Name: Ethernet101/1/1

  Switchport: Enabled

  Switchport Monitor: Not enabled

  Operational Mode: trunk

  Access Mode VLAN: 1 (default)

  Trunking Native Mode VLAN: 1 (default)

  Trunking VLANs Enabled: 1-3967,4048-4093

  Administrative private-vlan primary host-association: none

  Administrative private-vlan secondary host-association: none

  Administrative private-vlan primary mapping: none

  Administrative private-vlan secondary mapping: none

  Administrative private-vlan trunk native VLAN: none

  Administrative private-vlan trunk encapsulation: dot1q

  Administrative private-vlan trunk normal VLANs: none

  Administrative private-vlan trunk private VLANs:

  Operational private-vlan: none

  Unknown unicast blocked: disabled

  Unknown multicast blocked: disabled

 

BTH-CR-6506-02#sh int tenGigabitEthernet 1/15 switchport

Name: Te1/15

Switchport: Enabled

Administrative Mode: trunk

Operational Mode: trunk (member of bundle Po4)

Administrative Trunking Encapsulation: dot1q

Operational Trunking Encapsulation: dot1q

Negotiation of Trunking: On

Access Mode VLAN: 1 (default)

Trunking Native Mode VLAN: 1 (default)

Administrative Native VLAN tagging: enabled

Operational Native VLAN tagging: disabled

Voice VLAN: none

Administrative private-vlan host-association: none

Administrative private-vlan mapping: none

Operational private-vlan: none

Trunking VLANs Enabled: ALL

Pruning VLANs Enabled: 2-1001

Capture Mode Disabled

Capture VLANs Allowed: ALL

 

Unknown unicast blocked: disabled

Unknown multicast blocked: disabled

 

We have tried so many options but nothing seems to work, so please help.

 

Thanks again...
0
 
mukvinmanAuthor Commented:
issue fixed
0
 
mukvinmanAuthor Commented:
esxi doesnt support 2 eather tunnels in IP hash
0

Featured Post

Cyber Threats to Small Businesses (Part 2)

The evolving cybersecurity landscape presents SMBs with a host of new threats to their clients, their data, and their bottom line. In part 2 of this blog series, learn three quick processes Webroot’s CISO, Gary Hayslip, recommends to help small businesses beat modern threats.

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now