?
Solved

Remove some stubborn items ignored by Cisco PIX ACL firewall PCI

Posted on 2011-10-21
3
Medium Priority
?
416 Views
Last Modified: 2012-05-12
Hi,

I am not a Cisco guy but previously, ports 1433 and 1434 were open to allow SQL from our management company. Needless to say I put a stop to it since it was on machines in the card holder emviroment.However I'm not sure how he did it but he added them in a way that  they're being ignored by pics however when I run  are settings in the plain text I can see those lines are still there I'll post brief piece of our logs and  if someone could be so kind and point out anything in their that just seems horribly wrong it would be greatly appreciated. By the way, all of our machines are connected to this security appliance and is our only gateway at the time, it has two interfaces  so I plan to segregate or isolate those in the payment card holder environment. Should I based on the logs below also put a secondary security appliance I was thinking of one running in the next such as clearOS or centOS.  any insight in the logs you can give me would be greatly appreciated and any other best practices used  open source software for security management purposes would be greatly appreciated as well.

Thanks,



Building configuration...
: Saved
:
PIX Version 6.3(5)
interface ethernet0 10baset
interface ethernet1 10baset
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password XXXXXXXXXXXXX encrypted
passwd 8/XXXXXXXXXX ncrypted
hostname cisco-pix
domain-name bs-one.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list 100 permit icmp any any
access-list 100 permit tcp any any eq 1433
access-list 100 permit tcp any any eq 1434
access-list 100 permit udp any any eq 1434
access-list 100 permit udp any any eq 1433
access-list any permit tcp any any eq 1433
access-list any permit udp any any eq 1434
access-list 300 permit ip any any
access-list inbound permit tcp any any eq 82
access-list inbound permit tcp any any eq 15962
access-list inbound permit tcp any any eq 9000
pager lines 20
logging on
logging buffered warnings
mtu outside 1500
mtu inside 1500
ip address outside XX.XX.113.2 255.255.255.240
ip address inside 10.63.104.11 255.255.0.0
ip audit info action alarm
ip audit attack action alarm
pdm location 10.63.104.253 255.255.255.255 inside
pdm location 10.63.104.0 255.255.255.0 inside
pdm location 10.63.104.227 255.255.255.255 inside
pdm location 10.63.104.69 255.255.255.255 inside
pdm logging debugging 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
access-group inbound in interface outside
access-group 300 in interface inside
route outside 0.0.0.0 0.0.0.0 XX.X.113.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 10.63.104.253 255.255.255.255 inside
http 10.63.104.227 255.255.255.255 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
telnet timeout 5
ssh 10.63.104.0 255.255.255.0 inside
ssh 10.63.104.69 255.255.255.255 inside
ssh timeout 60
console timeout 0
username aperez password XXXXXXXXXXXXXXXX encrypted privilege 15
terminal width 80
Cryptochecksum:7576007370f717fa6d5970111f5595a8
: end
[OK]
0
Comment
Question by:kaosmadness
  • 2
3 Comments
 
LVL 79

Expert Comment

by:lrmoore
ID: 37005808
The only pieces you need to be concerned with are these:

>access-group inbound in interface outside
This is the name of the access-list that is applied for traffic coming IN from OUTSIDE

access-list inbound permit tcp any any eq 82
access-list inbound permit tcp any any eq 15962
access-list inbound permit tcp any any eq 9000

These are the only 3 ports allowed in from outside to internal hosts

You can safely delete acl "100" and acl "any" because they are not applied anywhere
no access-list 100 permit icmp any any
no access-list 100 permit tcp any any eq 1433
no access-list 100 permit tcp any any eq 1434
no access-list 100 permit udp any any eq 1434
no access-list 100 permit udp any any eq 1433
no access-list any permit tcp any any eq 1433
no access-list any permit udp any any eq 1434
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 2000 total points
ID: 37005826
Additionally, if you don't have any static nat entries - don't know if you deliberatley left them out or if they just don't exist in the config - the inbound acl is not doing any good either and can also be safely deleted and removed from the interface. Access-lists simply don't do any good without the appropriate static port mappings.

Given the posted config, I would expect to see something like:
 static (inside,outside) tcp interface 82 10.63.104.xx 82 netmask 255.255.255.255
 static (inside,outside) tcp interface 15962 10.63.104.xx 15962 netmask 255.255.255.255
 static (inside,outside) tcp interface 9000 10.63.104.xxx 9000 netmask 255.255.255.255
0
 

Author Closing Comment

by:kaosmadness
ID: 37110228
thanks!
0

Featured Post

Veeam Disaster Recovery in Microsoft Azure

Veeam PN for Microsoft Azure is a FREE solution designed to simplify and automate the setup of a DR site in Microsoft Azure using lightweight software-defined networking. It reduces the complexity of VPN deployments and is designed for businesses of ALL sizes.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Imagine you have a shopping list of items you need to get at the grocery store. You have two options: A. Take one trip to the grocery store and get everything you need for the week, or B. Take multiple trips, buying an item at a time, to achieve t…
A 2007 NCSA Cyber Security survey revealed that a mere 4% of the population has a full understanding of firewalls. As business owner, you should be part of that 4% that has a full understanding.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

839 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question