• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 684
  • Last Modified:

DFS Namespace not working properly

Hey guys,

I have a couple of namespaces.Some of them are 2008 mode and some of them are in 2000 mode. We are all running domain and forest level R2. When I type from computers or servers \\domain.com\namespace\folder it works .
 When I type \\domain.com\ I do get only NETLOGON and SYSVOL share. Why the namespace don't show ?
Also I should be able to access by netbios as well not necessary by FQDN. So I tried \\netbios\namespace\ and it works. But when i just do \\netbios\ without the namespace it doesnt work.

Any ideas ?

 

Any ideas guys where should I start troubleshooting this ? DNS issue ?

 

Thanks a lot.
0
tog2012
Asked:
tog2012
  • 3
1 Solution
 
Paul MacDonaldDirector, Information SystemsCommented:
I think that's default behavior.  The namespaces act like they're hidden.
0
 
kevinhsiehCommented:
You get that because if you don't specify the DFS namespace, you connect to any domain controller, not necessarily a domain contoller that hosts the namespace. If you connect to \\dfsnamespaceserver you will see the namespace as one of the shares. A namespace is not hidden unless you put $ at the end of the namespace name. If you want to be able to browse to the namespace by just entering the domain name, host the namespace on EVERY domain controller in the domain.
0
 
tog2012Author Commented:
that`s very interesting. I`ll try that kevin and see if it works. So on DC I should install DFS and make sure the namespace is hold on that DC as well . Right now my namespace are hold by file servers.
0
 
tog2012Author Commented:
you are right kevin. Thanks a lot It works now.
0
 
tog2012Author Commented:
Thanks a lot
0

Featured Post

Vote for the Most Valuable Expert

It’s time to recognize experts that go above and beyond with helpful solutions and engagement on site. Choose from the top experts in the Hall of Fame or on the right rail of your favorite topic page. Look for the blue “Nominate” button on their profile to vote.

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now