How can I fix Server 2000 OS?

Posted on 2011-10-21
Last Modified: 2013-12-05
Dell PowerEdge 840
Service Tag: JT72MD1
Setup has a Perc/5i adaptor, DVD and Floppy drives, 3 160 GB HDD's
OS I believe is Windows 2000

I have a client whom hasn't had us service their server in several months, and their server's OS has gotten corrupted. Now this server needs to be fixed since it has software on it that allows them to read some particular data on the RAID5 array.

I've tried booting off of a system disk to attempt a repair, but the server doesn't give any options to 'hit any key to boot from CD' etc. I have connected a separate hard drive to SATA0 on the motherboard itself and activated the port in the BIOS. Only problem is, after the system reboots to put the change into effect, it doesn't keep the change. SATA0 is 'Off' when I check back in the BIOS.

Which for that particular issue, I have tried changing out the battery on the BIOS. That didn't fix that particular issue. I have even downloaded the server BIOS from the Dell website and placed the file on a floppy in the proper manner directed on the Dell site. This didn't get any where either, the system will read the floppy disk, but it never really even truly gets started with the upgrade. It will sit there, this is what it reads, BIOS Upgrade
The last thing I have done is insert a spare video card I had laying around, as when the system boots up, it will revert to a blank screen after going through system boot up. Which the video card revealed what it had been saying,
'Loading PBR for descriptor 1...done.'

The message will stay on the top left corner of the screen, and doesn't do anything else.

I've run out of ideas on what to do in getting this thing running again, so I would certainly appreciate
 any assistance in this matter.
Question by:xsawkins
    LVL 25

    Expert Comment

    First, how do you know the operating system is corrupted?

    You need to return the system to the state it was before you touched it. If the original video card was bad, then change it. If you made any BIOS changes, reverse them.

    Next, have you checked the battery on the Perc/5i adaptor card?

    You need to create a boot disk to point the system to the Perc/5i adaptor, and thus to the raid array.

    You need to locate and download the correct boot disk data and be able to identify the correct Windows 2000 mass storage driver.

    One of the files in the driver package is TXTSETUP.OEM. Edit TXTSETUP.OEM with NOTEPAD (or a text editor of your choice). In the [Defaults] section locate the line that starts with “scsi = “. The
    value on the right hand side of the equals sign must represent the Windows 2000 mass storage driver.

    You will find all of the drivers you need here:

    Author Comment

    The OS being corrupted is our best guess, as it doesn't boot up after it passes through the BIOS.  Far as changes, the only changes we've made is the boot sequence when we were wanting the server to boot off of the Windows Server 2000 disc in an attempt to repair the OS. Which it never did offer any 'hit any key to boot from CD etc.'. Just goes straight to the blank screen with 'Loading PBR for descriptor 1...done.'

    Also, the server didn't have a video card. It used what was built into the motherboard itself. Which is why I had put a video card in there to see if the motherboards' video card wasn't displaying something after it passed through the BIOS boot.

    On the 21st, we had also switched the Perc/5i into another Dell server we had (So battery works fine). Essentially as a means of seeing if it would work on this computers' BIOS. Which still came with same results. Both servers can recognize the RAID adaptor, and in the adaptors configuration, it detects the RAID5, the 3 HDD's attached to it, and reads them as being in optimal condition. Seeing as the system detects the Perc/5i adaptor just fine and the RAID on it, would I still need to point the system to the adaptor?

    We did a test, where we unplugged the RAID5 from the Perc/5i adaptor to see if it would boot from the Windows Server 2000 disc we've been trying to have the system boot from and failing. This time, it booted from the disc perfectly fine, despite us having setup the BIOS to boot from the disc before the RAID itself earlier. We have even gone into the boot menu and told the system to boot from the disc itself, and still doesn't boot from the CD. Whether the CD is in the systems internal CD drive, or an external USB drive.

    Apologies on the late update as well.
    LVL 25

    Expert Comment

    If I had to venture a guess, it would be that you have a BIOS issue, as you should be able to force the BIOS to boot to the CD first.

    Author Comment

    Possibly, but the BIOS on two different Dell Server systems both not wanting to boot directly to the disc? A bit unlikely I would have to imagine, unless we are just that unlucky!
    LVL 25

    Accepted Solution

    The other issue is that your Windows 2000 server CD requires a Windows 200 Server boot disk.

    Manual installations usually come in 3 flavors:

    Boot from CD - No existing partition is required.

    Boot from the 4 Setup Boot Disks, then insert the CD - No existing partition is required.

    Boot from an MS-DOS startup floppy, go to the command prompt, create a 4GB FAT32 partition with FDISK, reboot, format the C partition you've created, then go to the CD drive, go into the I386 folder, and run the WINNT.EXE command.
    LVL 15

    Assisted Solution

    It sounds to me like your hardware may be toast.

    Author Comment

    Update: On Friday, several co-workers and I managed to get the server to boot from the Windows 2000 disc. Attempted to do a second level repair of OS, with the disc reporting being unable to locate any OS.

    Previously we had attempted doing backup of RAID5 data with 3rd party software, but were unsuccessful.

    We will be calling it quits on this server, as we have spent more time than are able to bill.

    I wish to thank you two for taking the time in attempting to help us fix this server.

    Author Closing Comment

    Calling it quits on attempting restoration of server with RAID5 data intact.

    Hardware possibly damaged/worn out, or software corrupted.

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Enabling OSINT in Activity Based Intelligence

    Activity based intelligence (ABI) requires access to all available sources of data. Recorded Future allows analysts to observe structured data on the open, deep, and dark web.

    On a regular basis I get questions about slow RDP performance, RDP connection problems, strange errors and even BSOD, remote computers freezing or restarting after initiation of a remote session. In a lot of this cases the quick solutions made b…
    Welcome to my series of short tips on migrations. Whilst based on Microsoft migrations the same principles can be applied to any type of migration. My first tip is around source server preparation. No migration is an easy migration, there is a…
    Need more eyes on your posted question? Go ahead and follow the quick steps in this video to learn how to Request Attention to your question. *Log into your Experts Exchange account *Find the question you want to Request Attention for *Go to the e…
    how to add IIS SMTP to handle application/Scanner relays into office 365.

    779 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    15 Experts available now in Live!

    Get 1:1 Help Now