?
Solved

Port Forwarding is not working on my Linksys e1000

Posted on 2011-10-21
14
Medium Priority
?
858 Views
Last Modified: 2012-05-12
Hello All,

I am trying to setup port forwarding on my Linksys E1000 and a Windows XP computer.  I need to have a block of 100 ports available for some software to communicate across the internet.  The software will run on a Windows XP machine and there shouldn’t be more than 5 to 10 connections to the computer at any one time.  Right now there are only about 3 connections.  

I followed the instructions as defined in the E1000 docs.  I have a static IP from my cable provider.  I have that programmed in the router.  This seems to be working fine because I have wired and wireless connections communicating through the router that don’t need specific IPs, so these computers use the default dynamic configuration. I just need the XP computer to have a static IP address.

I went to the applications and games areas and then the port forwarding tab and typed in the following:
Start   End    Protocol   IP Address      Enabled
6700 6799     Both      192.168.1.102   Yes

Then I set up the XP computer to point to 192.168.1.102 .  The subnet mask was set to 255.255.255.240 – according to the cable guys.

So, I checked the computer setup using “ipconfig /all”.  It shows that the address was set, but the DHCP has not.  It said No.  I bring this up because on my wireless laptop the DHCP is set to yes for its configuration.  But this configuration is automatic.  The IP is not specified, so it is getting its IP from the router.

On the XP computer, after I setup everything, I get no internet access at all.  I tried to ping yahoo.com – no luck.  On my laptop, I did ping yahoo.com successfully.

What am I doing wrong?  I think it is either the DHCP or a firewall issue.  However, I did disable the firewall on the XP computer – still no luck.

Desperate. Please advise.

0
Comment
Question by:garrickbradley660
  • 5
  • 3
  • 2
  • +3
14 Comments
 
LVL 26

Expert Comment

by:Soulja
ID: 37007622
Can you ping by ip address out to the internet. Try ping 4.2.2.2
0
 
LVL 26

Expert Comment

by:Soulja
ID: 37007628
If you can ping by ip address to the internet, than you need to check your dns settings on the xp computer. Make sure you have a dns server ip address configured on it.  Then try pinging a yahoo.com or such.
0
 
LVL 31

Assisted Solution

by:Wayne Barron
Wayne Barron earned 600 total points
ID: 37007652
Once you setup a static IP on your computer, you loose the DHCP that is why it shows NO.

Can you screenshot your Network Card settings and upload it here?
This way we can see what you have.

You want to make sure that your gateway is the IP Address of the Router.
Which is usually
192.168.1.1
(or)
192.168.2.1

Then set up the DNS Server to the DNS of your ISP for both, you should be able to go online and type in your ISP's name and then DNS information and get that.

Carrzkiss
0
Get your Conversational Ransomware Defense e‑book

This e-book gives you an insight into the ransomware threat and reviews the fundamentals of top-notch ransomware preparedness and recovery. To help you protect yourself and your organization. The initial infection may be inevitable, so the best protection is to be fully prepared.

 

Author Comment

by:garrickbradley660
ID: 37007684
I am using the DNS server settings given to me by the Cable Internet provider.  I am typing these numbers in on the same screen that I am using to specify the computer's specific IP address.
0
 

Author Comment

by:garrickbradley660
ID: 37007688
What does pinging 4.2.2.2 do?
0
 

Author Comment

by:garrickbradley660
ID: 37007711
I really don't think that I am able to access the internet at all.  

What's weird is, I used an old Wireless-G Linksys router and this worked fine until 2 days ago when I tried to upgrade.  Once, I put on the new router I followed the instructions as before, and I couldn't get it to work.  I think I am missing something very simple.
0
 
LVL 27

Expert Comment

by:davorin
ID: 37007751
Most probably your network mask on XP is wrong.
Configure XP to use DHCP and connect it to router. Use ipconfig and check the ip address and network mask. most probably it will be 192.168.0.x and 255.255.255.0. Configure again static IP on your xp and use the mask you sow previously.
0
 
LVL 27

Expert Comment

by:davorin
ID: 37007773
Or check the LAN network mask on router and use the same on XP. You are using UTP cable to connect, aren't you?
0
 

Author Comment

by:garrickbradley660
ID: 37007802
What is a UTP cable?  I am connecting these devices using ethernet cables.  

I tried using two subnet masks.  255.255.255.0 and 255.255.255.240 (this the mask give to me by the Cable Internet guys).
0
 
LVL 27

Expert Comment

by:davorin
ID: 37007863
Yes, thats ethernet cable. if you use dhcp on xp what ip address, mask and gateway do you get?
0
 
LVL 31

Expert Comment

by:Wayne Barron
ID: 37008102
Take a screenshot of your Settings for the Ethernet Card and post it here
0
 

Author Comment

by:garrickbradley660
ID: 37008159
I will respond this evening with the screen shots.  Thanks so much for the help.  I will get back to you tonight.
0
 
LVL 8

Accepted Solution

by:
askurat1 earned 1400 total points
ID: 37008776
Here should be your TCP/IP settings:

IP: 192.168.1.102
Subnet Mask: 255.255.255.0
Default Gateway: This is the IP of the router, normally 192.168.1.1

DNS Server: Also the router IP

If all the setting are correct on the router this should work.

0
 
LVL 10

Expert Comment

by:Jim-R
ID: 37008788
FYI,  I believe UTP stands for Unshielded Twisted Pair.



The network mask should be 255.255.255.0 on all the computers in your simple network.

Make certain that the WAN IP from your cable provider is, in fact, STATIC.  Many times it would appear the IP is static, however it may not be.  I know my IP is dynamic, but it remains the same, sometimes for weeks on end.  If, however, I change out the router, it will change immediately.

The XP Computer should have the specific router IP set as you indicated.  Otherwise, it would be purely by chance that the ports forwarded would ever see that XP computer.  If your router allows reserving that IP for a specific computer, you could do that so no other computer addressing the router is allowed to take the IP that your ports are forwarded to.

Also note that once a port is forwarded to one specific IP (your XP Computer), those ports can not be used by any other IP (computer) on the same router.

0

Featured Post

Important Lessons on Recovering from Petya

In their most recent webinar, Skyport Systems explores ways to isolate and protect critical databases to keep the core of your company safe from harm.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The Cisco RV042 router is a popular small network interfacing device that is often used as an internet gateway. Network administrators need to get at the management interface to make settings, change passwords, etc. This access is generally done usi…
Creating an OSPF network that automatically (dynamically) reroutes network traffic over other connections to prevent network downtime.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

807 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question