Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1062
  • Last Modified:

Exchange 2007 SP3 install errors

Trying to install SP3 on Exchange 2007 in order to continue the migration of exchange 2003 environment. Fails on Hub Transport Role Prerequisites, Client Access Role Prerequisites, Unified Messaging Server Role Prerequisites, and Mailbox Role Prerequisites.
Error:

There was a problem accessing the registry on this computer. This may happen if the Remote Registry service is not running; it may also indicate a network problem.

I have checked the Registry services are running on this server and on the Exchange 2003 server. This server is a stand alone. Client for Microsoft Networks and File and Printer Sharing for Microsoft Networks are enabled.

Below is the setup log. Any help on this is greatly appreciated!

 

[10/20/2011 10:01:48 PM] [0] **************

[10/20/2011 10:01:48 PM] [0] Setup will run the task 'test-setuphealth'

[10/20/2011 10:01:48 PM] [1] Setup launched task 'test-setuphealth -DomainController 'exchange2003.domain' -DownloadConfigurationUpdates $true -ExchangeVersion '8.3.83.6' -Roles 'Global' -ScanType 'PrecheckUpgrade' -SetupRoles 'Global' -PrepareLegacyExchangePermissions $null -PrepareOrganization $true -PrepareSchema $true'

[10/20/2011 10:01:48 PM] [1] Beginning processing.

[10/20/2011 10:01:52 PM] [1] Beginning processing.

[10/20/2011 10:01:52 PM] [1] Beginning processing.

[10/20/2011 10:01:52 PM] [1] Administrator Active Directory session settings are: View Entire Forest: 'True', Configuration Domain Controller: 'exchange2003.domain', Preferred Global Catalog: 'exchange2003.domain', Preferred Domain Controllers: '{ exchange2003.domain }'

[10/20/2011 10:01:52 PM] [1] Searching objects of type "ResourceBookingConfig" with filter "$null", scope "OneLevel" under the root "Global Settings".

[10/20/2011 10:01:52 PM] [1] Previous operation run on domain controller 'exchange2003.domain'.

[10/20/2011 10:01:52 PM] [1] Preparing to output objects. Maximum result set size "unlimited".

[10/20/2011 10:01:52 PM] [1] Administrator Active Directory session settings are: View Entire Forest: 'True', Configuration Domain Controller: 'exchange2003.domain', Preferred Global Catalog: 'exchange2003.domain', Preferred Domain Controllers: '{ exchange2003.domain }'

[10/20/2011 10:01:52 PM] [1] Searching objects of type "ResourceBookingConfig" with filter "$null", scope "OneLevel" under the root "Global Settings".

[10/20/2011 10:01:52 PM] [1] Previous operation run on domain controller 'exchange2003.domain'.

[10/20/2011 10:01:52 PM] [1] Processing object "Resource Schema".

[10/20/2011 10:01:52 PM] [1] Ending processing.

[10/20/2011 10:01:52 PM] [1] Ending processing.

[10/20/2011 10:01:52 PM] [1] Beginning processing.

[10/20/2011 10:01:52 PM] [1] Administrator Active Directory session settings are: View Entire Forest: 'True', Configuration Domain Controller: 'exchange2003.domain', Preferred Global Catalog: 'exchange2003.domain', Preferred Domain Controllers: '{ exchange2003.domain }'

[10/20/2011 10:01:52 PM] [1] Searching objects "Exchange2007Server" of type "Server" under the root "$null".

[10/20/2011 10:01:52 PM] [1] Previous operation run on domain controller 'exchange2003.domain'.

[10/20/2011 10:01:52 PM] [1] Previous operation run on domain controller 'exchange2003.domain'.

[10/20/2011 10:01:52 PM] [1] Preparing to output objects. Maximum result set size "unlimited".

[10/20/2011 10:01:52 PM] [1] Ending processing.

[10/20/2011 10:01:53 PM] [1] Ending processing.

[10/20/2011 10:01:53 PM] [0] **************

[10/20/2011 10:01:53 PM] [0] Setup will run the task 'test-setuphealth'

[10/20/2011 10:01:53 PM] [1] Setup launched task 'test-setuphealth -DomainController 'exchange2003.domain' -DownloadConfigurationUpdates $false -ExchangeVersion '8.3.83.6' -Roles 'Bridgehead' -ScanType 'PrecheckUpgrade' -SetupRoles 'Bridgehead','ClientAccess','UnifiedMessaging','Mailbox','AdminTools' -TargetDir 'D:\Exchange2007Server''

[10/20/2011 10:01:53 PM] [1] Beginning processing.

[10/20/2011 10:01:56 PM] [1] Beginning processing.

[10/20/2011 10:01:56 PM] [1] Administrator Active Directory session settings are: View Entire Forest: 'True', Configuration Domain Controller: 'exchange2003.domain', Preferred Global Catalog: 'exchange2003.domain', Preferred Domain Controllers: '{ exchange2003.domain }'

[10/20/2011 10:01:56 PM] [1] Searching objects "Exchange2007Server" of type "Server" under the root "$null".

[10/20/2011 10:01:56 PM] [1] Previous operation run on domain controller 'exchange2003.domain'.

[10/20/2011 10:01:56 PM] [1] Previous operation run on domain controller 'exchange2003.domain'.

[10/20/2011 10:01:56 PM] [1] Preparing to output objects. Maximum result set size "unlimited".

[10/20/2011 10:01:56 PM] [1] Ending processing.

[10/20/2011 10:01:56 PM] [1] Beginning processing.

[10/20/2011 10:01:56 PM] [1] Administrator Active Directory session settings are: View Entire Forest: 'True', Configuration Domain Controller: 'exchange2003.domain', Preferred Global Catalog: 'exchange2003.domain', Preferred Domain Controllers: '{ exchange2003.domain }'

[10/20/2011 10:01:56 PM] [1] Searching objects of type "SmtpSendConnectorConfig" with filter "$null", scope "SubTree" under the root "Administrative Groups".

[10/20/2011 10:01:56 PM] [1] Previous operation run on domain controller 'exchange2003.domain'.

[10/20/2011 10:01:56 PM] [1] Preparing to output objects. Maximum result set size "unlimited".

[10/20/2011 10:01:56 PM] [1] Ending processing.

[10/20/2011 10:01:56 PM] [1] [WARNING] Setup cannot detect an SMTP or Send connector with an address space of '*'. Mail flow to the Internet may not work properly.

[10/20/2011 10:01:56 PM] [1] There was a problem accessing the registry on this computer. This may happen if the Remote Registry service is not running; it may also indicate a network problem.

[10/20/2011 10:01:56 PM] [1] Ending processing.

[10/20/2011 10:01:56 PM] [0] **************

[10/20/2011 10:01:56 PM] [0] Setup will run the task 'test-setuphealth'

[10/20/2011 10:01:56 PM] [1] Setup launched task 'test-setuphealth -DomainController 'exchange2003.domain' -DownloadConfigurationUpdates $false -ExchangeVersion '8.3.83.6' -Roles 'ClientAccess' -ScanType 'PrecheckUpgrade' -SetupRoles 'Bridgehead','ClientAccess','UnifiedMessaging','Mailbox','AdminTools' -TargetDir 'D:\Exchange2007Server' -IISInstalled $true'

[10/20/2011 10:01:56 PM] [1] Beginning processing.

[10/20/2011 10:01:59 PM] [1] Beginning processing.

[10/20/2011 10:01:59 PM] [1] Administrator Active Directory session settings are: View Entire Forest: 'True', Configuration Domain Controller: 'exchange2003.domain', Preferred Global Catalog: 'exchange2003.domain', Preferred Domain Controllers: '{ exchange2003.domain }'

[10/20/2011 10:01:59 PM] [1] Searching objects "Exchange2007Server" of type "Server" under the root "$null".

[10/20/2011 10:02:00 PM] [1] Previous operation run on domain controller 'exchange2003.domain'.

[10/20/2011 10:02:00 PM] [1] Previous operation run on domain controller 'exchange2003.domain'.

[10/20/2011 10:02:00 PM] [1] Preparing to output objects. Maximum result set size "unlimited".

[10/20/2011 10:02:00 PM] [1] Ending processing.

[10/20/2011 10:02:00 PM] [1] There was a problem accessing the registry on this computer. This may happen if the Remote Registry service is not running; it may also indicate a network problem.

[10/20/2011 10:02:00 PM] [1] Ending processing.

[10/20/2011 10:02:00 PM] [0] **************

[10/20/2011 10:02:00 PM] [0] Setup will run the task 'test-setuphealth'

[10/20/2011 10:02:00 PM] [1] Setup launched task 'test-setuphealth -DomainController 'exchange2003.domain' -DownloadConfigurationUpdates $false -ExchangeVersion '8.3.83.6' -Roles 'UnifiedMessaging' -ScanType 'PrecheckUpgrade' -SetupRoles 'Bridgehead','ClientAccess','UnifiedMessaging','Mailbox','AdminTools' -TargetDir 'D:\Exchange2007Server''

[10/20/2011 10:02:00 PM] [1] Beginning processing.

[10/20/2011 10:02:03 PM] [1] Beginning processing.

[10/20/2011 10:02:03 PM] [1] Administrator Active Directory session settings are: View Entire Forest: 'True', Configuration Domain Controller: 'exchange2003.domain', Preferred Global Catalog: 'exchange2003.domain', Preferred Domain Controllers: '{ exchange2003.domain }'

[10/20/2011 10:02:03 PM] [1] Searching objects "Exchange2007Server" of type "Server" under the root "$null".

[10/20/2011 10:02:03 PM] [1] Previous operation run on domain controller 'exchange2003.domain'.

[10/20/2011 10:02:03 PM] [1] Previous operation run on domain controller 'exchange2003.domain'.

[10/20/2011 10:02:03 PM] [1] Preparing to output objects. Maximum result set size "unlimited".

[10/20/2011 10:02:03 PM] [1] Ending processing.

[10/20/2011 10:02:03 PM] [1] Beginning processing.

[10/20/2011 10:02:03 PM] [1] Administrator Active Directory session settings are: View Entire Forest: 'True', Configuration Domain Controller: 'exchange2003.domain', Preferred Global Catalog: 'exchange2003.domain', Preferred Domain Controllers: '{ exchange2003.domain }'

[10/20/2011 10:02:03 PM] [1] Searching objects "Exchange2007Server" of type "Server" under the root "$null".

[10/20/2011 10:02:03 PM] [1] Previous operation run on domain controller 'exchange2003.domain'.

[10/20/2011 10:02:03 PM] [1] Previous operation run on domain controller 'exchange2003.domain'.

[10/20/2011 10:02:03 PM] [1] Preparing to output objects. Maximum result set size "unlimited".

[10/20/2011 10:02:03 PM] [1] Ending processing.

[10/20/2011 10:02:03 PM] [1] There was a problem accessing the registry on this computer. This may happen if the Remote Registry service is not running; it may also indicate a network problem.

[10/20/2011 10:02:03 PM] [1] Ending processing.

[10/20/2011 10:02:03 PM] [0] **************

[10/20/2011 10:02:03 PM] [0] Setup will run the task 'test-setuphealth'

[10/20/2011 10:02:03 PM] [1] Setup launched task 'test-setuphealth -DomainController 'exchange2003.domain' -DownloadConfigurationUpdates $false -ExchangeVersion '8.3.83.6' -Roles 'Mailbox' -ScanType 'PrecheckUpgrade' -SetupRoles 'Bridgehead','ClientAccess','UnifiedMessaging','Mailbox','AdminTools' -TargetDir 'D:\Exchange2007Server' -IISInstalled $true'

[10/20/2011 10:02:03 PM] [1] Beginning processing.

[10/20/2011 10:02:06 PM] [1] Beginning processing.

[10/20/2011 10:02:06 PM] [1] Ending processing.

[10/20/2011 10:02:07 PM] [1] Beginning processing.

[10/20/2011 10:02:07 PM] [1] Administrator Active Directory session settings are: View Entire Forest: 'True', Configuration Domain Controller: 'exchange2003.domain', Preferred Global Catalog: 'exchange2003.domain', Preferred Domain Controllers: '{ exchange2003.domain }'

[10/20/2011 10:02:07 PM] [1] Searching objects "Exchange2007Server" of type "Server" under the root "$null".

[10/20/2011 10:02:07 PM] [1] Previous operation run on domain controller 'exchange2003.domain'.

[10/20/2011 10:02:07 PM] [1] Previous operation run on domain controller 'exchange2003.domain'.

[10/20/2011 10:02:07 PM] [1] Preparing to output objects. Maximum result set size "unlimited".

[10/20/2011 10:02:07 PM] [1] Ending processing.

[10/20/2011 10:02:07 PM] [1] There was a problem accessing the registry on this computer. This may happen if the Remote Registry service is not running; it may also indicate a network problem.

[10/20/2011 10:02:07 PM] [1] Ending processing.


0
greatnfake
Asked:
greatnfake
  • 4
  • 2
1 Solution
 
Madan SharmaConsultantCommented:
Check to see if Windows File and Print sharing is installed on the NIC of the exchange server (I would make sure its on everywhere just to be certain) but I belive exchange requires this service running to install properly....

taken from http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_22856899.html
0
 
greatnfakeAuthor Commented:
It is
0
 
Madan SharmaConsultantCommented:
is your issue resolved ?
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
greatnfakeAuthor Commented:
No issue still remains no change.
0
 
greatnfakeAuthor Commented:
FYI: I found the solution to the problem by starting the "Computer Browser" service. Provided by the following link:
http://social.technet.microsoft.com/Forums/ar/exchangesvradmin/thread/6469264a-dc33-4b07-8a7c-e681a0f9248f
0
 
greatnfakeAuthor Commented:
The link provided describes the solution to installation of SP3 on exchange 2007.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now