[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 178
  • Last Modified:

Clicking on Excel 2010 file opens it in Excel 2007

I have Office 2010. The rial version of office 2007 came bundled with my laptop (Windows 7).

When I click on a excel file created in Excel 2010, it opens in Excel 2007 which I have nothing to do with. I have tried to right-click on the file and use open-with choice... but so far no success.

Please give me detailed information as to how I can make sure the files are opened in Excel 2010 not 2007.

Thank you.
0
Mike Eghtebas
Asked:
Mike Eghtebas
3 Solutions
 
Amit KhilnaneyCommented:
Why don't you uninstall trial version of office 2007. Keeping two version creates a problem.

Or is there is any specific reason to keep both of them?
0
 
andrewssd3Commented:
You obviously still have Office 2007 installed.  Go to control panel, programs and features, find Office 2007 and uninstall it.  That's from Windows 7, if you have Vista or XP, it's under Add and remove programs.
0
 
Mike EghtebasDatabase and Application DeveloperAuthor Commented:
I have:

Microsoft Office Home and Student 2007
Microsoft Office PowerPoint 2007 (English)
Compatibility Pack for 2007 Office system

Do I uninstall all three I have in the control panel?  I don't want to mess up something else.

Mike
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
sah18Commented:
Uninstalling your trial Office 2007 is one way to fix it.
Another option if you for some reason don't want to uninstall your Office 2007 trial, is to make sure that the program windows is set to open Excel files with is Excel 2010.  

You can do this in the following way:

Control Panel --> Programs --> Default Programs --> Associate a file type or protocol with a specific program

Scroll way down to the Xs and look for the Excel file extensions (there are more than one of these now in the 2007 and 2010 versions of Excel).  So, the primary ones I'd look for are:  .xls, .xlsx, .xlsm, .xlst

So, select one of the extensions you wish to change, say .xlsx & double-click it (or click the Change Program button).  Then click the Browse button and locate Excel.exe file for Excel 2010.  On my system it shows up here:
C:\Program Files (x86)\Microsoft Office\Office14\Excel.exe

Just do this for each of those extensions you wish to change to open in Excel 2010.

If you have any questions on this, just ask!
-sah18

ps:  As a work-around to this issue, you can always first open Excel 2010, then File, Open, and open the spreadsheet you wish to work on.  This will guarantee that your file will open in 2010.  Again, this isn't a fix, but may get you through until you have time to really solve it using one of the methods suggested!
0
 
sah18Commented:
Just saw your question above.  "Microsoft Office Home and Student 2007" is the one that contains Excel 2007.
0
 
Amit KhilnaneyCommented:
Yes uninstall all of them. There is no point in keeping old versions. On the safe side if you are using outlook 2007.

Take a backup of PST.
0
 
Amit KhilnaneyCommented:
sah18: I was trying to fix this issue by taking remote from my system (i.e. client side)

that issue was not resolved using file associations (The method you mentioned)

but files were opening when user open excel 2010 or word 2010 and then open file but not by double clicking, we tried everything but at last we uninstalled 2007 and then reinstall 2010
0
 
Amit KhilnaneyCommented:
eghtebas,

Please reinstall office 2010 after uninstalling office 2007.
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now