• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1655
  • Last Modified:

hp-ux configure email to use exchange server

experts,

how can i configure and test my hp-ux server to use smtp through an smtp server?

thanks in advance for the help.

0
telliot79
Asked:
telliot79
  • 6
  • 6
2 Solutions
 
xtermCommented:
vi /etc/mail/sendmail.cf  (may be just /etc/sendmail.cf on your system)

search for DS

# "Smart" relay host (may be null)
DS<ip-address to relay>

restart sendmail (ps -eaf | grep sendmail, and then kill -HUP the process ID returned by the first command)
0
 
telliot79Author Commented:
i'm recieving a 550 <email address>... Host unknown (Name server: <email server>: host not found)

i'm pretty sure the email server is configured correctly. Any ideas what this could be?
0
 
xtermCommented:
Please paste the lines that you modified in sendmail.cf, and what your steps to this point have been.

Are you currently using client software set to connect to the HP-UX box and send mail?

Can you paste what appears in /var/log/maillog (just the last few lines) when you attempt to relay?

0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
telliot79Author Commented:
my steps to this point:
-modify perms on sendmail.cf so i could write to it
-modify sendmail.cf inserting my smtp server ip address and commenting out other line
- trying to send an email to me using sendmail myemailaddress@me.com
test
.


lines i changed in sendmail.cf:

# "Smart" relay host (may be null)
DS111.11.111.11
#DS

I'm not using any client software

here's the mail message i' m recieving:

From MAILER-DAEMON@name Mon Oct 24 11:26:26 EST 2011
Received: from localhost (localhost)
        by name (8.9.3 (PHNE_35950)/8.9.3) with internal id LAA03488;
        Mon, 24 Oct 2011 11:26:26 -0500 (EST)
Date: Mon, 24 Oct 2011 11:26:26 -0500 (EST)
From: Mail Delivery Subsystem <MAILER-DAEMON@name>
Message-Id: <201110241626.LAA03488@name>
To: root@name
MIME-Version: 1.0
Content-Type: multipart/report; report-type=delivery-status;
        boundary="LAA03488.1319473586/name"
Subject: Returned mail: Host unknown (Name server: 111.11.111.11: host not found)
Auto-Submitted: auto-generated (failure)

This is a MIME-encapsulated message

--LAA03488.1319473586/name

The original message was received at Mon, 24 Oct 2011 11:26:21 -0500 (EST)
from root@localhost

   ----- The following addresses had permanent fatal errors -----
myemailaddress@me.com

   ----- Transcript of session follows -----
550 myemailaddress@me.com... Host unknown (Name server: 111.11.111.11
: host not found)

--LAA03488.1319473586/name
Content-Type: message/delivery-status

Reporting-MTA: dns; name
Arrival-Date: Mon, 24 Oct 2011 11:26:21 -0500 (EST)

Final-Recipient: RFC822; myemailaddress@me.com
Action: failed
Status: 5.1.2
Remote-MTA: DNS; 111.11.111.11
Last-Attempt-Date: Mon, 24 Oct 2011 11:26:26 -0500 (EST)

--LAA03488.1319473586/name
Content-Type: message/rfc822

Return-Path: <root>
Received: (from root@localhost)
        by name (8.9.3 (PHNE_35950)/8.9.3) id LAA03486
        for myemailaddress@me.com; Mon, 24 Oct 2011 11:26:21 -0500 (E
ST)
Date: Mon, 24 Oct 2011 11:26:21 -0500 (EST)
From: root
Message-Id: <201110241626.LAA03486@name>
MIME-Version: 1.0

test1





0
 
xtermCommented:
Okay, please try change 111.11.111.11 to the hostname of the smart host.  Be sure that you can ping that hostname by name from the HP server.  Then restart sendmail and try your relay again.
0
 
telliot79Author Commented:
how do i change 111.11.111.11 to the hostname of the smart host? i can already ping 111.11.111.11 from the hp-ux server.

0
 
xtermCommented:
For some reason your server appears to be trying to do a forward DNS lookup on 111.11.111.11 to change that to an IP, even though it is already an IP - I do not know if this is related to system resolver behavior on HPUX.  Thus, I'd like you to try it using the server's name instead of that IP address.  Does it not have a name like mailhost.somedomain.com?

What happens when you do an nslookup on 111.11.111.11?  Does that return a name that resolves properly back to that IP?
0
 
telliot79Author Commented:
ignore that last question, realise you're just asking me to name not IP address in my sendmail.cf file. i've managed to telnet to the email server and send an email from there if that helps?
0
 
xtermCommented:
Yes, that helps.  And yes, that's all I'm saying is to try putting the server's name in the DS line of sendmail.cf instead of the IP, and then restart sendmail, and see if that works?
0
 
telliot79Author Commented:
genius. FQDN worked. not sure why it wouldn't resolve the IP address, but i've got it working and that's good enough for me for now. Thanks fo your help and promprt replies, much appreciated.
0
 
telliot79Author Commented:
brilliant
0
 
xtermCommented:
Glad to hear it - my guess is something different with the way the resolver libs work on HP than they do on BSD derivatives like Linux (which happily accept an IP address) but who knows, just glad it worked for you.  Take care.
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

  • 6
  • 6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now