Silent install of Oracle 10g on Windows 7 returns error

Posted on 2011-10-21
Last Modified: 2013-12-18
I'm trying to setup an automated install of the Oracle 10g client for Windows 7.  I can install it interactively just fine, but when I try a silent install with a response file, I get four pop-ups, each with the associated event below.  If I click on OK for each pop-up, the install continues on and finishes, but I don't know if the install is good at this point.  

Has anyone ever found a way to do a silent install of Oracle 10g to a Windows 7 workstation?

Log Name:      System
Source:        Application Popup
Date:          9/12/2011 11:53:59 AM
Event ID:      26
Task Category: None
Level:         Information
Keywords:      Classic
User:          N/A
Application popup: java.exe - Entry Point Not Found : The procedure entry point GetProcessImageFileNameW could not be located in the dynamic link library PSAPI.DLL.
Question by:RhoSysAdmin
    LVL 30

    Accepted Solution

    LVL 16

    Expert Comment

    by:Swadhin Ray

    Author Comment

    So following the same advice referenced in three of the four links above works.  That is, using a standard response file and adding parameters for my install directory.  I have one issue left, specific to SCCM.  

    The Oracle installer is kicked off as a separate program, so my original batch file closes when the install has actually just gotten started.  Is there any way to get my batch file to stick around until the Oracle client install has completed?  I don't think I can make this work in a task sequence unless I can make sure the task completes before moving on to the next task.  I'm concerned the install will get interrupted before it finishes.

    Author Comment

    I guess I could use AutoIT and rig the install to not be 100% silent so there's a dialog box to clear at the end, but I was hoping to not introduce another layer into the install since the -response option does just what I need.


    Author Comment

    btw, I tried "start /w" in my batch file and my initial command prompt window still closes shortly after kicking off the installer.

    LVL 16

    Expert Comment

    by:Swadhin Ray
    AutoIT  ... not much handy with it but can be helpful on your scenario..

    Author Closing Comment

    Solved my initial problem, so now Oracle will install properly unattended.  Still cannot submit as part of a task sequence in SCCM, but that's another issue entirely now.

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    How your wiki can always stay up-to-date

    Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
    - Increase transparency
    - Onboard new hires faster
    - Access from mobile/offline

    Working with Network Access Control Lists in Oracle 11g (part 2) Part 1: Previously, I introduced the basics of network ACL's including how to create, delete and modify entries to allow and deny access.  For many…
    If you get continual lockouts after changing your Active Directory password, there are several possible reasons.  Two of the most common are using other devices to access your email and stored passwords in the credential manager of windows.
    This video explains what a user managed backup is and shows how to take one, providing a couple of simple example scripts.
    The viewer will learn how to successfully create a multiboot device using the SARDU utility on Windows 7. Start the SARDU utility: Change the image directory to wherever you store your ISOs, this will prevent you from having 2 copies of an ISO wit…

    794 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    16 Experts available now in Live!

    Get 1:1 Help Now