• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 671
  • Last Modified:

My Smtp Port is not allowing me to send emails out, but i can get emails in

I am using the thunderbird mail client, and i tried to access to send mail and the following message occurred all of a sudden, i have not changed any setting on the server, but i i cannot seem to figure out what to do. I am new to linux, so i would need some to explain to me what happen so i can resolve this issue. i received the following message when i try to send emails, i can receive email, not send any.


ERROR MESSAGE: An error occurred during a connection to mail.b1fam.com:25

SSL received a record that exceeded the maximum permissible length.

(Error code: ssl_error_rx_record_too_long)


I am using a Linux based Plesk 10 control panel, running on a centos 5 os. My control panel is also sending me this message as well, i am not sure if this is related to the error in the mail client:

 ################# SSL Certificate Warning ################

  Certificate for hostname 'Parallels Panel', in file:
     /usr/local/psa/var/certificates/certHTY7112

  The certificate needs to be renewed; this can be done
  using the 'genkey' program.

  Browsers will not be able to correctly connect to this
  web site using SSL until the certificate is renewed.

 ##########################################################

                                  Generated by certwatch(1)


i checked the ports on my wireless router, and all are assigned properly

smtp:25
pop3:110

I went in the panel and create a new self signing certificate, but it did not resolve this issue, so i made the original certificate the default once i saw the new one did not work. Please help. If any one can direct me in the right path that would be great.
0
dramous44
Asked:
dramous44
  • 3
  • 3
1 Solution
 
Dave BaldwinFixer of ProblemsCommented:
As I said before on your previous question, port 25 is not used for secure encrypted email.  Either switch it to standard unencrypted email or change the port to 465 or 587, whichever your ISP requires.
0
 
dramous44Author Commented:
I dont know how to switch to port 587 on the server, but i did switch the port on my router. tell me what i need to do thanks
0
 
Dave BaldwinFixer of ProblemsCommented:
No, you need to switch the port in Thunderbird.  Each connection in Thunderbird has to match the mail server it is connecting to.  Plain, unencrypted, email goes out on port 25.  Secure encrypted email usually goes out on port 465.  In any case, they have to match both the port and the method that the mail server is using.  Your email will not work until they match.  Find out what your mail server or ISP requires and set your Thunderbird connection to that.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
dramous44Author Commented:
thanks davebaldwin, are you familiar with plesk, i have that ssl warning coming in my email very day?
0
 
dramous44Author Commented:
How do i renew or update the certificate ?
0
 
Dave BaldwinFixer of ProblemsCommented:
I know what it does but I am not familiar with Plesk.  What does that have to do with Thunderbird?

Your email problem is really very simple.  Whether it is Thunderbird or email service on your web site, you have a mismatch between email settings.  You can't send secure email to port 25.

You may also have an expired SSL cert but I believe that is a different problem.  Web browsers use port 443 for secure web connections.  Do not try to change that.
0

Featured Post

[Webinar] Database Backup and Recovery

Does your company store data on premises, off site, in the cloud, or a combination of these? If you answered “yes”, you need a data backup recovery plan that fits each and every platform. Watch now as as Percona teaches us how to build agile data backup recovery plan.

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now